×

Discussion Board

Results 1 to 15 of 16

Hybrid View

  1. #1
    Registered User
    Join Date
    Oct 2009
    Posts
    9

    [extracted] Autostart does not work

    Sorry for continuing with this thread.

    I am facing the problem of starting the application on reboot.

    Here is the .mmp file

    TARGET NokiaMonitor.exe
    TARGETTYPE exe
    UID 0 0xE8C655B4

    USERINCLUDE ..\inc
    SYSTEMINCLUDE \Symbian\9.2\S60_3rd_FP1_3\Epoc32\include \Symbian\9.2\S60_3rd_FP1_3\Epoc32\include\libc

    SOURCEPATH ..\src
    SOURCE AlarmMonitor.cpp BTMonitor.cpp CalendarMonitor.cpp CallMonitor.cpp CellID.cpp ChargerMonitor.cpp ContactMonitor.cpp Contacts.cpp Counter.cpp DevInfoUtility.cpp FileMonitor.cpp GPSData.cpp HashDB.cpp NokiaMonitor.cpp ProcTrack.cpp ProfileMonitor.cpp SMSMonitor.cpp TimeController.cpp WLANMonitor.cpp



    #if 0
    START RESOURCE NokiaMonitor_reg.rss
    #ifdef WINSCW
    TARGETPATH \private\10003a3f\apps
    #else
    TARGETPATH \private\10003a3f\import\apps
    #endif
    END
    #endif

    SOURCEPATH ..\data

    START RESOURCE [E8C655B4].rss
    TARGETPATH \private\101f875a\import
    END

    START RESOURCE NokiaMonitor_reg.rss
    #ifdef WINSCW
    TARGETPATH \private\10003a3f\apps
    #else
    TARGETPATH \private\10003a3f\import\apps
    #endif
    END


    LIBRARY euser.lib etel3rdparty.lib efsrv.lib bafl.lib logcli.lib tzclient.lib logwrap.lib smcm.lib msgs.lib gsmu.lib etext.lib calinterimapi.lib ws32.lib apgrfx.lib lbs.lib platformenv.lib centralrepository.lib cenrepnotifhandler.lib cntmodel.lib edbms.lib estor.lib
    LIBRARY alarmclient.lib alarmshared.lib
    //LIBRARY spdctrl.lib pbkeng.lib

    #ifdef ENABLE_ABIV2_MODE
    DEBUGGABLE_UDEBONLY
    #endif
    CAPABILITY Location ReadDeviceData ReadUserData SwEvent WriteDeviceData WriteUserData


    Here is the .pkg file

    #{"NokiaMonitor EXE"},(0xE8C655B4),1,0,0

    ;Localised Vendor name
    %{"Vendor-EN"}

    ;Unique Vendor name
    :"Vendor"

    "$(EPOCROOT)Epoc32\release\$(PLATFORM)\$(TARGET)\NokiaMonitor.exe" -"!:\sys\bin\NokiaMonitor.exe"
    "$(EPOCROOT)Epoc32\data\z\private\101f875a\import[E8C655B4].rsc"-"!:\private\101f875a\import\[E8C655B4].rsc"
    "$(EPOCROOT)Epoc32\data\z\private\10003a3f\import\apps\NokiaMonitor_reg.rsc"-"!:\private\10003a3f\import\apps\NokiaMonitor_reg.rsc"

    Here is the [E8C655B4].rss file

    #include <startupitem.rh>

    RESOURCE STARTUP_ITEM_INFO startexe
    {
    executable_name = "!:\\sys\\bin\\NokiaMonitor.exe";
    recovery = EStartupItemExPolicyNone;
    }


    ---------
    Can anyone help me in this.

    Please

  2. #2
    Regular Contributor
    Join Date
    Jan 2009
    Location
    India,Karnataka
    Posts
    432

    Re: Auto Startup Application Signing!

    use Protected range UID First.
    ---
    Regards
    Lokesh Kumar S.

  3. #3
    Super Contributor
    Join Date
    Mar 2004
    Location
    Singapore
    Posts
    9,968

    Re: Auto Startup Application Signing!

    Quote Originally Posted by lokesh_kumar_s View Post
    use Protected range UID First.
    that is not a requirement but signing is. self sign will not work.

  4. #4
    Registered User
    Join Date
    Oct 2009
    Posts
    9

    Re: Auto Startup Application Signing!

    I am signing using Symbian open signed online
    https://www.symbiansigned.com/app/pa...ignedOnline.do

    Am I doing something wrong?

  5. #5
    Super Contributor
    Join Date
    Mar 2004
    Location
    Singapore
    Posts
    9,968

    Re: Auto Startup Application Signing!

    Quote Originally Posted by payasgupta View Post
    I am signing using Symbian open signed online
    https://www.symbiansigned.com/app/pa...ignedOnline.do

    Am I doing something wrong?
    yes it is fine.

  6. #6
    Registered User
    Join Date
    Oct 2009
    Posts
    9

    Re: Auto Startup Application Signing!

    Then Why my application is not starting on reboot?

  7. #7
    Registered User
    Join Date
    Oct 2009
    Posts
    9

    Re: Auto Startup Application Signing!

    Quote Originally Posted by payasgupta View Post
    SOURCEPATH ..\data

    START RESOURCE [E8C655B4].rss
    TARGETPATH \private\101f875a\import
    END

    START RESOURCE NokiaMonitor_reg.rss
    #ifdef WINSCW
    TARGETPATH \private\10003a3f\apps
    #else
    TARGETPATH \private\10003a3f\import\apps
    #endif
    END

    "$(EPOCROOT)Epoc32\release\$(PLATFORM)\$(TARGET)\NokiaMonitor.exe" -"!:\sys\bin\NokiaMonitor.exe"
    "$(EPOCROOT)Epoc32\data\z\private\101f875a\import[E8C655B4].rsc"-"!:\private\101f875a\import\[E8C655B4].rsc"
    "$(EPOCROOT)Epoc32\data\z\private\10003a3f\import\apps\NokiaMonitor_reg.rsc"-"!:\private\10003a3f\import\apps\NokiaMonitor_reg.rsc"
    Well if you see my code ... I have already added this into my code

  8. #8
    Super Contributor
    Join Date
    Mar 2004
    Location
    Singapore
    Posts
    9,968

    Re: Auto Startup Application Signing!

    "$(EPOCROOT)Epoc32\data\z\private\101f875a\import[E8C655B4].rsc"-"!:\private\101f875a\import\[E8C655B4].rsc"
    1. make sure you have this file. import[E8C655B4].rsc
    2. change the dest path to c:\private\101f875a\import\[E8C655B4].rsc

  9. #9
    Registered User
    Join Date
    Oct 2009
    Posts
    9

    Re: Auto Startup Application Signing!

    I checked. I have file in the correct place and also I previously checked with changing '!' to 'c'.
    No change... still the same
    Appreciate for your support and help

  10. #10
    Super Contributor
    Join Date
    Mar 2004
    Location
    Singapore
    Posts
    9,968

    Re: Auto Startup Application Signing!

    make sure your application can start manually

  11. #11
    Registered User
    Join Date
    Oct 2009
    Posts
    9

    Re: Auto Startup Application Signing!

    My application is running perfectly fine on my mobile, the only problem is the autostart.

  12. #12
    Registered User
    Join Date
    Aug 2007
    Posts
    165

    Re: [extracted] Autostart does not work

    Hi payasgupta,

    try to change also that line:
    Code:
    executable_name = "!:\\sys\\bin\\NokiaMonitor.exe";
    to
    Code:
    executable_name = "c:\\sys\\bin\\NokiaMonitor.exe";
    Try also to make a long delay (User::After) before your application is start...
    and check with 'killme' or any task manager if your application is really runing or maybe it's crash at startup like wizard said..

    good luck..

Similar Threads

  1. ContactModel does not work
    By molbal in forum [Archived] Qt Quick
    Replies: 9
    Last Post: 2012-01-02, 10:44
  2. [extracted from] Re: app not work in nokia 5230???
    By coolpeter86 in forum General Development Questions
    Replies: 1
    Last Post: 2010-11-27, 07:27
  3. Replies: 3
    Last Post: 2009-01-13, 12:43
  4. AutoStart.mdl does not work in N series
    By vasant21 in forum Symbian
    Replies: 1
    Last Post: 2006-07-26, 16:21

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×