×

Discussion Board

Results 1 to 2 of 2
  1. #1
    Registered User
    Join Date
    Mar 2003
    Posts
    3

    Unhappy Help!!!!New Development (OpenSigned) Cert does NOT work for S60 3rd Edition Phones!!!

    Hi All,

    After the migration to new SymbianSigned.com, I have verified my account and successfully downloaded the development certificate. After unzipping, I got one .key file and one .cer file. I then use signsis.exe to sign my SIS file. After that, I tried to install it on my S60 3rd Edition phones (one E63 and one 6120). During the installation, both phones gave me this error: "Constrained by certificate". I have double checked and confirmed both phones have the correct date and time settings.

    In the meanwhile, I used my previous old OpenSigned cert to sign the same SIS file and installed on the same phones successfully.

    I also tried the new cert on S60 5th edition phones and it installed fine.

    There must be something wrong with the new development cert that causes the problem on S60 3rd edition phones. I used "signsis -p" to see the content of the cert, and found the difference between the new cert and the old OpenSigned cert is that the new cert has one addition "X509 extension" item:

    Old Cert:
    Code:
            X509v3 extensions:
                1.2.826.0.1.1796587.1.1.1.1: critical
                    0.....[IMEIs are removed]
                1.2.826.0.1.1796587.1.1.1.6: critical
                    ...}.......
    New Cert:
    Code:
            X509v3 extensions:
                1.2.826.0.1.1796587.1.1.1.6: critical
                    ...}.......
                1.2.826.0.1.1796587.1.1.1.1: critical
                    0.....[IMEIs are removed]
                1.2.826.0.1.1796587.1.1.1.4: critical
                    0..H.. ..g.. ..h.. ..l.. ..... ..1.. .6... .@... .Ji.. .K... .aN.. .... .Y.
    Besides that, the "Serieal No" of both certs are also different:

    Old Cert:
    Code:
            Serial Number:
                ae:a4:f3:d0:8d:d7:ec:2d:cd:8a:8a:3a:bb:37:6b:66:a3:0f:6d:b9:ca:53:c4:f1:da:96:14:de:51:0a:6d:be:e2:35:65:9a:58:c0:0b:f1:56:41:b6:98:ba:b9:b8:51:a1:4c:fb:68:7c:fd:41:7f:6e:35:1a:44:91:87:5b:8f:0a:b9:0c:0f:b4:a2:67:cf:4f:43:59:32:dd:cd:40:d0:45:83:cf:a1:a9:a5:a2:28:67:db:f9:96:f8:5f:05:32:49:f4:dd:06:99:ac:9d:bb:05:80:bc:d1:f7:9d:af:a3:e7:64:c7:a4:79:c5:36:32:0a:71:57:8f:90:35:56:5f
    New Cert:
    Code:
            Serial Number:
                01:30:b6:a2:7a:07:94:2c
    Can someone from SymbianSigned team give an quick answer to these problems asap? We need to provide the application for our testing team to test but we can't, due to this problem. And this is delaying our very tight schedule.

    Thanks!!!!!

    - Lei

  2. #2
    Registered User
    Join Date
    Mar 2003
    Location
    Germany
    Posts
    200

    Re: Help!!!!New Development (OpenSigned) Cert does NOT work for S60 3rd Edition Phone

    Looking at the new extension in one of my certificates, it seems that it contains a list of all our UIDs - I suspect that the new DevCerts are actually somewhat more restrictive than the old ones, and verify the UID of your application (not exactly sure which one - package, UID3 of executables?) at install time, to make sure that you cannot use them to sign someone else's package.

    Could it be that there are some binaries in your package with a UID not listed in your account?

Similar Threads

  1. Emulator of S60 3rd Edition FP2 SDK does not work?
    By patrick_307 in forum Mobile Java Tools & SDKs
    Replies: 8
    Last Post: 2008-12-07, 16:17
  2. Carbide.c++ 1.3 does not create SIS-file for S60 3rd edition SDK
    By lovemydoog in forum Symbian Tools & SDKs
    Replies: 1
    Last Post: 2008-06-12, 09:54
  3. S60 2nd OR 3rd edition for new software development
    By patil_ruturaj in forum Symbian Tools & SDKs
    Replies: 1
    Last Post: 2006-06-30, 09:30
  4. S60 2nd OR 3rd edition for new software development
    By patil_ruturaj in forum Mobile Java Tools & SDKs
    Replies: 3
    Last Post: 2006-06-30, 08:57
  5. Why Int64 not work for S60 3rd Edition ?
    By comb in forum Symbian C++
    Replies: 2
    Last Post: 2006-06-25, 21:02

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •