×

Discussion Board

Results 1 to 7 of 7

Hybrid View

  1. #1
    Registered User
    Join Date
    Jun 2011
    Posts
    6

    Problems with Qt Mobility

    Hi
    I'm a beginner at Qt Quick. i have the qt sdk 1.1 beta version and i'm unable to access the Qt Mobility plugins for qml. It gives me the following error
    module "QtMobility.messaging" is not installed
    for the line
    import QtMobility.messaging 1.1
    This is happening even though i included the lines
    CONFIG += mobility
    MOBILITY = messaging
    i even updated the whole thing but it's still not working
    Please help! Thanks in advance!

  2. #2
    Registered User
    Join Date
    Jun 2011
    Posts
    6

    Problems with Qt Mobility

    Hi
    I'm a beginner at Qt Quick and i'm having some problems with Qt Mobility APIs
    it gives me the following error
    module "QtMobility.messaging" is not installed
    for the line
    import QtMobility.messaging 1.1
    i'm using the qt sdk beta 1.1 and i just updated the whole thing
    i even included the lines
    CONFIG += mobility
    MOBILITY = messaging
    in the .pro file
    Please help!

  3. #3
    Super Contributor
    Join Date
    Oct 2008
    Location
    INDIA
    Posts
    2,326

    Re: Problems with Qt Mobility

    Your answer is given here , do not create double copy : General discussion

    Best regards,

  4. #4
    Super Contributor
    Join Date
    Oct 2008
    Location
    INDIA
    Posts
    2,326

    Re: Problems with Qt Mobility

    Where is Qmessage file in your system ?

    Whether <QMessage> is included in your project ?

    Qt mobility is not currently configured, may be.

    Try below changes,

    CONFIG += mobility
    MOBILITY += messaging

    Ask Qt related question in Qt Forum,
    Best regards,

  5. #5
    Registered User
    Join Date
    Jun 2011
    Posts
    2

    Re: Problems with Qt Mobility

    I have the same problem.

    I even added this statement in main.cpp
    #include <QMessage>

    Still it gives me error for import statement in qml file

    Please help.

  6. #6
    Registered User
    Join Date
    Apr 2008
    Location
    Budapest, Hungary
    Posts
    56

    Re: Problems with Qt Mobility

    I have added the lines before but I still get the not installed error

  7. #7
    Registered User
    Join Date
    Dec 2010
    Posts
    10

    Re: Problems with Qt Mobility

    the problem is with the MingW compilter. messaging API is not compatible with the same as given in the Qt documentation

Similar Threads

  1. Nokia Qt SDK and Qt Mobility - Installation Problems
    By napstar in forum [Archived] Qt SDKs and Tools
    Replies: 8
    Last Post: 2011-06-07, 13:40
  2. Qt Mobility 1.1 organizer API problems on N900
    By blakharaz in forum [Archived] Qt Mobility Project
    Replies: 5
    Last Post: 2010-11-12, 03:18
  3. Replies: 4
    Last Post: 2010-11-04, 20:40
  4. Video playback with Qt 4.7 and Qt Mobility 1.1.0 on Symbian^3
    By santama in forum [Archived] Qt Mobility Project
    Replies: 0
    Last Post: 2010-10-25, 14:05
  5. error installing qt-mobility with qt 4.7 on Windows 7
    By kaycee1 in forum [Archived] Qt SDKs and Tools
    Replies: 0
    Last Post: 2010-09-24, 02:18

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×