×

Discussion Board

Results 1 to 8 of 8
  1. #1
    Nokia Developer Champion
    Join Date
    Aug 2008
    Location
    Vadodara, India.
    Posts
    911

    Error when i run my Qt Project for Meego on Qt SDK 1.1.2

    When i created Qt Quick project -> Harmattan Application for Harmattan(Meego) i got below error on Run.

    :-1: error: Deployment failed: Qemu was not running. It has now been started up for you, but it will take a bit of time until it is ready.

    Anybody have any idea how i can fix this?
    Nokia Developer Wiki Moderation team
    World's Greatest Speeches for Windows Phone is now available on WP Marketplace.

  2. #2
    Super Contributor
    Join Date
    Oct 2009
    Posts
    4,326

    Re: Error when i run my Qt Project for Meego on Qt SDK 1.1.2

    And was Qemu emulator running?

  3. #3
    Nokia Developer Champion
    Join Date
    Aug 2008
    Location
    Vadodara, India.
    Posts
    911

    Re: Error when i run my Qt Project for Meego on Qt SDK 1.1.2

    Quote Originally Posted by divanov View Post
    And was Qemu emulator running?
    nope. its still showing same error. its not started yet. any idea. How i can fix this??
    Nokia Developer Wiki Moderation team
    World's Greatest Speeches for Windows Phone is now available on WP Marketplace.

  4. #4
    Nokia Developer Champion
    Join Date
    Aug 2008
    Location
    Vadodara, India.
    Posts
    911

    Re: Error when i run my Qt Project for Meego on Qt SDK 1.1.2

    Quote Originally Posted by divanov View Post
    And was Qemu emulator running?
    Well Its Started finally when i changed the Harmattan Build type to "Meego 1.2 harmattan API - Debug" from only "Harmattan API - Debug".

    Now i can see Application view of N9 in emulator.

    Cheers .
    Chintan.
    Nokia Developer Wiki Moderation team
    World's Greatest Speeches for Windows Phone is now available on WP Marketplace.

  5. #5
    Registered User
    Join Date
    Jul 2011
    Posts
    69

    Re: Error when i run my Qt Project for Meego on Qt SDK 1.1.2

    Quote Originally Posted by chintandave_er View Post
    Well Its Started finally when i changed the Harmattan Build type to "Meego 1.2 harmattan API - Debug" from only "Harmattan API - Debug".
    Chintan.
    Thanks for the tip. Now it works for me as well.

    Now I would also have to figure out, how to stop my app again. There seems to be no x for closing :|

    BTW: QEMU seems to be very slow, even I have a far fast enough CPU. Is there any way to improve that?

  6. #6
    Super Contributor
    Join Date
    Apr 2003
    Location
    USA, CA
    Posts
    7,191

    Re: Error when i run my Qt Project for Meego on Qt SDK 1.1.2

    You "close" the apps with a swipe
    https://www.developer.nokia.com/swip...The_Swipe.html

    (to be exact, you return to home with a swipe and you can close the application in the Open applications view of the home https://www.developer.nokia.com/swip...ages/Home.html)

    Hartti

  7. #7
    Registered User
    Join Date
    Jul 2011
    Posts
    69

    Re: Error when i run my Qt Project for Meego on Qt SDK 1.1.2

    Thank you very much for your explanations!
    Reading the links you showed help a lot.

    (I tried to swipe it, how ever only from a side, not from a corner.)
    I am sure I would have figured out quickly on a real device but with a mouse in QEMU I am not used to do such gestures
    Same for a long push for closing

  8. #8
    Super Contributor
    Join Date
    Apr 2003
    Location
    USA, CA
    Posts
    7,191

    Re: Error when i run my Qt Project for Meego on Qt SDK 1.1.2

    If you use the N950s through the Remote Device Access, there is a button next to the keyboard to go back to home.
    https://www.developer.nokia.com/Devi...device_access/

    Hartti

Similar Threads

  1. Replies: 1
    Last Post: 2011-03-06, 21:28
  2. How to: MeeGo apps on Nokia Qt SDK
    By pedro_242 in forum Nokia N9
    Replies: 1
    Last Post: 2010-08-23, 10:04
  3. Qt Nokia SDK Installer Sefault on Meego Netbook
    By tcostigl in forum [Archived] Qt SDKs and Tools
    Replies: 1
    Last Post: 2010-07-18, 18:59
  4. Trying to run Qt project on N900 via MAD developer: getting Packaging error
    By titanic2 in forum [Archived] Qt SDKs and Tools
    Replies: 1
    Last Post: 2010-07-08, 10:18
  5. My first Project on Qt Nokia SDK!! :D
    By Nanokun in forum [Archived] Qt Mobility Project
    Replies: 3
    Last Post: 2010-07-01, 15:58

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×