×

Discussion Board

Results 1 to 7 of 7
  1. #1
    Registered User
    Join Date
    Aug 2010
    Posts
    21

    hi, problem with UID

    hi

    i read "http://www.developer.nokia.com/Community/Blogs/blog/ovi-publisher-alert/2010/08/02/qt-content-qa"

    Do first qmake && make release-gcce

    after make sis qt_sis_certificate = developer.crt qt_sis_key = developer.key
    (i have own developer certificate and key)

    and have follow

    d:\qt\app\ColorIt>make sis qt_sis_certificate = developer.crt qt_sis_key = devel
    oper.key
    make: *** empty variable name. Stop.

    d:\qt\app\ColorIt>make sis qt_sis_certificate=developer.crt qt_sis_key=developer
    .key
    make -f Makefile ok_sis MAKEFILES=.make.cache
    make[1]: Entering directory `d:/qt/app/ColorIt'
    createpackage -g ColorIt_template.pkg RELEASE-armv5
    Auto-patching self-signed package.

    Patching package file and relevant binaries...
    Patching: UID 0x200***E3 is not compatible with self-signing!
    Patching: Package UID changed to: 0xE0035CE3.

    Patching: Executable with SID in the protected range (0x200***e3) detected: "Col
    orIt_patched_caps.exe". A self-signed sis with protected executables is not supp
    orted.


    Patching: Unable to patch the package for self-singing.
    Use a proper developer certificate for signing this package.

    ERROR: Automatic patching failed at D:\QtSDK\Symbian\SDKs\Symbian3Qt473\bin\crea
    tepackage.pl line 357.
    make[1]: *** [ok_sis] Error 2
    make[1]: Leaving directory `d:/qt/app/ColorIt'
    make: *** [sis] Error 2


    Can you explain me this error?

    Problem

    Patching: UID 0x200***E3 is not compatible with self-signing!
    Patching: Package UID changed to: 0xE0035CE3.


    My uid don't work?

    thanks

  2. #2
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Budapest, Hungary
    Posts
    28,572

    Re: hi, problem with UID

    It is more of a problem with the tool
    Auto-patching self-signed package
    apparently it wants to self-sign the package for some reason. You may want to check the Qt-boards, they have probably seen such messages, and know the fix/settings for getting rid of this feature.

  3. #3
    Registered User
    Join Date
    Aug 2010
    Posts
    21

    Re: hi, problem with UID

    I wrote to publishtoovi.support@nokia.com
    think my uid is off...
    I will wait their answer
    I don't know reason and how fix for rid of this (self-sign the package) feature.

  4. #4
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Budapest, Hungary
    Posts
    28,572

    Re: hi, problem with UID

    They must be happy now, since this problem has nothing to do with Ovi and its support.
    I will try to get this thread moved to the Qt boards.

  5. #5
    Registered User
    Join Date
    Aug 2010
    Posts
    21

    Re: hi, problem with UID

    Quote Originally Posted by wizard_hu_ View Post
    They must be happy now, since this problem has nothing to do with Ovi and its support.
    I will try to get this thread moved to the Qt boards.
    thanks - give me url of Qt boards.
    What can i do now? May be reinstall qtsdk?

  6. #6
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Budapest, Hungary
    Posts
    28,572

    Re: hi, problem with UID

    You already have some posts in the Qt boards, but here is the link: http://www.developer.nokia.com/Commu...lay.php?219-Qt - I would suggest the Tools board.
    I do not think that reinstall is necessary, probably some setting is missing only.

  7. #7
    Registered User
    Join Date
    Aug 2010
    Posts
    21

    Re: hi, problem with UID

    if i do make sis without my certificate and key - it's work, but I need use own certificate and key(

Similar Threads

  1. Hi im new *with a small problem lol*
    By Andyvalver in forum General Development Questions
    Replies: 3
    Last Post: 2006-07-04, 20:05
  2. Hi im new *with a small problem lol*
    By Andyvalver in forum Mobile Java General
    Replies: 2
    Last Post: 2006-07-03, 21:13
  3. Problem with UID
    By hariprasadth in forum Symbian Tools & SDKs
    Replies: 1
    Last Post: 2006-01-06, 02:53
  4. hi i got some problem with my 9210i
    By mimi83 in forum General Development Questions
    Replies: 1
    Last Post: 2004-01-01, 12:04

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •