×

Discussion Board

Results 1 to 13 of 13
  1. #1
    Registered User
    Join Date
    Mar 2009
    Posts
    8

    Cool Problem SSH'ing into N950?

    I have problem SSH'ing into the N950, any ideas? No problem into N900. I can SSH "root@localhost" on the N950 itself, but trying from external machine to SSH, I get the password prompt, I type in the password (yes, properly), and it just re-displays the password prompt with no further comment, ad infinitum.

    Anyone know what gives?

    /Z

  2. #2
    Super Contributor
    Join Date
    Oct 2009
    Posts
    4,326

    Re: Problem SSH'ing into N950?

    It sounds like you are trying to login with wrong password or to wrong host (or both in extreme case).

  3. #3
    Registered User
    Join Date
    Mar 2009
    Posts
    8

    Re: Problem SSH'ing into N950?

    Eh... no. I said so already

    If I am on the N950, I can do

    ssh root@localhost

    or

    But if I am on an other device (even my good old N900) and I try to

    ssh root@[ip-of-n950]

    ....I get the failure. And yes, it's the right IP, and yes, it is the right password. I'm not completely dumb

    /Z

  4. #4
    Super Contributor
    Join Date
    Oct 2009
    Posts
    4,326

    Re: Problem SSH'ing into N950?

    Try ssh -v

  5. #5
    Registered User
    Join Date
    Mar 2009
    Posts
    8

    Re: Problem SSH'ing into N950?

    OpenSSH_5.1p1 Debian-6.maemo5, OpenSSL 0.9.8n 24 Mar 2010
    debug1: Reading configuration data /etc/ssh/ssh_config
    debug1: Applying options for *
    debug1: Connecting to 20.100.100.130 [20.100.100.130] port 22.
    debug1: Connection established.
    debug1: permanently_set_uid: 0/0
    debug1: identity file /root/.ssh/identity type -1
    debug1: identity file /root/.ssh/id_rsa type -1
    debug1: identity file /root/.ssh/id_dsa type -1
    debug1: Remote protocol version 2.0, remote software version OpenSSH_5.1p1 Debian-2+harmattan28+0m6
    debug1: match: OpenSSH_5.1p1 Debian-2+harmattan28+0m6 pat OpenSSH*
    debug1: Enabling compatibility mode for protocol 2.0
    debug1: Local version string SSH-2.0-OpenSSH_5.1p1 Debian-6.maemo5
    debug1: SSH2_MSG_KEXINIT sent
    debug1: SSH2_MSG_KEXINIT received
    debug1: kex: server->client aes128-cbc hmac-md5 none
    debug1: kex: client->server aes128-cbc hmac-md5 none
    debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
    debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
    debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
    debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
    debug1: Host '20.100.100.130' is known and matches the RSA host key.
    debug1: Found key in /root/.ssh/known_hosts:4
    debug1: ssh_rsa_verify: signature correct
    debug1: SSH2_MSG_NEWKEYS sent
    debug1: expecting SSH2_MSG_NEWKEYS
    debug1: SSH2_MSG_NEWKEYS received
    debug1: SSH2_MSG_SERVICE_REQUEST sent
    debug1: SSH2_MSG_SERVICE_ACCEPT received
    debug1: Authentications that can continue: publickey,password
    debug1: Next authentication method: publickey
    debug1: Trying private key: /root/.ssh/identity
    debug1: Trying private key: /root/.ssh/id_rsa
    debug1: Trying private key: /root/.ssh/id_dsa
    debug1: Next authentication method: password
    root@20.100.100.130's password:
    debug1: Authentications that can continue: publickey,password
    Permission denied, please try again.
    root@20.100.100.130's password:

  6. #6
    Registered User
    Join Date
    Nov 2007
    Location
    Finland
    Posts
    26

    Re: Problem SSH'ing into N950?

    Is developer mode on? Is the SDK Connection (the app in the grid) selected to be USB or WLAN? If yes to both, then I don't have a clue... Works for me...

  7. #7
    Registered User
    Join Date
    Mar 2009
    Posts
    8

    Re: Problem SSH'ing into N950?

    Quote Originally Posted by kypeli View Post
    Is developer mode on? Is the SDK Connection (the app in the grid) selected to be USB or WLAN? If yes to both, then I don't have a clue... Works for me...
    Huh, what is the "SDK connection" and what does it have to do with SSH'ing into the device?

    But okay, I tried, not sure how I turn that "on", but it gave me a (different) password (not the one I set on my root account), but it doesn't help and I can't log in with that either.

    You didn't do any trickery with SSH keys or other things? It seems to want a public/private key pair... but the way I understand it a password sohuld also work?

    /Z

  8. #8
    Registered User
    Join Date
    Nov 2007
    Location
    Finland
    Posts
    26

    Re: Problem SSH'ing into N950?

    Quote Originally Posted by MasterZap View Post
    Huh, what is the "SDK connection" and what does it have to do with SSH'ing into the device?
    I don't know what it actually does - maybe nothing, but at least it will show you the WLAN IP address so you can SSH over WiFi

    Quote Originally Posted by MasterZap View Post
    But okay, I tried, not sure how I turn that "on", but it gave me a (different) password (not the one I set on my root account), but it doesn't help and I can't log in with that either.

    You didn't do any trickery with SSH keys or other things? It seems to want a public/private key pair... but the way I understand it a password sohuld also work?
    So which username + password combo are you using? root / rootme is the root login credentials that work for me. From there you can do "su - user" to become a normal user. Qt Creator will use the "developer" account to install the packages from Qt Creator on to the device, but I always SSH in as root.

  9. #9
    Registered User
    Join Date
    Mar 2009
    Posts
    8

    Re: Problem SSH'ing into N950?

    Quote Originally Posted by kypeli View Post
    I don't know what it actually does - maybe nothing, but at least it will show you the WLAN IP address so you can SSH over WiFi
    The IP I know already.

    Quote Originally Posted by kypeli View Post
    So which username + password combo are you using? root / rootme is the root login credentials that work for me. From there you can do "su - user" to become a normal user. Qt Creator will use the "developer" account to install the packages from Qt Creator on to the device, but I always SSH in as root.
    Done all that, and I'm using "root / rootme" altohugh I changed the password on the device from "rootme" to something else, so I am using that other thing, not actually "rootme", but yeah, the root pwd of the device, user name root. Keep getting it.

    Maybe I should just reset the device from scratch and try again.....

    Sigh, I'm a bit depressed I really wanted to play around with this thing, but it seems stupid trivial obstacles are in my way for some reason.

    /Z
    Last edited by divanov; 2011-07-13 at 08:17. Reason: Removing unrelated information

  10. #10
    Super Contributor
    Join Date
    Oct 2009
    Posts
    4,326

    Re: Problem SSH'ing into N950?

    Create another account on the device and try to login with its credentials
    http://linux.die.net/man/8/useradd

  11. #11
    Super Contributor
    Join Date
    Apr 2003
    Location
    USA, CA
    Posts
    7,191

    Re: Problem SSH'ing into N950?

    And you followed the instructions in here http://library.developer.nokia.com/t...ttan_85c9.html ?

    Hartti

  12. #12
    Registered User
    Join Date
    Mar 2009
    Posts
    8

    Re: Problem SSH'ing into N950?

    SOLVED IT: A fellow Linux guru told me to look in /etc/ssh/sshd_config and lo and behold, there is limiting to the SSH to certain networks, and yes, I use a very peculiar IP range in my house, NOT one of the ones listed as "okay" in the config file... solved!!

    To explain, the N950 is set up to only enjoy SSH:ing into it when it's in one of the "private" ip range of e.g. 10.*.*.* or 192.168.*.* for example; I use neither, so it broke.

    /Z

  13. #13
    Super Contributor
    Join Date
    Apr 2003
    Location
    USA, CA
    Posts
    7,191

    Re: Problem SSH'ing into N950?

    Thanks for the tip!

    Hartti

Similar Threads

  1. N950 avaialbility?
    By shmerl in forum Feedback - Nokia Developer Services & Infrastructure
    Replies: 66
    Last Post: 2011-11-21, 06:27
  2. NOKIA N950
    By developer 123 in forum News and Announcements
    Replies: 23
    Last Post: 2011-07-25, 12:42
  3. MeeGo N950 Errors
    By v-6 in forum Nokia N9
    Replies: 3
    Last Post: 2011-07-03, 09:54
  4. N950 Getting Started
    By v-6 in forum Nokia N9
    Replies: 15
    Last Post: 2011-06-29, 09:23

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×