×

Discussion Board

Results 1 to 8 of 8
  1. #1
    Registered User
    Join Date
    Jun 2011
    Posts
    1

    Problem with loading

    While the interface of Index page has not been loaded completely, the User click on some buttons and then the app runs into the state of suspended forever. My idea for fixing this problem is that I will hide the background and show progressing indicator until the whole Interface completely loaded...But I don't know how to catch the event when all stuffs have been loaded completely. Could you please show me the way to solve it?

  2. #2
    Registered User
    Join Date
    May 2012
    Posts
    5

    Re: Problem with loading

    Please help us with this problem. We need to show custom loading image, is it possible?

  3. #3
    Nokia Developer Moderator
    Join Date
    Jun 2008
    Location
    Tampere
    Posts
    833

    Re: Problem with loading

    Hi and welcome to forum!

    Do you mean a custom loading image instead of the Nokia one, or splash screen that is shown when web app is loaded?

    Br,
    Ilkka

  4. #4
    Registered User
    Join Date
    May 2012
    Posts
    5

    Re: Problem with loading

    I want to replace Nokia loading image at top-right side to a custom loading image.

  5. #5
    Nokia Developer Moderator
    Join Date
    Jun 2008
    Location
    Tampere
    Posts
    833

    Re: Problem with loading

    OK now I understand. I'm sorry to say, but that is platform functionality and cannot be customized.
    I'll forward this request to RnD. Any additional feedback is welcome as well.

    Br,
    Ilkka

  6. #6
    Registered User
    Join Date
    May 2012
    Posts
    5

    Re: Problem with loading

    Is it possible to apply custom loading image for example full screen transparent PNG?
    if native loading image appear, show transparent PNG, does SDK allow it?

  7. #7
    Registered User
    Join Date
    May 2012
    Posts
    5

    Re: Problem with loading

    My application contains few drop box, if I select first drop box application make request to server and page starts loading but nokia loading image is too small and also allow user to click on page's objects while application makes request to server. So how can I prevent user to click on page's objects while page is loading?
    Last edited by Elgiz; 2012-05-10 at 04:49.

  8. #8
    Nokia Developer Moderator
    Join Date
    Jun 2008
    Location
    Tampere
    Posts
    833

    Re: Problem with loading

    Hi,

    Native loading indicator cannot be replaced, because no events are being fired, when it will be shown. However you can show your own .gif loading indicator when initiating e.g. XMLHttpRequest. For example Qype example uses this method. https://projects.developer.nokia.com/PlacesS40v2. As CSS z-index property is not supported, a full screen transparent PNG is not doable.

    Perhaps the bigger loading indicator would help with clicking problem as well. It doesn't change the platform functionality, on how clicks are handled, when the native loading indicator is shown. But form UX perspective, if can make users to wait properly instead of tapping the other buttons in the UI.

    Br,
    Ilkka

Similar Threads

  1. Problem with the Bitmap loading
    By xDaex in forum Symbian User Interface
    Replies: 3
    Last Post: 2007-09-25, 03:55
  2. problem with loading textures
    By niempi2 in forum Symbian Media (Closed)
    Replies: 3
    Last Post: 2007-05-04, 21:59
  3. Problem with Appln Loading...
    By yasomca in forum Mobile Java Tools & SDKs
    Replies: 0
    Last Post: 2005-10-04, 02:54
  4. Problem with Appln Loading...
    By yasomca in forum Mobile Java General
    Replies: 0
    Last Post: 2005-10-04, 02:52
  5. problem with loading image
    By rathikathangaraj in forum Mobile Java General
    Replies: 1
    Last Post: 2005-06-22, 08:53

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •