×

Discussion Board

Results 1 to 11 of 11

Hybrid View

  1. #1
    Registered User
    Join Date
    Feb 2011
    Posts
    45

    Garbled Emulator Text Rendering On Ubuntu 11.04

    Hi guys,

    Currently, I'm developing on linux (ubuntu 11.04). However, I got this irritating bug when testing using emulator.

    Please see below for rendering example:




    I'm pretty sure it is caused by font rendering. But, I can't pin point the exact problem. So, maybe you guys could help me out?

  2. #2
    Registered User
    Join Date
    Feb 2011
    Posts
    45

    Re: Garbled Emulator Text Rendering On Ubuntu 11.04

    Did anyone have clue(s)?

  3. #3
    Registered User
    Join Date
    Feb 2011
    Posts
    45

    Re: Garbled Emulator Text Rendering On Ubuntu 11.04

    *bump**bump*
    Quote Originally Posted by artinteg View Post
    Did anyone have clue(s)?

  4. #4
    (Retired) Nokia Developer Admin.
    Join Date
    Jan 2006
    Location
    Michigan
    Posts
    4,664

    Re: Garbled Emulator Text Rendering On Ubuntu 11.04

    I believe the browser team is on vacation until the first of August. If no one replies by the 5th of August write directly to me. I apologize for the long delay but this is a Finnish thing. (and there summers are beautiful).

    Ron

  5. #5
    Registered User
    Join Date
    Feb 2011
    Posts
    45

    Re: Garbled Emulator Text Rendering On Ubuntu 11.04

    ow haha, sorry. I forgot that it's summer over there.

    Okay, I'll wait till you guys come back[1]. Have a nice vacation!




    [1]In the mean time, I'll have to stick with Windows T_T.

  6. #6
    Registered User
    Join Date
    Jan 2011
    Posts
    6

    Re: Garbled Emulator Text Rendering On Ubuntu 11.04

    +1 this also affects Ubuntu 10.04.3 32bit. The inspector of the device simulator is rendered so badly you can only guess what is written there...

  7. #7
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Posts
    115

    Re: Garbled Emulator Text Rendering On Ubuntu 11.04

    Hey,

    What are your regional / locale and font settings in the Ubuntu installation? We need to try to reproduce this here at our end.

    petro
    'petro
    @petrosoininen

  8. #8
    Registered User
    Join Date
    May 2011
    Posts
    24

    Re: Garbled Emulator Text Rendering On Ubuntu 11.04

    I'm affeced by this bug too.

    Here's my locale:


    Code:
    silent@hackedLP3:~$ cat /etc/default/locale 
    LANG="en_US.UTF-8"
    My fonts setting:

    Code:
    Application: Ubuntu
    Document: Sans
    Desktop: Ubuntu
    Window title: Ubuntu
    Fixed width: Monospace
    Rendering method: subpixel smoothing
    Code:
    silent@hackedLP3:~$ uname -a
    Linux hackedLP3 2.6.38-10-generic #46-Ubuntu SMP Tue Jun 28 15:05:41 UTC 2011 i686 i686 i386 GNU/Linux
    silent@hackedLP3:~$ lsb_release -a
    No LSB modules are available.
    Distributor ID:	Ubuntu
    Description:	Ubuntu 11.04
    Release:	11.04
    Codename:	natty

  9. #9
    Registered User
    Join Date
    Oct 2013
    Posts
    5

    Re: Garbled Emulator Text Rendering On Ubuntu 11.04

    Hello,

    I am not yet ready to let my beloved N8 go, so I still am developing wrt widgets .
    I know that all support goes into Windows Phone now, but still I would like to see this issue solved.

    I tried to vary all font settings in Ubuntu but nothing changed within the Web Inspector, the font always stays the same.
    The Web Inspector seems to use its own fonts and not using that of Ubuntu.

    Is there any solution or workaround (except of using Windows...) for this?

  10. #10
    Registered User
    Join Date
    Oct 2013
    Posts
    5

    Re: Garbled Emulator Text Rendering On Ubuntu 11.04

    The results of my investigations so far are:
    - the Web Inspector and the device simulator are written in JAVA.
    - if the font used by the java application is missing, an other font is used instead which is then producing the bad text rendering
    - installing the windows fonts under ubuntu didn't help
    - installing the current java runtime from oracle didn't help

    What I am now trying is to change the default fonts used by java applications.
    I will report my progress here. Maybe this helps someone...

Similar Threads

  1. Installing Qt Mobility 1.1 on Ubuntu 10.04 and using it with Qt Creator
    By tkatva in forum [Archived] Qt Mobility Project
    Replies: 3
    Last Post: 2010-12-15, 03:18
  2. NokiaQtSDK Simultor build problem on Ubuntu 10.04
    By srikanthsombhatla in forum [Archived] Qt SDKs and Tools
    Replies: 8
    Last Post: 2010-08-24, 08:04
  3. Remote compiler not selectable in Qt Creator (Ubuntu 10.04)
    By josefr in forum [Archived] Qt SDKs and Tools
    Replies: 4
    Last Post: 2010-07-26, 19:42
  4. Upgrading firmware Ubuntu 9.04
    By Plitter in forum General Development Questions
    Replies: 1
    Last Post: 2009-07-20, 16:48
  5. Using Nokia S60 3rd from Ubuntu 8.04
    By FBulovic in forum News and Announcements
    Replies: 2
    Last Post: 2008-11-09, 00:31

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×