×

Discussion Board

Results 1 to 5 of 5
  1. #1
    Registered User
    Join Date
    Jul 2011
    Posts
    3

    Post Application icon lost if running file during installation

    Hello all,

    I have a problem concerning an application lunch icon.
    At the end of installation I need to start configuration exe file using FILERUN, RUNINSTALL, RUNWAITEND. After the installation completed, the application has the default symbian icon. If I remove from pkg file FILERUN, RUNINSTALL, RUNWAITEND options, then application has correct lunch icon after installation.

    Does anyone know what is the matter? Please help.

  2. #2
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,751

    Re: Application icon lost if running file during installation

    Make sure that the _reg.rsc and .mif files are deployed before the executable. Generally FR,RI lines should be the last ones in the .pkg

  3. #3
    Registered User
    Join Date
    Jul 2011
    Posts
    3

    Re: Application icon lost if running file during installation

    Launched host_sis_ca.exe file is installed and started at the end. Interesting thing, that if I move this exe file at the beginning, before installing main host.exe file with resources, then icon is displayed correct. But in that case I am not able to start host.exe for initialization, KErrNotFound error is returned. Below is the part of pkg file:

    ;Files to install
    "host.exe" -"!:\sys\bin\WsmHost.exe"
    "host.rsc" -"!:\resource\apps\WsmHost.rsc"
    "autostart.lock" -"!:\private\200325EB\autostart.lock"
    if exists("z:\system\install\Series60v5.2.sis")
    "host2.mbm" -"!:\resource\apps\WsmHost.mbm"
    else
    "host.mbm" -"!:\resource\apps\WsmHost.mbm"
    endif
    ;"host.mif" -"!:\resource\apps\WsmHost.mif"
    "host_reg.rsc" -"!:\private\10003a3f\import\apps\WsmHost_reg.rsc"

    "starthost.exe" -"!:\sys\bin\WsmHostStart.exe"
    "starthost.rsc" -"c:\private\101f875a\import\[200325EB].rsc"

    "mainview.mbm" -"!:\resource\apps\WsmHost_mainview.mbm"
    "infoview.mbm" -"!:\resource\apps\WsmHost_infoview.mbm"
    "historyview.mbm" -"!:\resource\apps\WsmHost_historyview.mbm"
    "logo.mbm" -"!:\resource\apps\WsmHost_logo.mbm"

    "host_sis_ca.exe" -"!:\sys\bin\WsmWebCfg.exe", FR, RI, RW

    ;required for application to be covered by backup/restore facility
    "backup_registration.xml" -"!:\private\200325EB\backup_registration.xml"

    mif file is not used. Icon is included into "WsmHost.mbm".

  4. #4
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,751

    Re: Application icon lost if running file during installation

    I thought it was the same .exe which was started and which had an icon.
    Consider deploying the host.exe after its resources and icons.

  5. #5
    Registered User
    Join Date
    Jul 2011
    Posts
    3

    Re: Application icon lost if running file during installation

    I moved line ""host.exe" -"!:\sys\bin\WsmHost.exe"" after line ""host_reg.rsc" -"!:\private\10003a3f\import\apps\WsmHost_reg.rsc"", but no luck.

Similar Threads

  1. Invalid Jar File During Installation
    By amit_1234 in forum Mobile Java General
    Replies: 1
    Last Post: 2010-12-10, 10:45
  2. Check If Application Running?
    By ManuMies in forum Symbian
    Replies: 0
    Last Post: 2010-11-04, 14:21
  3. SIS file information during installation
    By souparnalodh in forum Symbian
    Replies: 2
    Last Post: 2009-07-15, 07:38
  4. Running Executables During Installation
    By felipebzr in forum Symbian
    Replies: 13
    Last Post: 2007-03-02, 08:51

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×