×

Discussion Board

Page 1 of 2 12 LastLast
Results 1 to 15 of 22
  1. #1
    Registered User
    Join Date
    May 2011
    Posts
    34

    Exclamation file I/O fault, cannot find ../../../../../../epoc32/release/gcce/urel/Texture.exe

    Dear All,

    My texture.exe file got deleted after cleaning the project and now when I build my project I got errors like below:

    file I/O fault, cannot find ../../../../../../epoc32/release/gcce/urel/Texture.exe
    makesis.exe returned with exit value = 1
    Cannot find file : ../../../../../../epoc32/release/gcce/urel/Texture.exe


    Can anybody please help me regarding this. Thanks in advance.

    Regards,
    Atul Prakash Singh

  2. #2
    Nokia Developer Champion
    Join Date
    Feb 2009
    Location
    India
    Posts
    1,174

    Re: file I/O fault, cannot find ../../../../../../epoc32/release/gcce/urel/Texture.ex


  3. #3
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,752

    Re: file I/O fault, cannot find ../../../../../../epoc32/release/gcce/urel/Texture.ex

    The file is not found. Are you building for GCCE UREL?

  4. #4
    Registered User
    Join Date
    May 2011
    Posts
    34

    Re: file I/O fault, cannot find ../../../../../../epoc32/release/gcce/urel/Texture.ex

    Yes, I am building for GCCE UREL(Phone Release). But how can I fix this error?

  5. #5
    Registered User
    Join Date
    May 2011
    Posts
    34

    Angry Changes in code are not reflecting back in build!!!!!!!!

    Dear All,

    I am facing serious problems with Symbian^3.

    Right now I am making changes in my code but unfortunately these changes are not reflecting back in the build, although build is updated all the times(i.e. new build is made successfully)

    If I clean my project then there comes another problem like:

    cannot find../../../../../../epoc32/release/gcce/urel/Texture.exe

    Please Respond.

  6. #6
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,752

    Re: Changes in code are not reflecting back in build!!!!!!!!

    Clean deletes the result files, that is its purpose.
    Check if the file exists in epoc32\release\gcce\urel, after a build.
    If it exists, the .pkg has to be fixed, the ..\..\..-thing is a relative path, which can be wrong.
    If it does not exist, there are other errors, which you should see in the Problems view or in the Console.

  7. #7
    Nokia Developer Champion
    Join Date
    Jun 2008
    Location
    Noida,India
    Posts
    4,091

    Re: Changes in code are not reflecting back in build!!!!!!!!

    instead of mentioning relative path for the files..mention like this:

    "$(EPOCROOT)Epoc32\release\$(PLATFORM)\$(TARGET)\Texture.exe" -"!:\sys\bin\Texture.exe"

  8. #8
    Registered User
    Join Date
    May 2011
    Posts
    34

    Re: Changes in code are not reflecting back in build!!!!!!!!

    I tried it, but it doesn't make any difference here.

    My actual problem is like: If I clean my project then I can see clearly that both the files in epoc32\release\gcce\urel(i.e. texture.exe and texture.exe.map) got deleted at that moment. After that If I build my project in phone release mode then it shows error like texture.exe is missing in epoc32\release\gcce\urel.

    When we build our project then texture.exe.map file is got generated in epoc32\release\gcce\urel folder but texture.exe is not being generated at that moment, this is what creating problems. Is there any way to generate the texture.exe file?

    Please do reply.

    Thanks.

  9. #9
    Nokia Developer Champion
    Join Date
    Jun 2008
    Location
    Noida,India
    Posts
    4,091

    Re: Changes in code are not reflecting back in build!!!!!!!!

    if this is the case then there must be some error with the building of you project. See the console tab of carbide , are there any red lines in it or search for the keyword 'error' in it.

  10. #10
    Registered User
    Join Date
    May 2011
    Posts
    34

    Re: Changes in code are not reflecting back in build!!!!!!!!

    Yes, there are red lines in my console tab of carbide. Many warnings are being listed out here in red color. And last two lines are like below:

    make[1]: *** [\Nokia\Devices\Nokia_Symbian3_SDK_v0.9\epoc32\release\gcce\urel\texture.exe] Error 1
    make: *** [TARGETTEXTURE] Error 2


    But there is no specific description regarding error. How can I locate this error?

  11. #11
    Nokia Developer Champion
    Join Date
    Feb 2009
    Location
    India
    Posts
    1,174

    Re: Changes in code are not reflecting back in build!!!!!!!!

    One of the possible cause can be any of your .cpp is not converted into .o successfully. So, try to search for ".o" (file extension) in your console window. If you find any such entry then it means you have some logical problem in that corresponding .cpp file, not syntax because of which your .exe is not getting generated.

  12. #12
    Registered User
    Join Date
    May 2011
    Posts
    34

    Re: Changes in code are not reflecting back in build!!!!!!!!

    Yes, there are various files of .o extension in my console window. But how can I solve the logical problems, any sugesstions??

  13. #13
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,752

    Re: Changes in code are not reflecting back in build!!!!!!!!

    Check for other errors. It is always the first one which you can surely fix. The latter errors may be caused by the earlier ones, like the missing file problem.

  14. #14
    Registered User
    Join Date
    Dec 2006
    Location
    Noida, India
    Posts
    150

    Re: Changes in code are not reflecting back in build!!!!!!!!

    Is there any description in "Problems" tab for those errors?

  15. #15
    Registered User
    Join Date
    May 2011
    Posts
    34

    Re: Changes in code are not reflecting back in build!!!!!!!!

    In problems tab there is no description for these errors but these are visible is console tab.

Similar Threads

  1. can't find the file HelloWorldBasic.exe in \S60\devices\S60_3rd_FP2_SDK_v1.1\epoc32\r
    By changshiop in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 8
    Last Post: 2009-05-03, 01:56
  2. build in gcce platform cannot find .exe file? in release/gcce/urel/
    By glenchang in forum Symbian Tools & SDKs
    Replies: 3
    Last Post: 2008-11-26, 07:49
  3. Replies: 1
    Last Post: 2008-03-06, 10:31

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×