×

Discussion Board

Results 1 to 5 of 5
  1. #1
    Registered User
    Join Date
    Jul 2011
    Posts
    12

    Post PIPS Installer is not upgradable (-10256), how can I fix this?

    The event happened on my phone installing Qt component ,the full information my phone give me is "PIPS Installer is not upgradable (-10256), continue anyway? "
    And then I unpacked Qt.sis,and got a file named "pips.sis", then I try to install it.
    This time , I've got some more information .
    It tells me that "无法安装 组件已固化在手机系统中".
    Err...my phone is Chinese,so it gives information in Chinese, if you can't tell it,I'll translate it into English: "Cannot install ,the component is already in your ROM".
    Is anybody here can help me to solve this problem?Or, if it's really doesn't matter?
    Thank you.
    -------------------------------
    Oh,I forget to tell you that my phone is Nokia N79(RM-348).And my ROM version is 32.001.53.1(Not official version...In China there's a lot of version that people modified. )
    Last edited by jixiangqd; 2011-08-01 at 09:26. Reason: add

  2. #2
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,165

    Re: PIPS Installer is not upgradable (-10256), how can I fix this?

    if you are having non-official version of the firmware, then we here can not help you. Basically to use normal software updater to get a real official version of the firmware, and then try again. Then if you are having problems, then there would be something that could be done for helping you.

  3. #3
    Registered User
    Join Date
    Jul 2011
    Posts
    12

    Re: PIPS Installer is not upgradable (-10256), how can I fix this?

    Quote Originally Posted by symbianyucca View Post
    if you are having non-official version of the firmware, then we here can not help you. Basically to use normal software updater to get a real official version of the firmware, and then try again. Then if you are having problems, then there would be something that could be done for helping you.
    Thanks for your answer,I'll try it later for your advice...
    As it's a big project to reflash the firmware, I then continued install other components in Qt_installer (without PIPS),and I ran an Qt Applications correctly.
    Is that meaning doesn't matter for without installing the PIPS? Or, How I got an Error when I run Qt Applications?(I mean what can PIPS do for me?)

  4. #4
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,165

    Re: PIPS Installer is not upgradable (-10256), how can I fix this?

    AS you identified that your firmware is not official, I can not offer any help on it. Without knowing what it contains, it is rather impossible to start figuring out what the root cause it. Anyway, I would suggest trying to update the device libraries with Smart Installer, rather than using the sis files provided by the SDK, there are something some differences, and could you that you are experiencing them.

    All and all, "Cannot install ,the component is already in your ROM". indicates that the module is already there, then if you are lucky its also correct version, anyway, when using unofficial firmwares you takes complete risk by yourself, and I would not go guessing whether things work or not, you have to test that yourself as well.

  5. #5
    Registered User
    Join Date
    Jul 2011
    Posts
    12

    Re: PIPS Installer is not upgradable (-10256), how can I fix this?

    Quote Originally Posted by symbianyucca View Post
    AS you identified that your firmware is not official, I can not offer any help on it. Without knowing what it contains, it is rather impossible to start figuring out what the root cause it. Anyway, I would suggest trying to update the device libraries with Smart Installer, rather than using the sis files provided by the SDK, there are something some differences, and could you that you are experiencing them.

    All and all, "Cannot install ,the component is already in your ROM". indicates that the module is already there, then if you are lucky its also correct version, anyway, when using unofficial firmwares you takes complete risk by yourself, and I would not go guessing whether things work or not, you have to test that yourself as well.
    Thanks all the time!
    But I've tried the smart installer before, it also gives me some error and then exit.
    As your advice ,I'll take your advice to have an official firmware.
    All the way,thank you very much!!!!

Similar Threads

  1. Replies: 1
    Last Post: 2010-07-30, 03:32
  2. How to fix this error
    By chart12 in forum Symbian
    Replies: 1
    Last Post: 2009-08-23, 18:53
  3. How to fix this error?
    By DNA1981 in forum Symbian
    Replies: 2
    Last Post: 2007-07-06, 09:48
  4. 9210i - is it GPRS upgradable?
    By vtwillem in forum Symbian
    Replies: 1
    Last Post: 2002-07-15, 11:44

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×