×

Discussion Board

Results 1 to 8 of 8
  1. #1
    Regular Contributor
    Join Date
    Feb 2009
    Location
    ASIA PACIFIC
    Posts
    108

    Flash lite packing using Qt SDK?

    Hi
    Since the online packer has been made obsolete, is there a solution to pack Flashlite app into sis using Qt SDK or any other free resource ? How do you all pack Flashlite now that there is no tool available ?
    Website: http://nmamobiles.byethost2.com
    Blog: http://nmamobiles.byethost2.com/blog

  2. #2
    Nokia Developer Champion
    Join Date
    Jul 2008
    Location
    Pakistan
    Posts
    1,065

    Re: Flash lite packing using Qt SDK?

    Hi Rajan,
    I dont recommend packaging your flash content in Qt as you have to first take care of Qt packaging (i.e smart installer) and then Flash Lite. Better way is to use old techniques i.e
    1. Try this free packager (Helisso) which doesn't need any SDKs for SWF to SIS packaging.
    http://www.flashmobileblog.com/2010/03/03/helisso-a-packager-for-symbian-devices/

    OR
    2. Download Symbian 3rd or 5th SDK and Carbide C++, then follow this article :
    http://www.developer.nokia.com/Community/Wiki/Create_Flash_Applications_with_Carbide.c++


    Best Regards,
    SajiSoft

  3. #3
    Regular Contributor
    Join Date
    Feb 2009
    Location
    ASIA PACIFIC
    Posts
    108

    Re: Flash lite packing using Qt SDK?

    Thank you , but Helisso packs only flashlite 3.1 and there are a large number of users who still have < 3.1 flashlite. I guess there is no way other way than the app prompting user to upgrade to flashlite 3.1 . I don't want to download another sdk - I am sick of all the Qt and QML SDKs ! The online packer was so good. Wonder why they took it down.
    Website: http://nmamobiles.byethost2.com
    Blog: http://nmamobiles.byethost2.com/blog

  4. #4
    Nokia Developer Champion
    Join Date
    Jul 2008
    Location
    Pakistan
    Posts
    1,065

    Re: Flash lite packing using Qt SDK?

    Hi Rajan,
    Helisso does support Flash Lite 3.0 as well and have you test it with any Flash Lite 2.x and Flash Lite 3.0 device? because i think Helisso is based on Flash Lite Viewer Frameworks which has to work with Flash Lite 2.0 to 3.x
    The online packer was so good. Wonder why they took it down.
    Only some one from Nokia can comment on it .

    Best Regards,
    SajiSoft

  5. #5
    Regular Contributor
    Join Date
    Feb 2009
    Location
    ASIA PACIFIC
    Posts
    108

    Re: Flash lite packing using Qt SDK?

    Quote Originally Posted by sajisoft View Post
    Hi Rajan,
    Helisso does support Flash Lite 3.0 as well and have you test it with any Flash Lite 2.x and Flash Lite 3.0 device? because i think Helisso is based on Flash Lite Viewer Frameworks which has to work with Flash Lite 2.0 to 3.x
    Unfortunately if I try to pack with < 3.1 Flashlite I get the following error [in warap.exe.log file]
    Traceback (most recent call last):
    File "Wrap.py", line 15, in <module>
    File "python_wrap.pyc", line 10, in <module>
    File "ensymble\cmd_swf2sis.pyc", line 404, in run
    MemoryError
    Traceback (most recent call last):
    File "Wrap.py", line 15, in <module>
    File "python_wrap.pyc", line 10, in <module>
    File "ensymble\cmd_swf2sis.pyc", line 404, in run
    MemoryError
    Traceback (most recent call last):
    File "Wrap.py", line 15, in <module>
    File "python_wrap.pyc", line 10, in <module>
    File "ensymble\cmd_swf2sis.pyc", line 404, in run
    MemoryError
    Traceback (most recent call last):
    File "Wrap.py", line 15, in <module>
    File "python_wrap.pyc", line 10, in <module>
    File "ensymble\cmd_swf2sis.pyc", line 404, in run
    MemoryError
    Website: http://nmamobiles.byethost2.com
    Blog: http://nmamobiles.byethost2.com/blog

  6. #6
    Nokia Developer Champion
    Join Date
    Jul 2008
    Location
    Pakistan
    Posts
    1,065

    Re: Flash lite packing using Qt SDK?

    Hi Rajan,
    I also found some issues with Helisso Packager. So now, we left with two options :
    1- Carbide C++, Symbian SDK and Code.
    2- Embeds SWF into a WRT.


    Best Regards,
    SajiSoft

  7. #7
    Nokia Developer Champion
    Join Date
    Feb 2011
    Location
    bucharest
    Posts
    149

    Re: Flash lite packing using Qt SDK?

    yes, the easiest way to make an app with flash is WRT...
    but you cannot use the flash APIs, instead you need to use WRT APIs and pass data between WRT and flash

    Code:
    document.getElementById("flashOBJ").SetVariable("var1",value1);

  8. #8
    Regular Contributor
    Join Date
    Feb 2009
    Location
    ASIA PACIFIC
    Posts
    108

    Re: Flash lite packing using Qt SDK?

    Nokia Flash online packer is back ! but God only knows for how long. Use it while its there!
    Website: http://nmamobiles.byethost2.com
    Blog: http://nmamobiles.byethost2.com/blog

Similar Threads

  1. Packing Flashlite file in sis using Qt SDK
    By rajan.mba in forum [Archived] Flash Lite on Nokia Devices
    Replies: 1
    Last Post: 2010-11-24, 20:34
  2. Packing a Flash Lite Application with APIBridge
    By ranco in forum [Archived] Flash Lite on Nokia Devices
    Replies: 4
    Last Post: 2010-03-24, 14:52
  3. Problem with Flash Lite & Nokia - Flash Lite does not open in MMS
    By muggzy in forum [Archived] Flash Lite on Nokia Devices
    Replies: 4
    Last Post: 2008-12-17, 17:13
  4. I have a problem in chat using Kuneri Lite and Flash Lite.
    By Felipe.Sampaio in forum [Archived] Flash Lite on Nokia Devices
    Replies: 1
    Last Post: 2008-07-09, 07:40
  5. Best practice for packing Flash Lite
    By TurfStudios in forum [Archived] Flash Lite on Nokia Devices
    Replies: 4
    Last Post: 2008-04-28, 12:40

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×