×

Discussion Board

Results 1 to 5 of 5
  1. #1
    Registered User
    Join Date
    Aug 2009
    Posts
    8

    Smart Installer: To publish in OVI must install drive be selectable ? If so how ?

    I submitted an app to OVI developed with Qt Creator, Qt 6.3 and using Smart Installer V1.1. With previous apps, there was no problem. This time it failed because the drive was not selectable on installation. I thought this was not possible with the Smart Installer. Has something changed, and how does one get around the problem ? I would be thankful for any advice - Nick.

  2. #2
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,166

    Re: Smart Installer: To publish in OVI must install drive be selectable ? If so how ?

    did you reas any older posts, like : http://www.developer.nokia.com/Commu...lls-onto-C-WTF already

  3. #3
    Registered User
    Join Date
    Mar 2011
    Posts
    27

    Re: Smart Installer: To publish in OVI must install drive be selectable ? If so how ?

    I usually have the same problem. I have to manually edit the app_installer.pkg file, but it would be nice if the qmake autogenerated pkg file would automatically be generated with "!:\private\2002CCCE\import\app.sis" instead of "c:\private\2002CCCE\import\app.sis"
    Is there something we can do about it in the pro.file, or in some other place ? Some example ?

  4. #4
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: Smart Installer: To publish in OVI must install drive be selectable ? If so how ?

    What SDK version are you using, and which target. In my recent tests the generated wrapper package uses "!:\"
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  5. #5
    Registered User
    Join Date
    Mar 2011
    Posts
    27

    Re: Smart Installer: To publish in OVI must install drive be selectable ? If so how ?

    I just test it with the brand new SDK version 1.1.4. If I choose Qt 4.6.3 S^1 toolchain with creates "c:\..." but with S60 5ed toolchain with creates "!:\..." I was chosinh the first for greater compatiblity.

Similar Threads

  1. [moved] SDK Install (was Smart installer how-to)
    By codestain in forum Symbian Tools & SDKs
    Replies: 7
    Last Post: 2010-06-20, 21:48
  2. Publish to OVI using stripped down Qt static bin, Smart Installer release date?
    By marksmithdev in forum [Closed] Publishing to Nokia Store
    Replies: 2
    Last Post: 2010-05-18, 11:21
  3. Parameters to be used in package file to install application default to C drive
    By thokkal in forum Symbian Signed Support, Application Packaging and Distribution and Security
    Replies: 2
    Last Post: 2009-08-07, 10:43
  4. Ok so how on earth can I publish my game on OVI??
    By TacB0sS in forum [Closed] Publishing to Nokia Store
    Replies: 1
    Last Post: 2009-08-05, 17:04

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×