×

Discussion Board

Results 1 to 8 of 8
  1. #1
    Registered User
    Join Date
    Aug 2011
    Posts
    6

    Qt Quick: which phones are supported

    I'm possibly about to start a project, writing an app with the Nokia N8 as the main target. I'd like to use Qt Quick, but I'm worried that there might be problems with the app failing to install on N8s that have old firmware or the install progress requiring the user to install other packages first. I'd also like the app to run on older S60 v5 phones if possible. I've searched for information the best I can, but I cannot find anything definitive.

  2. #2
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,165

    Re: Qt Quick: which phones are supported

    Qt Quick requires Qt 4.7, which indeed supports Symbisn 5tth ed as well as Symbian^3 devices. anyway, if the device does not have Qt 4.7 or other required dependencies, they do need to be installed before the application is installed, and for this task you should use the Smart installer.

  3. #3
    Registered User
    Join Date
    Aug 2011
    Posts
    6

    Re: Qt Quick: which phones are supported

    Brilliant. Thanks for rapid reply.

  4. #4
    Registered User
    Join Date
    Sep 2009
    Posts
    40

    Re: Qt Quick: which phones are supported

    Quote Originally Posted by symbianyucca View Post
    Qt Quick requires Qt 4.7, which indeed supports Symbisn 5tth ed as well as Symbian^3 devices. anyway
    Hi,
    Have you tried the Qt Quick on symbian 5th?
    Last time I encounter of SIS error, lost a couple days of productivity on googleing on what's wrong...
    then I found out that QT Quick doesn't support 5th ed (but the QT compiler list it as supported, in which make me going nuts)

    Source: http://www.developer.nokia.com/Commu...er_for_Symbian

    To be exact... this one:
    http://www.developer.nokia.com/Commu...with_Qt_4.7.29

    In addition...
    this were at almost the end from the link above:
    All S60 3rd (3.1/3.2) and 5th Edition devices......... Qt Quick Components is not supported on these devices.
    Note: S60 5th Edition devices support Qt 4.7 which contains Qt Quick. In S60 5th Ed. however, Qt Quick Components are currently not supported.
    Last edited by cycnus; 2011-09-07 at 20:12. Reason: add note that Qt Quick IS in the S60 5th ed, but currently not supported

  5. #5
    Registered User
    Join Date
    Jan 2011
    Posts
    26

    Re: Qt Quick: which phones are supported

    What I am missing is some kind of roadmap from Nokia saying something like "By November 2011, all S60 and Symbian^3 devices will have QtQuick 1.1, QtMobility 1.2 and Qt3D 1.0". This would make things much easier for developers

    I posted this question in another thread:
    http://www.developer.nokia.com/Commu...onents-roadmap

  6. #6
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,165

    Re: Qt Quick: which phones are supported

    that is quite much unrelated to the original question on this thread, components are part of qtQuick, but just a part.

  7. #7
    Registered User
    Join Date
    Jan 2011
    Posts
    26

    Re: Qt Quick: which phones are supported

    Quote Originally Posted by symbianyucca View Post
    that is quite much unrelated to the original question on this thread, components are part of qtQuick, but just a part.
    In that case, I apologize for hijacking this thread. I felt that my question was a logical follow up to the OP's question but it seems I was mistaken...

  8. #8
    Registered User
    Join Date
    Sep 2009
    Posts
    40

    Re: Qt Quick: which phones are supported

    @tube42,
    I believe symbianyucca was answering to my post. He said... component are part of qtQuick, meaning... he's saying QtQuick were supported in 5th edition, and when i said Qt Quick component, it's a different things.

    @symbianyucca
    Actually I was talking about your answer to Glidos. (it is related to the question glidos were asking)

    Glidos ask about running QT Quick apps on 5th ed devices.
    A couple week back, I was also developing an apps with QT Quick, run perfectly on E7/N8, but when I tried on 5th ed RDA, the apps wouldn't run.
    After a couple of days searching on the web, i come to conclusion that 5th ed could not run QT Quick apps.
    here is the source that said 5th ed can't run QT Quick
    http://www.developer.nokia.com/Commu...with_Qt_4.7.29

    But,
    since you have post many post in this very developer web site,
    I was hopping maybe you know something that I didn't know.

Similar Threads

  1. How to check upon which QT version are apps built in QT creator?
    By DixieFlatline in forum [Archived] Qt SDKs and Tools
    Replies: 10
    Last Post: 2011-01-28, 10:25
  2. Which browsers are supported?
    By wizard_hu_ in forum Feedback on Forum Nokia's Renewal 2010
    Replies: 7
    Last Post: 2010-06-09, 15:15
  3. Which are all the Nokia Mobile Supported in AMR Format
    By tlgkumar in forum Mobile Java General
    Replies: 4
    Last Post: 2008-10-22, 08:07
  4. Are other phones like 6162 and 6185 supported?
    By Nokia_FAQ in forum PC Suite API and PC Connectivity SDK
    Replies: 1
    Last Post: 2002-05-13, 20:44

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×