×

Discussion Board

Results 1 to 7 of 7
  1. #1
    Super Contributor
    Join Date
    Jun 2004
    Location
    SymbianLand
    Posts
    763

    Exclamation Getting "Cannot install a protected application from untrusted supplie" error!!!

    Hi,
    I have a demo app which has a UID from the unprotected range[0xAxxxxxx]. It has no capabilties. I tried self-signing, signing with the devcert from symbiansigned.com , but still getting this error.
    I have followed all the instructions specified on these pages, but still to no use:
    http://www.developer.nokia.com/Commu...roubleshooting
    Also the installation settings are to install All. There is no timing skew.
    I am going nuts here. Any other suggestions to fix this issue?
    Thanks in advance.

  2. #2
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,751

    Re: Getting "Cannot install a protected application from untrusted supplie" error!!!

    Date/time problems would cause an other type of error message.
    This one is about UID-s. What is in your .pkg file?

  3. #3
    Super Contributor
    Join Date
    Jun 2004
    Location
    SymbianLand
    Posts
    763

    Re: Getting "Cannot install a protected application from untrusted supplie" error!!!

    Irrelevant parts obscured with XXX
    Code:
    APP_LAYER_SYSTEMINCLUDE
    
    TARGET			XXX_0xA0011833.exe
    TARGETTYPE		exe
    UID		  0x100039CE 0xA0011833
    
    SOURCEPATH		..\src
    SOURCE			XXX.cpp
    SOURCE			XXXApplication.cpp
    SOURCE			XXXAppView.cpp
    SOURCE			XXXAppUi.cpp
    SOURCE			XXXDocument.cpp
    SOURCE 			2X.cpp
    
    SOURCEPATH		..\data
    START RESOURCE	XXX.rss
    HEADER
    TARGET XXX_0xA0011833
    TARGETPATH resource\apps
    END //RESOURCE
    
    START RESOURCE	XXX_reg.rss
    TARGET XXX_0xA0011833_reg
    TARGETPATH 	  \private\10003a3f\apps
    END //RESOURCE
    
    USERINCLUDE	   ..\inc
    
    
    
    LIBRARY		   euser.lib
    LIBRARY		   apparc.lib
    LIBRARY		   cone.lib
    LIBRARY		   eikcore.lib
    LIBRARY		   avkon.lib
    //LIBRARY		   commonengine.lib
    //LIBRARY		   efsrv.lib 
    //LIBRARY		   estor.lib
    //LIBRARY        aknnotify.lib
    LIBRARY        gdi.lib
     
    
    LANG SC
    
    VENDORID	  	  0
    SECUREID		  0xA0011833
    CAPABILITY	  	  NONE
    
    DEBUGGABLE_UDEBONLY
    // End of File

  4. #4
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,751

    Re: Getting "Cannot install a protected application from untrusted supplie" error!!!

    Not bad after all, it seems to be fine.
    However the question was about the .pkg. (I was planning to ask about the .mmp later)

  5. #5
    Super Contributor
    Join Date
    Jun 2004
    Location
    SymbianLand
    Posts
    763

    Re: Getting "Cannot install a protected application from untrusted supplie" error!!!

    I am pathetic, my state of mind does not seem good
    Code:
    ;Language - standard language definitions
    &EN
    
    ; standard SIS file header
    #{"XXX"},(0xA0011833),1,0,0
    
    ;Localised Vendor name
    %{"Vendor"}
    
    ;Unique Vendor name
    :"Vendor"
    
    ;Supports Series 60 v 5.0
    [0x101F7961], 0, 0, 0, {"Series60ProductID"}
    [0x20022E6D], 0, 0, 0, {"Series60ProductID"}
    
    ;Files to install
    ;You should change the source paths to match that of your environment
    ;<source> <destination>
    "$(EPOCROOT)epoc32\release\$(PLATFORM)\$(TARGET)\XXX_0xA0011833.exe"		-"!:\sys\bin\XXX_0xA0011833.exe"
    "$(EPOCROOT)epoc32\data\z\resource\apps\XXX_0xA0011833.rsc"		-"!:\resource\apps\XXX_0xA0011833.rsc"
    "$(EPOCROOT)epoc32\data\z\private\10003a3f\apps\XXX_0xA0011833_reg.rsc"	-"!:\private\10003a3f\import\apps\XXX_0xA0011833_reg.rsc"
    "$(EPOCROOT)epoc32\data\z\resource\apps\XXX_0xA0011833.mif" -"!:\resource\apps\XXX_0xA0011833.mif"
    ;"..\help\XXX_0xA0011833.hlp"							 -"!:\resource\help\XXX_0xA0011833.hlp"
    
    ; Add any installation notes if applicable
    ;"XXX.txt"		-"!:\private\e3d0ad20\XXX.txt"
    
    ;required for application to be covered by backup/restore facility 
    "..\sis\backup_registration.xml"		-"!:\private\e3d0ad20\backup_registration.xml"

  6. #6
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,751

    Re: Getting "Cannot install a protected application from untrusted supplie" error!!!

    That backup_registration.xml in the last line, it goes to a different folder than what the UID allows.

  7. #7
    Super Contributor
    Join Date
    Jun 2004
    Location
    SymbianLand
    Posts
    763

    Re: Getting "Cannot install a protected application from untrusted supplie" error!!!

    Commented out that .xml line and its working.
    Thanks a lot for the kind help.

Similar Threads

  1. Replies: 3
    Last Post: 2009-07-01, 14:30
  2. N85: DLL install error: unable to install a protected application from an untrusted
    By Donald.Eaves in forum Symbian Signed Support, Application Packaging and Distribution and Security
    Replies: 5
    Last Post: 2009-02-06, 22:34
  3. S60 3rd MR: "Unable to install a protected application from an untrusted supplier"
    By RB_Sahu in forum Symbian Signed Support, Application Packaging and Distribution and Security
    Replies: 7
    Last Post: 2008-01-23, 03:34
  4. S60 3rd MR: "Unable to install a protected application from an untrusted supplier"
    By RB_Sahu in forum Symbian Signed Support, Application Packaging and Distribution and Security
    Replies: 1
    Last Post: 2008-01-22, 08:08

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×