×

Discussion Board

Results 1 to 8 of 8
  1. #1
    Registered User
    Join Date
    Oct 2009
    Posts
    56

    Qt SDK 1_1_3 cannot compile program for N950

    Hello,
    I've just got a Nokia N950 dev kit and I am trying to build a program for it using the new SDK, which I've downloaded today. The problem is that there are some older libraries in the device than those which are used by the new SDK. The output looks like this for any project I try to create:

    Code:
    Preparing SFTP connection...
    Starting upload...
    Successfully uploaded package file.
    Installing package to device...
    warning, in file '/var/lib/dpkg/status' near line 663 package 'mp-harmattan-rm680-pr':
     missing description
    Selecting previously deselected package aaa.
    (Reading database ... 29156 files and directories currently installed.)
    Unpacking aaa (from .../developer/aaa_0.0.1_armel.deb) ...
    aegis-installing aaa (from 'com.nokia.maemo')
    dpkg: dependency problems prevent configuration of aaa:
     aaa depends on libqtcore4 (>= 4.7.4~git20110516); however:
      Version of libqtcore4 on system is 4.7.3~git20110329-0maemo1+0m6.
     aaa depends on libqtgui4 (>= 4.7.4~git20110516); however:
      Version of libqtgui4 on system is 4.7.3~git20110329-0maemo1+0m6.
    dpkg: error processing aaa (--install):
     dependency problems - leaving unconfigured
    Errors were encountered while processing:
     aaa
    Deployment failed.
    I've been googling the error, but there are no responses for it yet. I've also tried to update the libraries in the device by executing apt-get update, while being root. I've also tried apt-get install libqtgui4. Both say the libraries are up to date. I'm developing in Windows.

    Can anyone help? I can provide more information if needed. Thank you.

  2. #2
    Super Contributor
    Join Date
    Mar 2009
    Posts
    1,024

    Re: Qt SDK 1_1_3 cannot compile program for N950

    What firmware version are you using?
    A temporary "dirty" workaround for this is to remove "${shlibsepends}, ${miscepends}" from the "Depends:" field in the debian/control file.

  3. #3
    Registered User
    Join Date
    Oct 2009
    Posts
    56

    Re: Qt SDK 1_1_3 cannot compile program for N950

    According to the screen displayed after typing *#0000# it says:

    Code:
    V 1.2011.15-7_PR_RM680 Nxx

  4. #4
    Super Contributor
    Join Date
    Apr 2003
    Location
    USA, CA
    Posts
    7,191

    Re: Qt SDK 1_1_3 cannot compile program for N950

    That's a really outdated version. The SDK (at least 1.1.2) was based on 22-6... (week 22 build, where as your device has a firmware from week 15). Is your device a N950 distributed during the summer or an earlier prototype? If it is an earlier prototype, I am not sure if the one click flashers available on Nokia developer site will work for you...

    Hartti

  5. #5
    Nokia Developer Moderator
    Join Date
    Oct 2009
    Location
    Finland
    Posts
    327

    Re: Qt SDK 1_1_3 cannot compile program for N950

    Quote Originally Posted by hansorkrutor View Post
    According to the screen displayed after typing *#0000# it says:

    Code:
    V 1.2011.15-7_PR_RM680 Nxx
    As Hartti says, this is an outdated firmware revision use the one from https://www.developer.nokia.com/info...kFlashers.html (or give it to your Nokia contact if you have gotten it as part of some special or early access program or such).

  6. #6
    Registered User
    Join Date
    Oct 2009
    Posts
    56

    Re: Qt SDK 1_1_3 cannot compile program for N950

    New firmware did the job. In my case the quick erase flasher was the proper one.
    Thank you for your advices.

  7. #7
    Registered User
    Join Date
    Nov 2006
    Posts
    47

    Re: Qt SDK 1_1_3 cannot compile program for N950

    so what's your newest firmware version on N950?
    mine is 22-6 still met this issue.

    and how do you get it?

    and i get the firmware from: https://www.developer.nokia.com/info...kFlashers.html

  8. #8
    Super Contributor
    Join Date
    Apr 2003
    Location
    USA, CA
    Posts
    7,191

    Re: Qt SDK 1_1_3 cannot compile program for N950

    22-6 is the latest available currently

    Hartti

Similar Threads

  1. Replies: 2
    Last Post: 2011-08-02, 03:14
  2. Replies: 11
    Last Post: 2010-08-21, 12:11
  3. Replies: 2
    Last Post: 2009-11-03, 12:45
  4. Codewarrior: How to compile my program?
    By omarbilal in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 6
    Last Post: 2005-06-02, 22:27

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×