×

Discussion Board

Results 1 to 2 of 2
  1. #1
    Registered User
    Join Date
    Nov 2006
    Posts
    47

    Exclamation N950 app: voice recording and play packaging error to device: Package libqt4-multimed

    background: we develop a voice record app at N950, use audio input api.
    we almost finished the app, and try it well in the target :desktop output.
    but when we package it to Harmattan to n950, we meet below error:

    BEGIN failed--compilation aborted at c:/qtsdk/madde/madbin/dh_clean line 10.
    Installing package to sysroot ...
    c:\Users\nihoo\C;c:\qtsdk\madde\MyWorkerSpace\AudioInput\audioinput_0_0_1_armel.deb: No such file or directory
    c:\qtsdk\madde\targets\harmattan-nokia-meego-api\bin\ar.exe:
    Cannot find package name (in debian control file).
    Started uploading file 'C:\MyWorkerSpace\AudioInput\audioinput_0_0_1_armel.deb'.
    Successfully uploaded file 'C:\MyWorkerSpace\AudioInput\audioinput_0_0_1_armel.deb'.
    Installing package to device...
    (Reading database ...
    36758 files and directories currently installed.)
    Preparing to replace audioinput 0.0.1 (using .../audioinput_0_0_1_armel.deb) ...
    Unpacking replacement audioinput ...
    aegis-installing audioinput (from '')
    dpkg: dependency problems prevent configuration of audioinput:
    audioinput depends on libqt4-multimedia (>= 4.7.4~git20110516); however:
    Package libqt4-multimedia is not installed.
    dpkg: error processing audioinput (--install):
    dependency problems - leaving unconfigured
    Processing triggers for desktop-file-utils ...
    Processing triggers for hicolor-icon-theme ...
    Errors were encountered while processing:
    audioinput
    Deployment failed.
    Error while building project AudioInput (target: Harmattan)
    When executing build step 'Deploy to Harmattan device'


    any suggestion and idea?

  2. #2
    Nokia Developer Moderator
    Join Date
    Oct 2009
    Location
    Finland
    Posts
    327

    Re: N950 app: voice recording and play packaging error to device: Package libqt4-mult

    As per http://labs.qt.nokia.com/2010/05/06/...qt-multimedia/ the Multimedia module has been deprecated/reorganized into QtMultimediaKit and Phonon. It's weird that it works for you on the desktop (I don't have that package even on my desktop Linux install).

Similar Threads

  1. Replies: 3
    Last Post: 2011-11-06, 09:49
  2. Replies: 4
    Last Post: 2011-08-25, 00:00
  3. Can't install deb package on Nokia N950?
    By rishabh11 in forum Nokia N9
    Replies: 6
    Last Post: 2011-08-11, 20:21
  4. Error while creating Obj of player for voice recording.
    By maulik_ani in forum Mobile Java Media (Graphics & Sounds)
    Replies: 0
    Last Post: 2004-01-16, 11:35
  5. Replies: 0
    Last Post: 2004-01-16, 11:35

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •