×

Discussion Board

Results 1 to 10 of 10
  1. #1
    Registered User
    Join Date
    May 2010
    Posts
    29

    QA in Ovi Store failed: "No prompt for selecting a specific drive during installation

    I've submitted a Qt app for Symbian^3 to the Ovi Store QA. As before, the app's release-.sis is integrated with the smartinstaller.sis, so:
    make installer_sis QT_SIS_CERTIFICATE=<crt> QT_SIS_KEY=<key>
    I understand the smart installer is driving the installation procedure. Having passed successfully in the past, I was surprised to get the following response from Ovi Store QA a week ago:
    "When installing the content, the content is installed to C: drive by default without prompt for selecting a specific drive during installation."
    I went out to find the latest smartinstaller.sis, but it wasn't any more current than what I used for the app submission.
    I responded to QA asking where I could find a smartinstaller.sis that would drive the installation of the app in accordance with QA requirements, but no response back from Ovi Store QA.

    Anybody have an idea what I am doing wrong or where i can find a smart installer that provides the functionality QA is asking for?

  2. #2
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,165

    Re: QA in Ovi Store failed: "No prompt for selecting a specific drive during installa

    how does your pkg files look line ? and did you check the giudes on how to change them ?

  3. #3
    Super Contributor
    Join Date
    Oct 2008
    Location
    INDIA
    Posts
    2,326

    Re: QA in Ovi Store failed: "No prompt for selecting a specific drive during installa


  4. #4
    Registered User
    Join Date
    Feb 2008
    Location
    India, Nashik
    Posts
    816

    Re: QA in Ovi Store failed: "No prompt for selecting a specific drive during installa

    there is a simple solution, if your app instals on C: by default no offence just put a remark in the description stating clearly that this application will install on C: by default, thats it, and resubmit the app for QA

    -Vishal

  5. #5
    Registered User
    Join Date
    Feb 2008
    Location
    India, Nashik
    Posts
    816

    Re: QA in Ovi Store failed: "No prompt for selecting a specific drive during installa

    Quote Originally Posted by rahulvala View Post
    this is more specific link http://support.publish.ovi.com/wp-co...A-Failures.pdf /cc rahul

  6. #6
    Registered User
    Join Date
    May 2010
    Posts
    29

    Re: QA in Ovi Store failed: "No prompt for selecting a specific drive during installa

    Thanks for all the answers.
    The .pkg file is created by Qt Creator. Sure enough it specifies "c:" instead of "!:", as indicated in the PDF guide referenced by vdharankan.
    Looks like this is the root of the problem. Next question: Where in Qt Creator can I switch from "c:" to "!:"?
    I suspect this is a setting in the .pro file, under "symbian { ... }", but I could not find any documentation that shows how to set the installation drive.

  7. #7
    Super Contributor
    Join Date
    Oct 2008
    Location
    INDIA
    Posts
    2,326

    Re: QA in Ovi Store failed: "No prompt for selecting a specific drive during installa

    This will help you sure : How to install Qt app in directory

    Best regards,

  8. #8
    Registered User
    Join Date
    May 2010
    Posts
    29

    Re: QA in Ovi Store failed: "No prompt for selecting a specific drive during installa

    Understood, I used this documentation to create the application's .pro file.
    There does not seem to be any provision to set the destination drive. DESTDIR, which comes somewhat close, does not seem to have any impact on the package file.

  9. #9
    Registered User
    Join Date
    Jul 2011
    Posts
    57

    Re: QA in Ovi Store failed: "No prompt for selecting a specific drive during installa

    I got an app rejected for this, I just upgraded it from 4.6.3 to 4.7.3 and it worked fine without having to edit anything.

  10. #10
    Registered User
    Join Date
    May 2010
    Posts
    29

    Re: QA in Ovi Store failed: "No prompt for selecting a specific drive during installa

    Installing the most current SDK did the trick! It wasn't quite as seamless though.
    I decided to install the new release from scratch and not install it over the existing installation. After this fresh start, I had to change the following in Qt Creator's Projects/Targets window:
    - Two variables in the Symbian Build Environment still pointed to the old location (\NokiaQtSDK).
    - I had to add and select the build configuration Qt 4.7.3 for Symbian^3
    Lo and behold, the package file now points to "!:\", and the smart-installer-wrapped .sis now requests the drive during app installation.

    Thanks again for all the help.

Similar Threads

  1. Selecting a specific drive for installation.
    By paskuniak in forum Mobile Java General
    Replies: 4
    Last Post: 2011-08-08, 19:24
  2. "Installation failed!" and then "Select Access Point" dialog pops up
    By stolik in forum [Archived] Nokia Smart Installer for Symbian
    Replies: 5
    Last Post: 2011-03-05, 00:31
  3. QA failed - Reason: prompt to update and install Adobe Flash Lite during installation
    By supriyaakg in forum [Closed] Publishing to Nokia Store
    Replies: 4
    Last Post: 2010-07-19, 09:52
  4. Replies: 3
    Last Post: 2010-01-26, 08:05
  5. Installation failed - Ovi Store client
    By anatni in forum Mobile Java General
    Replies: 2
    Last Post: 2009-12-07, 08:53

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×