×

Discussion Board

Results 1 to 3 of 3
  1. #1
    Regular Contributor
    Join Date
    Dec 2010
    Posts
    228

    Question how to know if app is started normally or from auto start?

    hi,
    i am trying to implement the autostart in my application
    i am using the following link to do that:
    http://www.developer.nokia.com/Commu...ymbian_devices

    my question is how to know if the application is started from the autostart or from user ??
    any help about that?
    Thank you
    Rondo

  2. #2
    Regular Contributor
    Join Date
    May 2007
    Posts
    468

    Re: how to know if app is started normally or from auto start?

    I guess the only way to do this would be to write a starter app that is started on the boot which starts the actual app. The starter app would then let the real app know (by f.ex a central repository key, creating a certain file etc.) that it has started the app. Then the app should "nullify" the startup info (i.e. clear the cenrep key or delete the file).

    Jack

  3. #3
    Regular Contributor
    Join Date
    Oct 2008
    Location
    Oslo, Norway
    Posts
    329

    Re: how to know if app is started normally or from auto start?

    Quote Originally Posted by Jack Torrance View Post
    I guess the only way to do this would be to write a starter app that is started on the boot which starts the actual app. The starter app would then let the real app know (by f.ex a central repository key, creating a certain file etc.) that it has started the app. Then the app should "nullify" the startup info (i.e. clear the cenrep key or delete the file).

    Jack
    This is aready done in CS001564 - Implementing user-selectable autostart feature in Qt for Symbian. It has been recently updated to support Symbian^3 build targets as well, but that has not been tested too much yet - feedback appreciated.

    Note: When you test your autostart feature, turn off the 'silent install' feature in QtCreator project/deployment settings (or install the sis manually). Packages that are deployed using silent install are known to have problems with autostart.
    Last edited by treinio; 2011-10-03 at 12:33.

Similar Threads

  1. console app doesn't start at auto start
    By somnathbanik in forum Symbian
    Replies: 15
    Last Post: 2010-12-06, 15:05
  2. Auto Start Api
    By ahkhan in forum Symbian
    Replies: 5
    Last Post: 2008-11-29, 09:55
  3. Auto start and Auto installation
    By sunithadevim in forum Symbian
    Replies: 8
    Last Post: 2008-02-07, 04:58
  4. Auto Start Up
    By manjunath in forum Symbian
    Replies: 7
    Last Post: 2007-05-23, 11:22
  5. exe app to auto start (2ed)
    By shadow-2005 in forum Symbian
    Replies: 4
    Last Post: 2007-03-27, 10:04

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×