×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Registered User
    Join Date
    Jul 2011
    Posts
    20

    Problem when app start vía short url (Cannot load styles, preferences and javascript)

    I'm having trouble launching an app using the short url method. The thing is when the first page is loaded, it doesn't load the css styles, and cannot read the preferences (described in config.xml), and javascript behaviour is unpredictable. The only way to get things work is to reload the page. So far, this was, acceptable... but, when with times we end with a big problem here.
    Because of this, we haven't been able to validate our app with
    Nokia QA, that is required to publish the app in Ovi Store.
    So i am looking foward to solve this. But i found that this is happening in every app around i found around the web (including the app like "New Webs app proyect" that comes which the IDE for development (Nokia Web Developer Environment 1.2.0).
    So i guess this is a problem of the platform.. but again i don't know.
    ¿Is there another expriencing this type of problem?. ¿Any work around?

    I hope someone can help me.
    Grettins and thanks for advance.


    P.D: We are working with "X3-00" and "3710 FOLD" devices.

  2. #2
    Registered User
    Join Date
    Nov 2010
    Posts
    40

    Re: Problem when app start vía short url (Cannot load styles, preferences and javascr

    hi,

    i had the same problem, try using the "upload series 40 web app" option, it gives you a full url like this:
    http://dev-cloud1.browser.ovi.com/de...Go&type=webapp
    you can just use this part
    dev-wam.browser.ovi.com/wam/v1_0/clients/39162c53c546fa6f39a4e3fddd383e1/webapps/72fea6865715ce2d7675d347ffa539c/?name=News%20on%20the%20Go&type=webapp

    hope it works for you

  3. #3
    Nokia Developer Expert
    Join Date
    Jun 2008
    Location
    Tampere
    Posts
    833

    Re: Problem when app start vía short url (Cannot load styles, preferences and javascr

    Hi,

    Please make sure that you are using 1.0.2.26 version of Browser when testing.
    Preferences not working with short URL is a known issue. As a workaround you can use method proposed by jcospina.
    http://www.developer.nokia.com/Commu..._via_short_URL

    Br,
    Ilkka

  4. #4
    Registered User
    Join Date
    Jul 2011
    Posts
    20

    Re: Problem when app start vía short url (Cannot load styles, preferences and javascr

    As always, thanks Isalento!.
    I will give it a try!.

Similar Threads

  1. Problem with preferences.
    By rtf_const in forum Nokia Asha Web Apps
    Replies: 3
    Last Post: 2011-06-14, 11:15
  2. emulator preferences problem
    By yaront in forum Symbian Tools & SDKs
    Replies: 10
    Last Post: 2010-05-20, 12:54
  3. Problem Network Preferences 3rd Emu
    By bherrera in forum Symbian Tools & SDKs
    Replies: 1
    Last Post: 2006-02-15, 19:34

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×