×

Discussion Board

Results 1 to 2 of 2
  1. #1
    Registered User
    Join Date
    Sep 2011
    Posts
    5

    Using smart installer for Qt Mobility 1.1 dependency on S60 FP1/ FP2

    Hi,

    I am developing an application which uses QNetworkConfigurationManager class available in Qt 4.7, as well as Qt Mobility 1.1.

    Now as documented Qt mobility 1.1 should work on S60 FP2 (infact i have been able to get it to work when installing my application sis file individually). However if i use the smart installer to wrap my sis and then try to install on an FP2 device, the installer tried to download Qt 4.7.3 and ends up throwing a "Device not supported error".

    The configuration i need the smart installer to install for my app is Qt 4.6.3 + Qt Mobility 1.1 on FP1/ FP2 devices. Is this possible.

    Here is the ADM log output,
    29/09/2011 11:26:03 Installer pkg on ÿ: (1)
    29/09/2011 11:26:03 * Parsing 'c:\adm\MyMobibook.sis'
    29/09/2011 11:26:03 + SetState(): 1 -> 2
    29/09/2011 11:26:03 + BuildDepTreeL(0)
    29/09/2011 11:26:03 * Processing 0x2001E61C (0, 0)
    29/09/2011 11:26:03 Package 0x2001E61C: v4.07.3 to be downloaded
    29/09/2011 11:26:03 + SetState(): 2 -> 3
    29/09/2011 11:26:03 Downloading CHANGES: '2001e61c_changes.xml'
    29/09/2011 11:26:04 Starting download
    29/09/2011 11:26:04 DL 33292/ 33292 (0.8 s, 38.64 kB/s) (total: 32 kB, 0.8 s, avg 38.64 kB/s) OK
    29/09/2011 11:26:04 + SetState(): 3 -> 4
    29/09/2011 11:26:04 + ParseChangesFileL(): 'C:\system\adm\2001e61c_changes.xml'
    29/09/2011 11:26:05 [0x2001E61C] v0.00.0 installed
    29/09/2011 11:26:05 [0x2001E61C] v4.07.3 requested
    29/09/2011 11:26:05 + SM::RunError(): 4, 20
    29/09/2011 11:26:05 ! Package 0x2001E61C v4.07.3 (qt) not available for 0x20014DD0
    29/09/2011 11:26:05 Exiting due to failure 4
    29/09/2011 11:26:05 + SetState(): 4 -> 16
    29/09/2011 11:26:05 + CADMAppUi::HandleFailure(): 16. err=4, m=3
    29/09/2011 11:26:05 - CADMAppUi::HandleFailure(): 0
    29/09/2011 11:26:06 + SetState(): 16 -> 15
    29/09/2011 11:26:06 About to uninstall wrapper
    29/09/2011 11:26:06 + SetState(): 15 -> 18
    29/09/2011 11:26:06 Exit (4)
    29/09/2011 11:26:06 Uninstalling wrapper 0xA000D7CE

  2. #2
    Registered User
    Join Date
    Sep 2011
    Posts
    5

    Re: Using smart installer for Qt Mobility 1.1 dependency on S60 FP1/ FP2

    This issue has been fixed after i included in the pkg file and built the code on Qt 1.0 SDK for Qt 4.6.3.

    ; Default dependency to Qt libraries
    (0x2001E61C), 4, 6, 3, {"Qt"}

    ; Default dependency to QtMobility libraries
    (0x2002AC89), 1, 0, 2, {"QtMobility"}

Similar Threads

  1. Installation with latest Smart Installer and Qt4.7 dependency fails on N8!
    By oskarinarki in forum [Archived] Nokia Smart Installer for Symbian
    Replies: 12
    Last Post: 2011-05-24, 10:22
  2. Smart installer & Qt Mobility release
    By Sorcery-ltd in forum [Archived] Nokia Smart Installer for Symbian
    Replies: 5
    Last Post: 2011-05-04, 18:03
  3. Mobility compatible in 3rd and 5th (+smart installer on Qt 4.6.2)
    By tineursic in forum [Archived] Qt Mobility Project
    Replies: 3
    Last Post: 2010-11-16, 08:46
  4. Smart installer server updated with Mobility 1.0.2
    By Jack Torrance in forum [Archived] Nokia Smart Installer for Symbian
    Replies: 1
    Last Post: 2010-08-14, 11:13
  5. Does Qt Mobility API included in the smart installer?
    By edwinywmak in forum [Archived] Nokia Smart Installer for Symbian
    Replies: 7
    Last Post: 2010-07-17, 07:40

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •