×

Discussion Board

Results 1 to 10 of 10
  1. #1
    Registered User
    Join Date
    Jun 2011
    Posts
    11

    Will symbian 3rd edition devices works with Qt support ? like the E series phones ?

    Will symbian 3rd edition devices works with Qt support ? like the E series phones ?

  2. #2
    Registered User
    Join Date
    Mar 2010
    Posts
    8

    Re: Will symbian 3rd edition devices works with Qt support ? like the E series phones

    S60 3rd edition phones like E72 and E5 should support Qt 4.6 but not Qt 4.7. However, Symbian^3 devices like E7 support latest Qt (4.7).

  3. #3
    Registered User
    Join Date
    Jun 2011
    Posts
    11

    Re: Will symbian 3rd edition devices works with Qt support ? like the E series phones

    hi ,

    Presently I am using Qt SDK 1.1 for Symbian^3 & 5th Edition phones without using Qt 4.7 features (like Qt Quick / QML) , so my question is that the same code should work for the 3rd edition device ?
    But I am getting an installation error when I try to install the App in a 3rd edition device (i.e E71) . I am building the App for Symbian^1 present in the Qt SDK .

    Please tell me what can be wrong ?

  4. #4
    Super Contributor
    Join Date
    Oct 2008
    Location
    INDIA
    Posts
    2,326

    Re: Will symbian 3rd edition devices works with Qt support ? like the E series phones

    If you want your application to be run in the new as well old Symbian^1 devices ,then pack your application with Nokia smart installer for Symbian.

    Search in the wiki Nokia smart installer for Symbian

    regards,

  5. #5
    Registered User
    Join Date
    Mar 2003
    Posts
    2

    Re: Will symbian 3rd edition devices works with Qt support ? like the E series phones

    I read there is a way, with help of smart installer we can run QT application on nokia s60 3rd edition Feature pack 1.

    I am developing a QT application. When I tried to build a sis package, I made sure the smart installer is enabled.


    I am using QT Creator (Qt Creator 2.2.0 : Based on Qt 4.7.4 (32 bit))->Projects->Symbian Devices->Run (Self-signed certificate), and checked Create Smart Installer Package.
    Is there any installation step missed out?
    On running it generates two sis package, test.sis and test_installer.sis

    On installing the test_installer.sis these are the messages I get in order
    'Application not compatible with phone. Continue anyway?' when I continue->
    'Nokia Smart Installation' pop's up, on continue->
    'Preparing installation message' ->
    'Reverting changes' ->
    'Device not supported message'

    What is the problem. The device I used to install is Nokia e71 (s60 3rd Edition), with Software Installation set All, Online Certificate check set Off.

    Is there any comprehensive list of the QT supported devices (irrespective of device manufacturer).


    Thanks in advance.

  6. #6
    Nokia Developer Champion
    Join Date
    Mar 2003
    Location
    Finland
    Posts
    9,545

    Re: Will symbian 3rd edition devices works with Qt support ? like the E series phones

    Quote Originally Posted by jmalik View Post
    Is there any comprehensive list of the QT supported devices (irrespective of device manufacturer).
    Nokia: http://www.developer.nokia.com/Devic...ns/?filter1=qt

    http://developer.qt.nokia.com/wiki/Support_for_Symbian

    Note also exceptions, like the Nokia N96, which is an S60 3rd Ed. FP2 based device, but based on ARM9, instead of ARM11, so Qt doesn't run on it at all. Some models might also have too little storage space to be able to accommodate Qt; e.g., the N81 is S60 3rd Ed FP1, but with only 16MB of free memory on the C-drive/phone memory as it comes from the factory, making it hard to install large runtimes that insist on being installed on the C-drive for the most part.

  7. #7
    Super Contributor
    Join Date
    Jul 2008
    Posts
    2,020

    Re: Will symbian 3rd edition devices works with Qt support ? like the E series phones

    For Qt on S60v3, you are SOL - not even bugs will be fixed anymore. See here:
    http://tamss60.tamoggemon.com/2011/1...xes-for-s60v3/

    I did some testing on E71 and E63, and can say that the apps "barely" work. Dont expect much, though!
    The lines above are the best I have to offer.If anyone of you is of more advanced knowledge, I ask for your patience and understanding! - unknown arab poet
    http://www.tamoggemon.com - Symbian blog - Windows Phone blog
    My other blogs:
    webOS blog iPhone blog BlackBerry blog Samsung bada blog Android blog

  8. #8
    Registered User
    Join Date
    Jun 2011
    Posts
    11

    Re: Will symbian 3rd edition devices works with Qt support ? like the E series phones

    Hi ,

    My Qt app works fine on 3.x devices but for this I need to manually install all the Qt binaries before I install my App .
    So the way i thought was to embed the Qt.sis to my App's package . As the Nokia smart installer doesnt work fine for 3.x devices therefore manual/embedded installation is needed . so is it a good idea to embed the Qt.sis to my App ?

    If yes I tried embedding it with the package id : 0x2001E61C as got from http://www.developer.nokia.com/Commu...er_for_Symbian , but it says wrong id when the package file is used for creating the sis . I am using the Qt 4.7.3 and Qt installers are of Symbian^1 sdk as given with the QtSDK .

    Please help mein this .

  9. #9
    Nokia Developer Champion
    Join Date
    Mar 2003
    Location
    Finland
    Posts
    9,545

    Re: Will symbian 3rd edition devices works with Qt support ? like the E series phones

    Quote Originally Posted by swatisaha View Post
    Hi ,
    is it a good idea to embed the Qt.sis to my App ?
    Yes, and no.

    It is not a good idea, if you wish to sell/distribute your app through the Nokia/Ovi Store. On the other hand, as Nokia requires the use of Smart Installer for Qt apps, and do not support embedding Qt, or an external dependency to a separate Qt installation, it in effect means that Nokia/Ovi Store does not support sales/distribution of Qt apps for S60 3.x device at all in any case.

    It is not a good idea, as it makes your app installation file huge (beware of installation is because of insufficient memory on some of the more limited S60 3.x devices). E.g., the N81 was horrible (the C-drive had only something like 17MB free as it came from the factory, and with contacts, calendar, messages defaulting to the C-drive without installing any apps, it soon dwindled to 10MB or less, causing issues with app installations, even when you tried to install on the mass memory or memory card).

    It is not a good idea, if everyone does it and, uninstalling some other app also embedding Qt, might end up uninstalling Qt, too, and thus rendering your app unusable as well.

    Of course, it is the only way to guarantee that Qt is there for your app, if Smart Installer doesn't work (isn't supported by Nokia).

    If you have a limited user base, it might still be better (especially as you can't use Nokia/Ovi Store anyway for distributing it), to provide a separate Qt installation file for your customers, and require/request them to install it first, before your app.

  10. #10
    Registered User
    Join Date
    Jun 2011
    Posts
    11

    Re: Will symbian 3rd edition devices works with Qt support ? like the E series phones

    Thanks for your reply .

    So as found from the URL : http://www.developer.nokia.com/Commu...ported_Devices . They say that devices after 3.1 versions are only compatible with smart installer . For now if I use a Qt 4.7.3 and wrap it with smart installer and try installing in 3.1/3.2 devices , will it automatically try to get the 4.6.3 Qt binaries from the nokia server or do I need to build my code for Qt 4.6.0 and then wrap it up with smart installer ?

Similar Threads

  1. Replies: 1
    Last Post: 2010-08-28, 07:44
  2. Replies: 12
    Last Post: 2009-03-23, 10:35
  3. Replies: 1
    Last Post: 2007-09-21, 07:58
  4. Replies: 2
    Last Post: 2007-05-07, 07:44
  5. How many bluetooth devices can Nokia phones support simultaneously?
    By soulshagga in forum Bluetooth Technology
    Replies: 0
    Last Post: 2006-10-30, 02:24

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •