×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Registered User
    Join Date
    Jun 2010
    Location
    Palestine/Ramallah
    Posts
    76

    Question User Agent returns UNTRUSTED/1.0

    Dears,
    I created web app, which gets text data from server, when i send the request from mobile I should detect at server side if the request came from mobile and what its model, but when i install the app on my Nokia N95 and sent the request, Iget User-Agent : UNTRUSTED/1.0

    Note: My app is not singed.
    is it will be like
    User-Agent : Mozilla/5.0 (SymbianOS/9.2; U; Series60/3.1 NokiaN95/30.0.015; Profile/MIDP-2.0 Configuration/CLDC-1.1 )
    after signing?

  2. #2
    Nokia Developer Champion
    Join Date
    Apr 2007
    Posts
    2,708

    Re: User Agent returns UNTRUSTED/1.0

    actually Im not sure if the signing will help at all
    Note: please don't send private questions to me, as I don't have time to provide private support. All such questions should be posted on public forums, where I and others can see and answer them.

  3. #3
    Nokia Developer Champion
    Join Date
    Feb 2009
    Location
    Noida, India
    Posts
    3,073

    Re: User Agent returns UNTRUSTED/1.0

    Quote Originally Posted by mohammad_kaied View Post
    Dears,
    I created web app, which gets text data from server, when i send the request from mobile I should detect at server side if the request came from mobile and what its model, but when i install the app on my Nokia N95 and sent the request, Iget User-Agent : UNTRUSTED/1.0

    Note: My app is not singed.
    is it will be like
    User-Agent : Mozilla/5.0 (SymbianOS/9.2; U; Series60/3.1 NokiaN95/30.0.015; Profile/MIDP-2.0 Configuration/CLDC-1.1 )
    after signing?
    I suggest to try on other devices or try request thu any other j2me app running on the device - it should give full user agent or it might be some problem on the server end in reading the user-agent.

    Test both your client server in local hosting with emulator.

    If its a simple HTTP request signing alone cannot help - it looks to be diff. issue.
    thanks,
    ~Amitabh
    (Champion of the Month -Aug'13)
    Follow me on my blog for Innovative Mobile Apps

  4. #4
    Registered User
    Join Date
    Jun 2010
    Location
    Palestine/Ramallah
    Posts
    76

    Re: User Agent returns UNTRUSTED/1.0

    if I call the link from the mobile browser, the server prints this
    User-Agent : Mozilla/5.0 (SymbianOS/9.2; U; Series60/3.1 NokiaN95/30.0.015; Profile/MIDP-2.0 Configuration/CLDC-1.1 )

    but from the app the UNTRUSTED/1.0 is printed

    The call code is:
    httpConn = (HttpConnection) Connector.open(url);
    httpConn.setRequestMethod(HttpConnection.GET);
    httpConn.setRequestProperty("User-Agent", "Profile/MIDP-2.0, Configuration/CLDC-1.1");
    httpConn.setRequestProperty("UID", encStr.substring(1, 12));
    httpConn.setRequestProperty("PW", encStr.substring(19, 36));
    httpConn.setRequestProperty("Size", "4587");
    httpConn.setRequestProperty("Lang","en);

Similar Threads

  1. N73 user agent
    By rupam_jaiswal in forum Browsing and Mark-ups
    Replies: 1
    Last Post: 2009-01-29, 08:35
  2. User agent
    By sunil.dce in forum Mobile Java General
    Replies: 2
    Last Post: 2007-01-29, 08:16
  3. About User-Agent
    By linjunan in forum Mobile Java Networking & Messaging & Security
    Replies: 2
    Last Post: 2003-12-29, 01:15

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •