×

Discussion Board

Page 1 of 2 12 LastLast
Results 1 to 15 of 24
  1. #1
    Regular Contributor
    Join Date
    Jul 2011
    Posts
    100

    help with my program

    'm doing a project and I have problems with one hand. The particular part is (imagen.cpp) the rest everything works perfectly. I would like someone to take a look to see if you can tell me where is the error. The works I do not display an image sent from a camera connected online. Here's an inline link to megaupload.
    thank you very much.

    link:

    http://www.megaupload.com/?d=ML5D7X00

  2. #2
    Nokia Developer Expert
    Join Date
    Aug 2008
    Posts
    43

    Re: help with my program

    Hi,
    I recommend to file a ticket: http://www.developer.nokia.com/Resources/Support/

  3. #3
    Regular Contributor
    Join Date
    Jul 2011
    Posts
    100

    Re: help with my program

    I just want to know what my mistakes, I've tried everything and just makes me pointers errors
    thank you very mauchs

  4. #4
    Regular Contributor
    Join Date
    May 2010
    Posts
    362

    Re: help with my program

    Don't mind mimuurin's comment.

    Most likely you won't find anyone here that would take the hours of work to fix the code.

    I suggest you try to narrow the scope and post the particular part or idea that is not working on your code and we might be able to help you.

    You should also say how it is failing - what kind of errors you are getting and so on.
    By debugging you should be able to tell us which "pointers" are failing.

  5. #5
    Regular Contributor
    Join Date
    Jul 2011
    Posts
    100

    Re: help with my program

    thank you very much,
    the code works correctly but I get problems compiling imagen.cpp file.
    My intention is to form an image from a buffer and display it on screen, when you load from a directory no problem doing so from the buffer Codeof modify this:
    ImageWidth int = 800;
    imageHeight int = 600;
    bytesPerPixel int = 4 / / 4 for RGBA, 3 for RGB
    int format = QImage:: Format_ARGB32 / / this is the pixel format - check Qimage:: Format enum type for more options
    QImage image (yourData, ImageWidth, imageHeight, ImageWidth * bytesPerPixel, format);

    but I get errors pointers.
    thanks again

  6. #6
    Regular Contributor
    Join Date
    May 2010
    Posts
    362

    Re: help with my program

    What kind of errors exactly?

  7. #7
    Regular Contributor
    Join Date
    Jul 2011
    Posts
    100

    Re: help with my program

    errors are these:
    : -1: Error: .. teratermobileimagen.cpp: No such file or directory

    : -1: Error: no input files

  8. #8
    Super Contributor
    Join Date
    Jul 2008
    Posts
    2,020

    Re: help with my program

    Could it be that you are copying this from another project?
    The lines above are the best I have to offer.If anyone of you is of more advanced knowledge, I ask for your patience and understanding! - unknown arab poet
    http://www.tamoggemon.com - Symbian blog - Windows Phone blog
    My other blogs:
    webOS blog iPhone blog BlackBerry blog Samsung bada blog Android blog

  9. #9
    Registered User
    Join Date
    Oct 2010
    Posts
    256

    Re: help with my program

    try cleaning and rebuilding (your) project. I had no problem building and running it on the simulator:

    Starting C:\teratermobile\teratermobile-build-simulator-Simulator_Qt_for_MinGW_4_4__Qt_SDK__Debug\debug\teratermobile.exe...
    C:\teratermobile\teratermobile-build-simulator-Simulator_Qt_for_MinGW_4_4__Qt_SDK__Debug\debug\teratermobile.exe exited with code 0

  10. #10
    Regular Contributor
    Join Date
    Jul 2011
    Posts
    100

    Re: help with my program

    I did the project, and added the top linia that appear because someone said I could do so, but I do not work, it is not a copy.
    jetrix:
    it works for you? How do you added? I included myself in the imagen.cpp and compile, have you edited any files?
    thank you very much

  11. #11
    Regular Contributor
    Join Date
    Jul 2011
    Posts
    100

    Re: help with my program

    forgive compilation mode was in release, to change it to debug I get the following error:

    C:\ejemplos_qt\teratermobile-build-simulator\..\teratermobile\imagen.cpp:96: error: no matching function for call to 'QImage::QImage(QBuffer*&, int&, int&, int, int&)'

  12. #12
    Super Contributor
    Join Date
    Jul 2008
    Posts
    2,020

    Re: help with my program

    Check the syntax of the call in question.

    Maybe the overload you use is not in the version you use.
    The lines above are the best I have to offer.If anyone of you is of more advanced knowledge, I ask for your patience and understanding! - unknown arab poet
    http://www.tamoggemon.com - Symbian blog - Windows Phone blog
    My other blogs:
    webOS blog iPhone blog BlackBerry blog Samsung bada blog Android blog

  13. #13
    Regular Contributor
    Join Date
    Jul 2011
    Posts
    100

    Re: help with my program

    How I can rule out a header of image data coming from the buffer?
    i think that's the problem
    greetings and thanks

  14. #14
    Regular Contributor
    Join Date
    May 2010
    Posts
    362

    Re: help with my program

    That can't be the cause of the compiling error.

    Try running Build->run qmake.
    And then run. Just to be sure.

  15. #15
    Regular Contributor
    Join Date
    Jul 2011
    Posts
    100

    Re: help with my program

    I do not mean and the fayo of compilation, the compile-fayo is due to improper use of pointers, but do not know which
    Can anyone compile my code?

Similar Threads

  1. [moved] 5800 program menu stays black (no program icons)
    By ---___db___--- in forum Symbian User Interface
    Replies: 13
    Last Post: 2009-02-20, 12:37
  2. Can a Symbian C++ client program communicate with a program residing on a webserver ?
    By razas in forum Symbian Networking & Messaging (Closed)
    Replies: 21
    Last Post: 2007-11-19, 17:33
  3. Connecting Java(J2SE) program on PC with SymbianC++ program on mobile using bluetooth
    By dotmilind in forum Symbian Networking & Messaging (Closed)
    Replies: 0
    Last Post: 2006-03-25, 23:10
  4. Replies: 1
    Last Post: 2005-05-24, 02:26

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×