×

Discussion Board

Page 3 of 3 FirstFirst 123
Results 31 to 39 of 39
  1. #31
    Registered User
    Join Date
    Dec 2004
    Location
    Cape Town / Singapore
    Posts
    51

    Re: Symbian Belle Plugin - lot of bugs?

    Hey Flotron

    Thanks for your reply, I will see if I can update to the E6 Belle plug-in today - talking about the E6 (touch), wow, worst touch integration ever, what a great phone completely messed up! Concerning your problem with your plug-ins not updating, are you using Windows 7 / Vista - if so you probably have to run as Administrator to have rights to update. I also found that if you have Dropbox running on your theme working folder, you run into some strange issues (compile errors, roll-backs of latest edits).

    S

  2. #32
    Registered User
    Join Date
    Dec 2004
    Location
    Cape Town / Singapore
    Posts
    51

    Re: Symbian Belle Plugin - lot of bugs?

    OK, so finally got it working, these are the steps I took:

    1) During first 1-3 seconds of Carbide.UI window displaying, go to : Window > Preferences > General > Startup and Shutdown and uncheck "Product Support" and "Startuptip Plug-in". This will stop your advanced preferences and functions such as Help > Check for Updates and Help > Install New Software from disappearing from the menus once Carbide.UI has fully loaded. If you don't see the "General" section under your preferences then you were too late clicking Window > Preferences, restart and try again!
    2) Now that you can see your preferences properly, go to Preferences > Install/Update > Available Software Sites.
    3) Select each repository and press "Reload" to refresh all the latest caches (I suspect my repositories somehow got out of sync)
    4) Now go to Help > Install New Software
    5) Choose to work with the "${p2.metadata.repo.name}"
    6) Unlick "Group items by category" otherwise you will see no items
    7) Select the Symbian Belle plugin and click Next
    8) It will install some dependencies and then warn you that there are some unsigned items, click to continue, Carbide will prompt you to restart, after that you should have the plug-in in your drop-down!

    Others have suggested running eclipse.exe -clean - I didn't try that, maybe that would help also.

    Stefan

  3. #33
    Registered User
    Join Date
    Dec 2004
    Location
    Cape Town / Singapore
    Posts
    51

    Unhappy Re: Symbian Belle Plugin - lot of bugs?

    So after finally getting the latest Belle plug-in to work, I'm disappointed to say that it's actually not worth it. My themes compiled with the older S^3 plugin gives me much better results in terms of application icon skinning, with the latest Belle-version icons like Maps, Software Update etc. are all back to default, even though they are defined in the IDE. There is really no reason to use the Belle plug-ins to compile a theme with custom icons / white accents. It's like 1 step forward and 2 steps back here at the moment.

  4. #34
    Registered User
    Join Date
    Mar 2008
    Posts
    77

    Re: Symbian Belle Plugin - lot of bugs?

    yes, this belle plugin is practically useless. I can't upgrade my old symbian anna themes to belle because i can't skin anything

  5. #35
    Registered User
    Join Date
    Dec 2004
    Location
    Cape Town / Singapore
    Posts
    51

    Re: Symbian Belle Plugin - lot of bugs?

    I was able to roll back to the Symbian^3 Basegraphics plugin that works the way it's supposed to. But there was no way to roll back officially, and there has been no answers on this forum on how to do it - luckily I had a snapshot of my dev environment from 4 months ago on another drive, otherwise we would have been in serious trouble in terms of making our deadlines. After getting 0 support from Nokia staff on this forum, I have come to the conclusion that you can no longer professionally create themes with the latest software, pity, because I know the Carbide.UI team has done some great work in the past.

  6. #36
    Registered User
    Join Date
    Mar 2008
    Posts
    77

    Re: Symbian Belle Plugin - lot of bugs?

    woo hoo! 1.8 plugin now available!

    hope it works!

    finger crossed

  7. #37
    Registered User
    Join Date
    Mar 2008
    Posts
    77

    Thumbs down Re: Symbian Belle Plugin - lot of bugs?

    Wow.. same history, nothing change in 1.80 and nothing skinned.

    Just look the main screen


  8. #38
    Registered User
    Join Date
    Dec 2004
    Location
    Cape Town / Singapore
    Posts
    51

    Re: Symbian Belle Plugin - lot of bugs?

    Can someone from Nokia let us know what are the new functionality / limitations of 1.8 plug-in? So we can make the decision before we risk upgrading and then risk DAYS to get things working again / starting from scratch / rolling-back (which is currently not supported).

  9. #39
    Registered User
    Join Date
    Jul 2008
    Location
    Pokhara/Nepal
    Posts
    119

    Re: Symbian Belle Plugin - lot of bugs?

    @breakdesign
    added new icons, some elements are back, fixed some bugs.

    @flotron
    plugin cannot fix it as discussed earlier.
    may be new FW will fix it but I'm not sure.

Similar Threads

  1. Symbian Belle SDK (beta) released
    By ltomuta in forum Symbian Tools & SDKs
    Replies: 55
    Last Post: 2012-06-01, 09:07
  2. Symbian Belle compilation issue
    By chintandhruva in forum Symbian Tools & SDKs
    Replies: 7
    Last Post: 2011-11-22, 17:42
  3. Why called Symbian Anna, Symbian Belle?
    By patrickz in forum Symbian
    Replies: 7
    Last Post: 2011-08-25, 11:03

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •