HI andrew,

i got following reply from QA team, i am really unable to find how to resolve the error:

Failed QA.
SUMMARY: The following disclaimer should be included in the metadata for the devices: N82, N95, N95_8GB and E90 Communicator to pass. Disclaimer: "Some Widget applications may not work on early device software versions (firmware) on some devices. To ensure this Widget application functions properly, it is recommended that your device is updated with the latest device software by using Nokia Software Updater."

thanks
-Sushant