×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Registered User
    Join Date
    Oct 2009
    Posts
    82

    Question sis installation for Symbian1 fails with Smart Installer, but succeeds for Symbian3

    Hi,

    I have an application sis built against Symbian1Qt473 and Symbian3Qt473.
    Both install fine on 5800 XM and C7 respectively. When wrapped in to Smart Installer however, the Symbian1 version stops installing.

    from C:/logs/ADM/log-boot.txt I see:

    ...
    31/10/2011 12:25:22 ADM is up-to-date (v1.35.0 / v1.35.0)
    31/10/2011 12:25:22 + RequestState(): 3->6
    31/10/2011 12:25:22 + LaunchAdm()
    31/10/2011 12:25:22 LaunchCtrl: 3
    31/10/2011 12:25:22 len 95
    31/10/2011 12:25:22 Launching ADM.exe '1519 4 537054415 8 3 e:\private\2002CCCE\import\AWordFree.sis'
    31/10/2011 12:25:22 Revealing ADM menu icon
    31/10/2011 12:25:22 - LaunchAdmL(): 0
    31/10/2011 12:25:22 + RequestState(): 6->7
    31/10/2011 12:25:22 + StateDownloadL()
    31/10/2011 12:25:23 - Download()
    31/10/2011 12:25:23 + RequestState(): 7->9
    31/10/2011 12:25:23 DlSt= 15, PrSt= 0
    31/10/2011 12:25:23 + RequestState(): 9->9
    31/10/2011 12:25:23 + RequestState(): 9->9
    31/10/2011 12:25:23 + RequestState(): 9->9
    31/10/2011 12:25:23 + RequestState(): 9->9
    31/10/2011 12:25:23 + ExitApp(9): 0
    31/10/2011 12:25:23 + CStateMachine::Stop()
    31/10/2011 12:25:26 + StopWaitNote(6)
    31/10/2011 12:25:26 + CStateMachine::RunError(-1003)
    31/10/2011 12:25:31 ~SmartInstaller()
    31/10/2011 12:25:31 ~StateMachine()
    31/10/2011 12:25:31 DlSt= 13, PrSt= 0
    31/10/2011 12:25:31 SmartInstaller bootstrap ends

    And from log.txt I see:

    31/10/2011 12:25:41 Building dependency list
    31/10/2011 12:25:41 Processing [0x2002AF5F] v0.50.0 (0)
    31/10/2011 12:25:41 Processing [0x20013851] v1.07.5 (0)
    31/10/2011 12:25:41 Processing [0x2000F866] v1.07.0 (0)
    31/10/2011 12:25:41 Processing [0x200110CB] v1.07.0 (0)
    31/10/2011 12:25:41 Processing [0x2001E61C] v4.07.3 (0)
    31/10/2011 12:25:41 Processing [0x2002AC89] v1.01.3 (0)
    31/10/2011 12:25:41 Processing [0x200267C2] v4.07.3 (0)
    31/10/2011 12:25:41 Processing [0x2004B4DB] v1.00.1 (0)
    31/10/2011 12:25:41 -> to fetch list
    31/10/2011 12:25:41 Removing downloaded files
    31/10/2011 12:25:41 + SetState(): 7 -> 8
    31/10/2011 12:25:41 SysDrive C: Free 24104960 (22.99 MB)
    31/10/2011 12:25:41 Drive E: Free 2365644800 (2,256.05 MB)
    31/10/2011 12:25:41 Download drive C: free 23449600 (22.36 MB)
    31/10/2011 12:25:41 Download size 0 (0)
    31/10/2011 12:25:41 PkgUid 0x2004B4DB: InstDrive C:, prio 0, size 0
    31/10/2011 12:25:41 Nothing to download, dependencies OK.
    31/10/2011 12:25:41 + SetState(): 8 -> 14
    31/10/2011 12:25:41 Finding root package
    31/10/2011 12:25:41 Root: UID 0x2004B4DB, 'AWordFree'
    31/10/2011 12:25:41 * Installing AppSis 0x2004B4DB 'e:\private\2002CCCE\import\AWordFree.sis' to E:
    31/10/2011 12:25:41 + SilentInstallPackage(): 'e:\private\2002CCCE\import\AWordFree.sis' to E:
    31/10/2011 12:27:08 CInstallManager: Install completed (-30478). 0
    31/10/2011 12:27:08 HandleInstallCompletedL(-30478): 14
    31/10/2011 12:27:08 + SetState(): 14 -> 16
    31/10/2011 12:27:08 + CADMAppUi::HandleFailure(): 16. err=5, m=3
    31/10/2011 12:27:08 - CADMAppUi::HandleFailure(): 0
    31/10/2011 12:27:09 DlSt= 13, PrSt= 0, L=0
    31/10/2011 12:27:10 + CreateInstallationResumeInfo()
    31/10/2011 12:27:10 Saving state for 'AWordFree' (7)
    31/10/2011 12:27:11 Adding info: 0x2002AF5F
    31/10/2011 12:27:11 Adding info: 0x20013851
    31/10/2011 12:27:11 Adding info: 0x2000F866
    31/10/2011 12:27:11 Adding info: 0x200110CB
    31/10/2011 12:27:11 Adding info: 0x2001E61C
    31/10/2011 12:27:11 Adding info: 0x2002AC89
    31/10/2011 12:27:11 Adding info: 0x200267C2
    31/10/2011 12:27:11 - CreateInstallationResumeInfo(): 0
    31/10/2011 12:27:11 + SetState(): 16 -> 18
    31/10/2011 12:27:11 Exit (14)

    Any idea what goes wrong?
    Grego
    http://mpaja.com/

  2. #2
    Registered User
    Join Date
    Oct 2009
    Posts
    82

    Re: sis installation for Symbian1 fails with Smart Installer, but succeeds for Symbia

    Hmm... further investigation seems to point to Inneractive Symbian1Qt473 SDK, for some yet unknown reason its inclusion will cause Smart Installer to fail for my app.
    I forwarded the question to Inneractive, let's see what they respond. In the meanwhile, please enlighten us if you know what is going on.
    Grego
    http://mpaja.com/

  3. #3
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: sis installation for Symbian1 fails with Smart Installer, but succeeds for Symbia

    Any answer from Inneractive?
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  4. #4
    Registered User
    Join Date
    Oct 2009
    Posts
    82

    Re: sis installation for Symbian1 fails with Smart Installer, but succeeds for Symbia

    The issue resolved itself somehow when I installed QtSDK 1.1.2 from scratch to a new virtual machine and used that to build the Symbian 1 package.
    Now that also works with Inneractive SDK.
    So chalking it up to gremlins for now...
    Grego
    http://mpaja.com/

Similar Threads

  1. Molome Installation Failed with Smart Installer
    By whousah in forum [Archived] Nokia Smart Installer for Symbian
    Replies: 2
    Last Post: 2011-06-22, 22:13
  2. Installation with latest Smart Installer and Qt4.7 dependency fails on N8!
    By oskarinarki in forum [Archived] Nokia Smart Installer for Symbian
    Replies: 12
    Last Post: 2011-05-24, 10:22
  3. smart installer fails with “Certificate error contact application supplier”.
    By jscurtis in forum [Archived] Nokia Smart Installer for Symbian
    Replies: 2
    Last Post: 2011-01-16, 15:12
  4. Installation of smart installer fails on E72
    By andrevw in forum [Archived] Nokia Smart Installer for Symbian
    Replies: 0
    Last Post: 2010-02-18, 12:06

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×