×

Discussion Board

Results 1 to 6 of 6
  1. #1
    Registered User
    Join Date
    May 2011
    Posts
    21

    Media quality failed problem

    Hi,

    I'm trying to publish an application in ovi store for s40 devices. But the media item was failed again and again three times, despite of my changes on application. I would like to ask what should I do to fix the bug below.

    SUMMARY: Display name for the content is different than the one on the device.
    ACTUAL RESULT: Display name for the content item doesn't match with the one on the device.
    EXPECTED RESULT: Information displayed in the metadata is consistent with the submitted content item. Display name accurately describes the content item. Display name for the content item does not need to match exactly with the content item as long as the names are expressing closely related meanings.
    CORRECTIVE ACTIONS: Please re-name the file so that it closely resembles the Metadata Display Name. For example: Weather Report.

    Thanks in advance.

  2. #2
    Nokia Developer Moderator
    Join Date
    Jun 2008
    Location
    Tampere
    Posts
    833

    Re: Media quality failed problem

    Hi,

    Does Web App short name and long name (aka Display name) match as well as possible in config.xml? (under restrictions mentioned below)
    <name short="short name">long name</name>

    The display name should be as short as possible so that it fits well in the display when translated in many languages. The short name must be 16 characters or shorter in length and can use the following characters only: ASCII characters, dashes, underscores, digits, and spaces.
    http://www.developer.nokia.com/Resou...r-web-app.html

    In addition check that the Title text in index.html matches to display name. They will match initially as project wizard fills in the display name to title, but when config.xml is updated the changes are not reflected to title tag.

    Br,
    Ilkka

  3. #3
    Registered User
    Join Date
    May 2011
    Posts
    21

    Re: Media quality failed problem

    Hi,

    here you can find the my config.xml file. As mentioned above the display name restriction is not seem to be a problem. But there seem name conflict in the application.

    <?xml version="1.0" encoding="UTF-8"?>
    <widget xmlns="http://www.w3.org/ns/widgets" height="200" id="http://HavaDurumu" version="1.0.0" viewmodes="windowed fullscreen" width="200">

    <name short="ExampleBasic">Hava Durumu</name>

    <description>
    An example Basic Series 40 web app runtime.
    </description>

    <!-- Note: Author href MUST BE Url encoded
    @see http://en.wikipedia.org/wiki/Percent-encoding -->
    <author email="john.doe@example.com" href="http://www.example.com">
    John Doe
    </author>

    <icon src="icon.png"/>

    <content src="index.html"/>

    <license>
    Copyright Foo Bar Corp, 2011.
    </license>

    <feature name="nokia://s40.nokia.com/SAWRT/1.0 " required="true" />
    </widget>

    as you can see I did not even changed the default configuration except the long name. The index.html title is Hava Durumu also. But ovi store still thinks that there is a conflict on file and display name. I could not understand the problem.

  4. #4
    Nokia Developer Moderator
    Join Date
    Jun 2008
    Location
    Tampere
    Posts
    833

    Re: Media quality failed problem

    Thanks for the config.xml

    The problem is in this line:
    <name short="ExampleBasic">Hava Durumu</name>

    Something like this should work:
    <name short="Hava Durumu">Hava Durumu</name>

    Br,
    Ilkka

  5. #5
    Registered User
    Join Date
    May 2011
    Posts
    21

    Re: Media quality failed problem

    As you think I also got the attention on that line but in one of my another application the config file seems exactly same other than the display name. And it has passed the quality test. That is why I'm thinking that's not the problem.

    But I'll give a try on that. Hope it will resolve. If you have another suggestion please send again. Because each submit to quality control takes at least one week to be reviewed.

    Thanks.

  6. #6
    Nokia Developer Champion
    Join Date
    Oct 2010
    Location
    Singapore
    Posts
    221

    Re: Media quality failed problem

    I'm not sure if this helps but you mentioned on your corrective actions.... The meta display name in publish.nokia.com is 'Weather Report' while on your s40 app you use 'Hava Durumu' .. I think both app name plus the shortname as mentioned should be same as the metadata title you use when you upload it in publish.nokia

Similar Threads

  1. OVI qa failed media for the input text issue
    By biskero in forum [Archived] Flash Lite on Nokia Devices
    Replies: 2
    Last Post: 2010-08-05, 14:12
  2. OVI QA failed media for certificate error when they need to Sign application!!!
    By biskero in forum [Closed] Publishing to Nokia Store
    Replies: 3
    Last Post: 2010-07-29, 12:38
  3. avax.microedition.media.MediaException: Failed to get Camera Snapshot data size
    By Len23 in forum Mobile Java Media (Graphics & Sounds)
    Replies: 2
    Last Post: 2010-03-25, 05:30
  4. Press release:Sevana Audio Quality Analyzer(AQuA)2.1 - means to test HD Voice quality
    By sevana in forum News, Announcements and Job Listings
    Replies: 2
    Last Post: 2010-01-26, 16:41
  5. ONE WAY VOICE QUALITY Problem ON E65
    By synthe_2000 in forum VoIP
    Replies: 0
    Last Post: 2008-07-17, 11:14

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •