×

Discussion Board

Results 1 to 11 of 11
  1. #1
    Super Contributor
    Join Date
    Nov 2010
    Posts
    1,229

    Cool The symbian application's icon is not displayed in the device menu.

    How to solve the below Issue of icon

    Failed QA.
    ISSUE#1: SUMMARY: The application's icon is not displayed in the device menu.
    STEPS TO REPRODUCE:
    1. Download the content OTA.
    2. Install the application.
    3. Go to “Applications” folder.
    ACTUAL RESULT: The application's icon is not displayed in the device menu, only the name of the application is visible.
    EXPECTED RESULT: Icon for the application is displayed in the device menu, the application should be easily found.
    AFFECTED DEVICES: All S60 3rd Edition, S60 3rd Edition FP1 and S60 3rd Edition FP2 devices.

  2. #2
    Registered User
    Join Date
    Apr 2010
    Posts
    76

    Re: The symbian application's icon is not displayed in the device menu.

    you have problem in svg icon or its path. confirm its path in rss file.

  3. #3
    Regular Contributor
    Join Date
    May 2010
    Posts
    362

    Re: The symbian application's icon is not displayed in the device menu.

    Sounds to me that there is indeed problem in the original SVG file. If the icon file was not found, then it should display the default icon.

    How does it look when you test your self on these devices?

  4. #4
    Super Contributor
    Join Date
    Nov 2010
    Posts
    1,229

    Re: The symbian application's icon is not displayed in the device menu.

    reg.rss or application.rss ?

  5. #5
    Super Contributor
    Join Date
    Nov 2010
    Posts
    1,229

    Re: The symbian application's icon is not displayed in the device menu.

    At my side on my devices icon is displayed clearly only. I gave for nokia signing during the publishing in ovi site.

  6. #6
    Regular Contributor
    Join Date
    May 2010
    Posts
    362

    Re: The symbian application's icon is not displayed in the device menu.

    Have you tested it on these devices. Like in https://www.developer.nokia.com/Devi...device_access/

  7. #7
    Super Contributor
    Join Date
    Nov 2010
    Posts
    1,229

    Re: The symbian application's icon is not displayed in the device menu.

    yes tested on Remote Device Access Icon is clearly visible.

  8. #8
    Regular Contributor
    Join Date
    May 2010
    Posts
    362

    Re: The symbian application's icon is not displayed in the device menu.

    Perhaps this is a problem with the paths.

    Have you hard coded the icon path to point to C:\ ?
    If so, then how do you have it defined in the PKG file?

  9. #9
    Super Contributor
    Join Date
    Nov 2010
    Posts
    1,229

    Re: The symbian application's icon is not displayed in the device menu.

    Here is my .pkg file where should I mention abot the icon path?


    "$(EPOCROOT)Epoc32\release\$(PLATFORM)\$(TARGET)\App1_0x2004aa1c.exe" -"!:\sys\bin\App1_0x2004aa1c.exe"
    "$(EPOCROOT)Epoc32\data\z\resource\apps\App1_0x2004aa1c.rsc" -"!:\resource\apps\App1_0x2004aa1c.rsc"
    "$(EPOCROOT)Epoc32\data\z\private\10003a3f\apps\App1_0x2004aa1c_reg.rsc" -"!:\private\10003a3f\import\apps\App1_0x2004aa1c_reg.rsc"

    ;"..\help\App1_0x2004aa1c.hlp" -"!:\resource\help\App1_0x2004aa1c.hlp"
    "$(EPOCROOT)Epoc32\data\z\resource\apps\my_background.mif" -"!:\resource\apps\my_background.mif"
    "$(EPOCROOT)Epoc32\data\z\resource\apps\my_background.mbm" -"!:\resource\apps\my_background.mbm"

    ; Add any installation notes if applicable
    ;"App1.txt" -"!:\private\2004aa1c\App1.txt"

    ;required for application to be covered by backup/restore facility
    "..\sis\backup_registration.xml" -"!:\private\2004aa1c\backup_registration.xml"

  10. #10
    Regular Contributor
    Join Date
    May 2010
    Posts
    362

    Re: The symbian application's icon is not displayed in the device menu.

    What have you defined in application.rss (or some other rss file)?
    Search for RESOURCE LOCALISABLE_APP_INFO there and see "icon_file = ***"

  11. #11
    Super Contributor
    Join Date
    Nov 2010
    Posts
    1,229

    Re: The symbian application's icon is not displayed in the device menu.

    I have corrected two mistakes

    included "$(EPOCROOT)\epoc32\data\z\resource\apps\App1_0x2004aa1c.mif" -"!:\resource\apps\App1_0x2004aa1c.mif"

    and

    in .rss

    icon_file = "\\resource\\apps\\App1_0x2004aa1c.mif";

Similar Threads

  1. Replies: 1
    Last Post: 2011-01-30, 15:04
  2. How to change application icon displayed on the menu (urgent)?
    By okegame in forum Symbian Tools & SDKs
    Replies: 9
    Last Post: 2010-01-16, 14:14
  3. How disable our Application's icon in to phone menu
    By Tanya in forum Symbian User Interface
    Replies: 9
    Last Post: 2007-08-09, 16:51

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×