×

Discussion Board

Results 1 to 5 of 5
  1. #1
    Super Contributor
    Join Date
    Nov 2010
    Posts
    1,228

    Cool How to develop and build Qt applications for s60 3rd edition

    How to develop and build Qt applications for s60 3rd edition.


    What Qt SDK to chose

    Which Qt creator works


    Which installation or build version is helpful.

    Will Qt work on s60 3rd ed , FP1 and FP2 devices?

    Will all types like widgets, Mobility , GUI apps works on s60 3rd edition devices?

  2. #2
    Super Contributor
    Join Date
    Mar 2003
    Location
    Finland
    Posts
    9,563

    Re: How to develop and build Qt applications for s60 3rd edition

    Only Qt 4.6.3 will work (but see below). Qt 4.7.4 and related features will now work.

    Even with Qt 4.6.3, it won't work on any S60 3rd Edition (original version = Series 60 v3.0) devices, and will work on most S60 3rd Ed FP1 (Series 60 v3.1) and FP2 (Series 60 v3.2) devices, but not all of them. On some S60 3rd Ed FP1/FP2 devices, you can get things working if you install Qt manually, but not if you use Smart Installer. You must use Smart Installer, if you wish to distribute through Nokia/Ovi Store.

    Also, from looking at posta here, nowadays, it seems to be difficult to get from Nokia the appropriate tools and SDKS to set up a working Qt 4.6.3 development environment for targeting Symbian/S60 3rd Edition.

  3. #3
    Super Contributor
    Join Date
    Nov 2010
    Posts
    1,228

    Re: How to develop and build Qt applications for s60 3rd edition

    How to install Qt manually? If I have Qt SDK 1.1.3 and Qt creator 2.3 based on Qt 4.7.4 Can I add other Qt like Qt 4.6.3 to it? Because Iam not finding Qt 4.6.3 in Qt creator 2.3

  4. #4
    Registered User
    Join Date
    Jul 2008
    Posts
    103

    Re: How to develop and build Qt applications for s60 3rd edition

    Sorry for reviving this thread, but I have the latest Qt SDK and 3rd edition toolchain was removed from it. Is there any way to build for 3rd edition without switching to an older version of SDK ? If I build for 4.6.3 and 5th edition and use smart installer, I get an error that application is not compatible with phone when installing it.

  5. #5
    Nokia Developer Champion
    Join Date
    Feb 2008
    Location
    Ahmedabad, Gujarat, India
    Posts
    3,852

    Re: How to develop and build Qt applications for s60 3rd edition

    i dont think there is any other way except using the old sdk which supports those devices.

Similar Threads

  1. Replies: 0
    Last Post: 2008-10-18, 12:58
  2. Is it possible to develop s40 applications in c/C++
    By kanchan sinha in forum Symbian Tools & SDKs
    Replies: 1
    Last Post: 2008-02-11, 14:58
  3. How to develop SyncML applications in 3rd?
    By chico156 in forum OMA DM/DS/CP
    Replies: 5
    Last Post: 2007-03-27, 19:32
  4. Replies: 3
    Last Post: 2005-08-16, 10:20

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×