×

Discussion Board

Results 1 to 12 of 12
  1. #1
    Super Contributor
    Join Date
    Nov 2010
    Posts
    1,228

    Cool [Moved]"Application not compatible with phone. Continue > anyway?" error > message is

    "Application not compatible with phone. Continue
    > anyway?" error
    > message is displayed.


    When Iam trying to install a symbian ,c++ application on s60 3rd , 5th and symbian 3 devices.


    I want the follwoing message instead :

    The application is downloaded and installed on the
    device

  2. #2
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,166

    Re: "Application not compatible with phone. Continue > anyway?" error > message is di

    did you try googling for the problem ? basically searching a bit would definetely make your problem solving a lot faster. Basically you need to specify the target platforms in your pkg.

  3. #3
    Super Contributor
    Join Date
    Nov 2010
    Posts
    1,228

    Re: "Application not compatible with phone. Continue > anyway?" error > message is di

    I have mentioned in the .pkg file for s60 3rd edition , FP1 and FP2 as below:


    ;Supports Series 60 v 3.0


    [0x102032BE], 0, 0, 0, {"Series60ProductID"}

    [0x101F7961], 0, 0, 0, {"Series60ProductID"}
    [0x102752AE], 0, 0, 0, {"Series60ProductID"}


    And built my application with S60_3rd_FP2_beta SDK on carbide c++

  4. #4
    Super Contributor
    Join Date
    Mar 2008
    Posts
    1,481

    Re: "Application not compatible with phone. Continue > anyway?" error > message is di

    Basically you can update your pkg file with UID for the platform you support. By default installer shows a note "Installation is complete", is it not enough for you?
    You could check the pkg file UID according to this (http://www.developer.nokia.com/Commu...fication_codes)

    ;S60 3rd Edition can be removed following line if you don't support S60 3rd edition
    [0x101F7961], 0, 0, 0, {"Series60ProductID"}

    ;S60 3rd Edition, FP1
    [0x102032BE], 0, 0, 0, {"Series60ProductID"}

    ;S60 3rd Edition, FP2
    [0x102752AE], 0, 0, 0, {"Series60ProductID"}

    ; S60 5th Edition / Symbian^1
    [0x1028315F], 0, 0, 0, {"Series60ProductID"}

    ;Symbian^3 (including Symbian Anna)
    [0x20022E6D], 0, 0, 0, {"Series60ProductID"}
    Last edited by mahbub_s60; 2011-11-08 at 11:35. Reason: uid error fix

  5. #5
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,688

    Re: "Application not compatible with phone. Continue > anyway?" error > message is di

    (Of course I am reflecting to #3, I have not seen #4 when typing)

    They are wrong.
    0x102032BE says that the application is compatible with S60 3rd FP1, while it is not. S60 3rd FP2 applications do not run flawlessly on S60 3rd FP1 devices.
    0x101F7961 is the same with S60 3rd noFP.

    0x102752AE is correct, an S60 3rd FP2 application really runs on S60 3rd FP2 devices.

    S60 5th and Symbian^3 are not listed, that is why the warning comes on those devices. Replace the wrong codes with these two and it will be fine. http://www.developer.nokia.com/Commu...fication_codes

    Otherwise: Why the hell are you using beta SDK-s for releasing applications? After the beta there was an 1.0 version, and now there is an 1.1 version of the S60 3rd FP2 SDK.

  6. #6
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,688

    Re: "Application not compatible with phone. Continue > anyway?" error > message is di

    Waahahaa, I just noticed the thread with exactly the same topic, from a week ago, http://www.developer.nokia.com/Commu...g-How-to-avoid
    It is really worth helping you.

  7. #7
    Registered User
    Join Date
    Nov 2011
    Posts
    1

    Re: [Moved]"Application not compatible with phone. Continue > anyway?" error > messag

    Hello all.

    I have this same problem. No help to google or search this forum.

    from pkg file:
    ;Supports Series 60 v 3.0
    [0x101F7961], 0, 0, 0, {"Series60ProductID"}
    ;Supports Series 60 v 5.0
    [0x1028315F], 0, 0, 0, {"Series60ProductID"}
    ;Supports Symbian v 3
    [0x20022E6D], 0, 0, 0, {"Symbian3ProductID"}

    Ovi store publishing message:

    ISSUE #1: SUMMARY: "Application not compatible with phone. Continue anyway?" error message is received while trying to install the application.
    STEPS TO REPRODUCE:
    1. Download the application.
    2. Try to install the application.
    ACTUAL RESULT: "Application not compatible with phone. Continue anyway?" error message is displayed.
    EXPECTED RESULT: The application is downloaded and installed on the device without any issues. Any error or warning messages should not be displayed during installation.
    AFFECTED DEVICES: All devices of S60 5th Edition and Symbian^3 platform.
    FREQUENCY REPRODUCED: 100%.
    SUGGESTED CORRECTIVE ACTION: Most of the times this issue is caused by specifying incorrect operating system in the package file.
    Please visit the following web page to get more information about Platform Identification code for different operating system. http://wiki.forum.nokiacom/index.php...fication_codes.

  8. #8
    Super Contributor
    Join Date
    Nov 2010
    Posts
    1,228

    Re: "Application not compatible with phone. Continue > anyway?" error > message is di

    what do you really want to say. Forgive me if anything wrong? Actually Iam very new to publishing.

  9. #9
    Super Contributor
    Join Date
    Nov 2010
    Posts
    1,228

    Re: [Moved]"Application not compatible with phone. Continue > anyway?" error > messag

    Hi mijohan for which device you want to build the application and install

  10. #10
    Super Contributor
    Join Date
    Nov 2010
    Posts
    1,228

    Re: "Application not compatible with phone. Continue > anyway?" error > message is di

    Hi wizard For symbian 3 and Anna we have to give {"Symbian3ProductID"} or {"Series60ProductID"} in .pkg file

  11. #11
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,688

    Re: "Application not compatible with phone. Continue > anyway?" error > message is di

    The hexadecimal numbers are the important part there, the {"Series60ProductID"} is a text label which does not get displayed on Symbian devices from Nokia.
    Most {"xy"} structures are localisable text labels in .pkg files, similar to the #-line you have fixed recently, that one is really getting displayed in the Application Manager as you have seen.

    The complex structure comes from that they are localisable.
    While a simple package looks like
    Code:
    #{"Hello World"},(0xE1234567),1,0,0
    %{"Blah-blah"}
    :"Blah-blah"
    [0x101F7961], 0, 0, 0, {"S60ProductID"}
    ...
    if someone adds multi-language support to the .pkg, all of them have to be localised:
    Code:
    &EN,HU
    #{"Hello World", "Helló Világ"},(0xE1234567),1,0,0
    %{"Blah-blah","Bla-bla"}
    :"Blah-blah"
    [0x101F7961], 0, 0, 0, {"S60 Product ID","S60 Készülékazonosító"}
    ...
    So, if the given device is set to Hungarian language, the Application Manager will display "Helló Világ" as the name of the application, while devices with other language will display Hello World, as English is the common fallback language.
    Series60ProductID is a similar displayable string, just it never gets displayed in reality.

  12. #12
    Super Contributor
    Join Date
    Nov 2010
    Posts
    1,228

    Re: "Application not compatible with phone. Continue > anyway?" error > message is di

    ok ok folowed

Similar Threads

  1. "Application not compatible with phone. Continue anyway" Warning Msg How to avoid?
    By GTO_India in forum Symbian Signed Support, Application Packaging and Distribution and Security
    Replies: 5
    Last Post: 2011-11-08, 14:00
  2. Application not compatible with phone. Continue anyway? error message
    By stevensei in forum [Archived] Nokia Smart Installer for Symbian
    Replies: 0
    Last Post: 2011-07-27, 04:54
  3. Replies: 8
    Last Post: 2010-07-08, 22:46
  4. [moved] "Application is not compatible with phone" on 5800
    By montysan in forum Symbian Signed Support, Application Packaging and Distribution and Security
    Replies: 6
    Last Post: 2009-12-24, 09:19
  5. Replies: 6
    Last Post: 2008-10-29, 02:00

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×