×

Discussion Board

Results 1 to 8 of 8
  1. #1
    Registered User
    Join Date
    Nov 2011
    Posts
    5

    QtMobility.gallery 1.1 and Nokia N9

    Just made an app with audio gallery using the DocumentGalleryModel and Qml. It works fine with the device attached and run from the QtCreator but when I try to run it standalone the gallery model doesn't fetch the data and the list view stays empty. What should I do? Does the device (n9) need firmware update or somthn?

  2. #2
    Super Contributor
    Join Date
    Apr 2003
    Location
    USA, CA
    Posts
    7,191

    Re: QtMobility.gallery 1.1 and Nokia N9

    If you start the application using terminal, do you get any error messages?
    This could be related to the application rights (aegis, under which user the app is run), but unfortunately I am not sure about these details

    Hartti

    PS. I'll also move this to a better suited forum in here
    Last edited by hartti; 2011-11-13 at 06:04.

  3. #3
    Super Contributor
    Join Date
    Oct 2008
    Location
    INDIA
    Posts
    2,326

    Re: QtMobility.gallery 1.1 and Nokia N9

    Then update your device firmware and run the same code. tell us what happen after ?

  4. #4
    Registered User
    Join Date
    Nov 2011
    Posts
    5

    Re: QtMobility.gallery 1.1 and Nokia N9

    Yep tried that one(running from the command line) and still doesn't work.

    Also tried to update the libqtm-11 for my device but it doesn't work. Can't fin the packages with apt-get. The official sw update still isn't available for my phone for some reason. Maybe I'll shout to the customer service and let's see if they get the update for me...

  5. #5
    Super Contributor
    Join Date
    Mar 2009
    Posts
    1,024

    Re: QtMobility.gallery 1.1 and Nokia N9

    Quote Originally Posted by Jr127 View Post
    Just made an app with audio gallery using the DocumentGalleryModel and Qml. It works fine with the device attached and run from the QtCreator but when I try to run it standalone the gallery model doesn't fetch the data and the list view stays empty. What should I do? Does the device (n9) need firmware update or somthn?
    No it's not a problem related to the firmware.
    You just missed to give the right capabilities to your application. To do so you need to specify an Aegis manifest file.
    The manifest file is in the directory debian/your_package_name.aegis.
    That file should look like the following one, where REQUIRED_TOKENS are specified at http://www.developer.nokia.com/Commu...ecurity_Tokens

    <aegis>
    <request>
    <credential name="REQUIRED TOKEN1" />
    <credential name="REQUIRED TOKEN2" />
    <for path="/opt/YOUR_PKG_NAME/bin/YOUR_PACKAGE_BINARY" />
    </request>
    </aegis>t file is blank.
    Last edited by gnuton; 2011-11-16 at 15:13. Reason: Url was wrong.

  6. #6
    Registered User
    Join Date
    Nov 2011
    Posts
    5

    Re: QtMobility.gallery 1.1 and Nokia N9

    Quote Originally Posted by gnuton View Post
    No it's not a problem related to the firmware.
    You just missed to give the right capabilities to your application. To do so you need to specify an Aegis manifest file.
    The manifest file is in the directory debian/your_package_name.aegis.
    I'm using the qtcreator integrated aegis and it has made an automatic file like this:

    <aegis>
    <request policy="add">
    <!-- Application uses QtDeclarative module. -->

    <!-- import QtMultimediaKit 1.1 -->
    <credential name="GRP::audio" />
    <credential name="GRP:: pulse-access" />
    <credential name="GRP::video" />

    <!-- import QtMobility.gallery 1.1 -->
    <credential name="TrackerReadAccess" />
    <credential name="TrackerWriteAccess" />

    <for path="/opt/myapp/bin/myapp" />
    </request>
    </aegis>

    Somebody know if I need some more credentials? As I said the app runs well when using it trough the usb cable but doesn't know how to use the gallery when run standalone.
    Last edited by Jr127; 2011-11-16 at 14:09. Reason: The site gave :p automatically for the text...

  7. #7
    Super Contributor
    Join Date
    Mar 2009
    Posts
    1,024

    Re: QtMobility.gallery 1.1 and Nokia N9

    Hi,
    That file looks okay to me. But if the app works fine if launched by Qt Creator and it doesn't work if launched from device there are only 2 options.
    1- Your device requires more capabilities
    2- Qt Creator runs apps as "developer", terminal and manu launch apps as "user".

    BTW I've corrected the link related to harmattan tokens reported in my previous post.

  8. #8
    Registered User
    Join Date
    Nov 2011
    Posts
    5

    Re: QtMobility.gallery 1.1 and Nokia N9

    Yeah now it works! Thx all!

    Then the explanation how I got it working:
    All the glorious detail is that I installed the sdk ver 1.1.4 -> qmake -> rebuild -> deploy -> Working fine!


    Seems that the Qt Creator knows how to do the aegis magic, but I'd suggest everybody trying to use the services requiring permissions to check the aegis docs mentioned and linked below by gnuton.

Similar Threads

  1. Qtmobility app not running on nokia c5
    By jainmonali21 in forum [Archived] Qt Mobility Project
    Replies: 4
    Last Post: 2011-02-16, 05:58
  2. how to updateQt and QtMobility Version in Nokia Qt SDK?
    By marine8086 in forum [Archived] Qt Mobility Project
    Replies: 3
    Last Post: 2010-12-20, 12:55
  3. How to update QtMobility to the latest version in Nokia Qt SDK
    By matthiaz in forum [Archived] Qt SDKs and Tools
    Replies: 4
    Last Post: 2010-09-08, 10:01
  4. Error with QtMobility 1.0 after succesfully intall QtMobility tp2
    By Estel in forum [Archived] Qt Mobility Project
    Replies: 0
    Last Post: 2010-06-21, 21:21

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×