×

Discussion Board

Results 1 to 6 of 6
  1. #1
    Registered User
    Join Date
    Feb 2011
    Posts
    12

    Qt SDK 1.1.4 smart installer issue (qt component 1.1 upgrade)

    I create smart installer sis for my application using latest qt sdk. my application was using qt components 1.0 and code was upgraded to use 1.0. on one of my test device the smart installer did not upgrade qt components 1.0 to 1.1 as expected. after manually installing new 1.1 sis application worked as expected. is this a known issue? other than changing package import are any other changes required to be done for Qt project?

  2. #2
    Super Contributor
    Join Date
    Oct 2008
    Location
    INDIA
    Posts
    2,326

    Re: Qt SDK 1.1.4 smart installer issue (qt component 1.1 upgrade)

    Read the Note about Qt Quick components : http://www.developer.nokia.com/Commu...er_for_Symbian

    regards,
    rahul

  3. #3
    Registered User
    Join Date
    Feb 2011
    Posts
    12

    Re: Qt SDK 1.1.4 smart installer issue (qt component 1.1 upgrade)

    Turns out that I was not using 4.7.4 build for Anna. will report back once I have re-tested this using 4.7.4 build target (test was done using 4.7.3 target)

  4. #4
    Super Contributor
    Join Date
    Oct 2008
    Location
    INDIA
    Posts
    2,326

    Re: Qt SDK 1.1.4 smart installer issue (qt component 1.1 upgrade)

    Update the result here, and write the cause of that problem, so, it will helpful for the other developers.

    thanks,
    rahul

  5. #5
    Registered User
    Join Date
    Feb 2011
    Posts
    1

    Re: Qt SDK 1.1.4 smart installer issue (qt component 1.1 upgrade)

    I'm having the same issue.

    App compiled with Remote Compiler > Symban Anna > Qt 4.7.4 with Smart installer.
    Device: N8, Symbian Anna, sw 025.007, Finnish locale.

    Installation went fine and Smart installer did update some packages (it did not tell which ones). When starting the app, QML ui does not work --> qt-components 1.1 are missing. Manual installation of qt-components 1.1.sis --> everything works.

    So Smart Installer does not currently update components from 1.0 to 1.1. This is a major problem.

  6. #6
    Registered User
    Join Date
    Feb 2011
    Posts
    12

    Re: Qt SDK 1.1.4 smart installer issue (qt component 1.1 upgrade)

    Thanks for the confirmation. I got all my device converted to 1.1 build during testing process and hence was not able to retest the issue yet. As is store QA is not yet accepting 4.7.4/Qt Component 1.1 on symbian due to some technical issue. maybe the issue could be same one we are facing here.

Similar Threads

  1. Smart Installer and E5-00
    By mainguet in forum [Archived] Nokia Smart Installer for Symbian
    Replies: 3
    Last Post: 2011-05-11, 20:11
  2. Smart Installer Language issue
    By Dreddik in forum [Archived] Nokia Smart Installer for Symbian
    Replies: 5
    Last Post: 2011-02-04, 10:22
  3. Nokia E5 Smart Installer Issue
    By epomerle in forum [Archived] Nokia Smart Installer for Symbian
    Replies: 1
    Last Post: 2010-11-17, 09:49
  4. RDA and smart installer
    By Guilo19 in forum [Archived] Nokia Smart Installer for Symbian
    Replies: 1
    Last Post: 2010-06-18, 22:34
  5. Partial upgrade installer problem
    By mapeters in forum Symbian
    Replies: 3
    Last Post: 2008-07-29, 17:10

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •