×

Discussion Board

Results 1 to 3 of 3
  1. #1
    Regular Contributor
    Join Date
    Sep 2010
    Posts
    65

    Angry SmartInstaller does not work on NonTouch phones!

    Hello,

    Here's the additional content that I've added in my pro file
    Code:
    # Clear existing pkg dependencies
    default_deployment.pkg_prerules =
    
    # Define pkg language dependent items
    languages = "&EN,FR,GE,SP,IT"
    packageheader = "$${LITERAL_HASH}{\"My App\", \"My App\", \"My App\", \"My App\", \"My App\"}, (UID3), 1, 0, 0, TYPE=SA"
    
    vendorinfo = \
    ";The global vendor name" \
    ":\"MyVendorName\"" \
    ";The localised vendor name" \
    "%{\"MyVendorName\", \"MyVendorName\", \"MyVendorName\", \"MyVendorName\", \"MyVendorName\"}"
    
    dependencyinfo = \
    "; Default HW/platform dependencies" \
    "[0x102032BE],0,0,0,{\"S60ProductID\",\"S60ProductID\",\"S60ProductID\",\"S60ProductID\", \"S60ProductID\"}" \
    "[0x102752AE],0,0,0,{\"S60ProductID\",\"S60ProductID\",\"S60ProductID\",\"S60ProductID\",\"S60ProductID\"}"
    
    qt_info = \
             " " \
        "; Default Qt dependencies" \
        "[0x2000F866],1,6,0,{\"Stdcpp\",\"Stdcpp\",\"Stdcpp\",\"Stdcpp\",\"Stdcpp\"}" \
        "[0x200110CB],1,6,0,{\"OpenC_SSL\",\"OpenC_SSL\",\"OpenC_SSL\",\"OpenC_SSL\",\"OpenC_SSL\"}" \
        "[0x20013851],1,6,0,{\"PIPS\",\"PIPS\",\"PIPS\",\"PIPS\",\"PIPS\"}" \
        "[0x2002AF5F],0,5,0,{\"Sqlite\",\"Sqlite\",\"Sqlite\",\"Sqlite\",\"Sqlite\"}" \
        "[0x2001E61C],4,6,3,{\"Qt\", \"Qt\", \"Qt\", \"Qt\", \"Qt\"}" \
        "[0x200267C2],4,6,3,{\"QtWebKit\", \"QtWebKit\", \"QtWebKit\", \"QtWebKit\", \"QtWebKit\"}"
    
    DEPLOYMENT.installer_header = "$${LITERAL_HASH}{\"My App\", \"My App\", \"My App\", \"My App\", \"My App\"},(0x2002CCCF),1,0,0"
    
    my_deployment.pkg_prerules = languages packageheader vendorinfo dependencyinfo qt_info
    DEPLOYMENT += my_deployment
    The smartinstaller works fine on Symbian^1 and Symbian^3 (as I build it directly using the Qt SDK in Creator). But I have no option in the Qt Creator to build for S60 3rd edition phones (which requires Qt 4.6.3 support)

    I have Carbide setup too (Nokia_N97_SDK being the default SDK), using Command Line I managed generating smartinstaller build for Non-Touch, but the smartinstaller file that I've used for this seems to be a problem (it was taken from the Nokia_Qt_SDK1.0.2), n it fails to install!!!

    Once it got installed but the application was missing in the App folder (though it showed in the Intalled apps. as the app is installed!!). Next time it said No Pending Installations, n again no app found!!! With another try there's this long long wait in the "Finalizing installation... " but nothing happens, it either cancels the installation or gives me the error "Installation failed"!! I have faced all the problems that a smartinstaller can ever give!!!!

    Can someone please help me with this?

  2. #2
    Regular Contributor
    Join Date
    Sep 2010
    Posts
    65

    Re: SmartInstaller does not work on NonTouch phones!

    I'm sorry, I just skipped few observations!! I face this problem even on the Symbian^1 and Symbian^3 devices!

    After adding the multiple language support option in the pro (languages = "&EN,FR,GE,SP,IT"), n accordingly overriding the platform dependency n Qt dependency info I get this problem! The application installs and asks for the Launch, but it doesn't download the missing Qt files on all the phones the behavior is the same! There's some major mistake that I've been doing in pro file, can someone help with the right content?

    Before adding the line --> languages = "&EN,FR,GE,SP,IT" everything had worked fine, missing Qt files did get downloaded n installed! So is this line absolutely necessary, or can we upload the app without the language info specified in the pro?

  3. #3
    Super Contributor
    Join Date
    Oct 2008
    Location
    INDIA
    Posts
    2,326

    Re: SmartInstaller does not work on NonTouch phones!

    Read this article carefully : http://www.developer.nokia.com/Commu...e_installation

    regards,
    rahul

Similar Threads

  1. Replies: 3
    Last Post: 2007-11-15, 12:55
  2. Will an HTTP app work on most phones in the US?
    By Subotai4Winds in forum Mobile Java Networking & Messaging & Security
    Replies: 2
    Last Post: 2006-09-17, 18:40
  3. Why does SIS Installer NOT work on certain phones?
    By bpinvest in forum General Development Questions
    Replies: 4
    Last Post: 2006-02-21, 22:44
  4. Any US phones KNOWN to work with SDK?
    By stevejarrett in forum PC Suite API and PC Connectivity SDK
    Replies: 2
    Last Post: 2003-07-15, 21:20
  5. Which US phones are KNOWN to work with SMS API?
    By stevejarrett in forum PC Suite API and PC Connectivity SDK
    Replies: 0
    Last Post: 2002-12-17, 19:52

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×