×

Discussion Board

Results 1 to 3 of 3

Threaded View

  1. #1
    Registered User
    Join Date
    Nov 2011
    Posts
    1

    LWUIT - Application almost unresponsive while loading on E7-00

    Hi all,

    I am writing a midlet and testing it on Nokia E7-00 and E6-00. A big part of it are Lists, where each item has an image.

    When each list item is shown its image is loaded using LWUIT's NetworkManager (which doesn't block the EDT). However while the images are loading the application is almost unresponsive. If I replace the images with static ones there are no performance problems.

    I have tested it with the phones being connected to a WiFi network. The devices are not updated to Symbian Anna (I was asked not to make it a requirement unless absolutely necessary). Each list screen shows about 6 items.
    The images are jpeg images, 70x70 pixels.

    Any ideas?
    Last edited by jeconomX; 2011-11-24 at 08:23.

Similar Threads

  1. RDA very unresponsive?
    By ehudshapira in forum Feedback - Nokia Developer Services & Infrastructure
    Replies: 4
    Last Post: 2011-09-19, 21:56
  2. Lwuit circle loading bar
    By mjagadeeshbabu in forum Mobile Java General
    Replies: 0
    Last Post: 2011-05-06, 13:17
  3. loading midlet from lwuit
    By simsimlhr in forum Mobile Java General
    Replies: 1
    Last Post: 2008-11-03, 19:56
  4. Unresponsive GPS
    By SomeIdiot in forum Symbian
    Replies: 2
    Last Post: 2007-12-06, 22:09

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×