×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Registered User
    Join Date
    May 2010
    Posts
    29

    QtCreator: Qt Mobility Bearer API error after switching from Qt 4.6.3 to 4.7.3

    After switching from Qt 4.6.3 to 4.7 ("4.7.3 for Symbian Anna (Qt SDK)" to be precise), I get the following make error:
    Code:
    Project MESSAGE: Qt Mobility Bearer API is deprecated when using Qt 4.7 or higher.
    Project MESSAGE: Please use source compatible replacement Bearer API in QtNetwork.
    There are some posts and instructions (here: http://doc.qt.nokia.com/qtmobility-1...anagement.html) on the web, but none fixed the problem. Here's the (sanitized) .pro file:
    Code:
    QT       += core gui\
            network\
            xml
    
    TARGET = MyApp
    TEMPLATE = app
    
    ICON = appicon.svg
    VERSION = 1.1.1
    
    SOURCES += main.cpp\
            source1.cpp \
        sourece2.cpp 
    
    HEADERS  += source1.hpp \
        source2.hpp
    
    FORMS    += myapp.ui
    
    CONFIG += mobility
    MOBILITY = bearer\
        location

    Based on the instructions, I understand "MOBILITY = bearer" should automatically select the correct API. If so, this does not seem to be the case. One more interesting nugget: Although I do not intend to build against Qt 4.7.4 for Symbian Belle for some time (devices in the US only receive Anna) - when selecting that version, the problem does not exist.

  2. #2
    Super Contributor
    Join Date
    Oct 2008
    Location
    INDIA
    Posts
    2,326

    Re: QtCreator: Qt Mobility Bearer API error after switching from Qt 4.6.3 to 4.7.3

    This line is true. "Starting with Qt 4.7 the Mobility version has been deprecated in favor of Qt's Bearer API".

    regards,
    rahul

  3. #3
    Registered User
    Join Date
    May 2010
    Posts
    29

    Re: QtCreator: Qt Mobility Bearer API error after switching from Qt 4.6.3 to 4.7.3

    Quote Originally Posted by rahulvala View Post
    This line is true. "Starting with Qt 4.7 the Mobility version has been deprecated in favor of Qt's Bearer API".

    regards,
    rahul

    Bother explain how to actually select the Qt Bearer API?

  4. #4
    Super Contributor
    Join Date
    Oct 2008
    Location
    INDIA
    Posts
    2,326

    Re: QtCreator: Qt Mobility Bearer API error after switching from Qt 4.6.3 to 4.7.3

    MOBILITY += bearer
    Check your .pro file.

Similar Threads

  1. Qt 4.7.0 incompatible with Qt Mobility 1.0.2 (Bearer management)?
    By Tuomo in forum [Archived] Qt Mobility Project
    Replies: 4
    Last Post: 2010-10-15, 08:47
  2. Qt mobility Bearer error when search for WLAN
    By Zombieisme in forum [Archived] Qt Mobility Project
    Replies: 0
    Last Post: 2010-06-21, 12:33
  3. MOBILITY = bearer or MOBILITY = Bearer??
    By tadu in forum [Archived] Qt Mobility Project
    Replies: 1
    Last Post: 2010-06-03, 21:01
  4. Error: data bearer not available
    By froemer in forum Mobile Java General
    Replies: 0
    Last Post: 2002-09-09, 15:36

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •