×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Registered User
    Join Date
    Nov 2011
    Posts
    1

    Can't build for Symbian^3 and up

    SOLVED
    Hi, I'm pretty new to Qt and this might be just something I've missed, but here goes:

    I can't seem to be able to build projects for Symbian^3, Anna or Belle. Simulator and S60 5th work fine. Here's the compiler output:

    Running build steps for project animatedtiles...
    Starting: "c:\qtsdk\symbian\sdks\symbiansr1qt474\bin\qmake.exe" C:\QtSDK\Examples\4.7\animation\animatedtiles\animatedtiles.pro -r -spec symbian-sbsv2 -after "OBJECTS_DIR=obj" "MOC_DIR=moc" "UI_DIR=ui" "RCC_DIR=rcc"
    The process "c:\qtsdk\symbian\sdks\symbiansr1qt474\bin\qmake.exe" exited normally.
    Starting: "C:\QtSDK\Symbian\SDKs\SymbianSR1Qt474\epoc32\tools\make.exe" debug-gcce -w
    C:\QtSDK\Symbian\SDKs\SymbianSR1Qt474\epoc32\tools\make.exe: Entering directory `C:/QtSDK/Examples/4.7/animation/animatedtiles'
    sbs -c arm.v5.udeb.gcce4_4_1 -this is where it hangs, and then I cancel the process
    The process "C:\QtSDK\Symbian\SDKs\SymbianSR1Qt474\epoc32\tools\make.exe" crashed.
    Canceled build.

    Thanks in advance.

    Edit: Looks like the problem was just my account not having admin privileges
    Last edited by Defeqel; 2011-11-28 at 19:07.

  2. #2
    Super Contributor
    Join Date
    Oct 2008
    Location
    INDIA
    Posts
    2,326

    Re: Can't build for Symbian^3 and up

    Make only one target S^3.

    Which SDK and Qt version are you using ?

    Add your custom build set up Projects->Symbian Device->Build Steps->Add Build Step

    You can add new custom build step between the qmake and make command.

  3. #3
    Registered User
    Join Date
    Oct 2006
    Posts
    9

    Re: Can't build for Symbian^3 and up

    It looks like you are picking up the wrong Symbian SDK.
    C:\QtSDK\Symbian\SDKs\SymbianSR1Qt474\epoc32\tools\make.exe
    If you are using Qt 4.7.4 you should use 'Symbian3Qt474'.

    Make sure that the 'Qt Version' and 'Toolchain' in 'Projects' tab are correctly selected.

    Br
    -Ravi

  4. #4
    Registered User
    Join Date
    Nov 2011
    Posts
    16

    Re: Can't build for Symbian^3 and up

    Hi.

    I came up similar issue.I don't think it is overall bug but in specific setup.There is some problem with creating sis file with Qt SDK and connecting Symbian Anna based device to Windows XP based PC via USB using Nokia OVI Suite.

    1. The device is Nokia C700 , OS for the device is Symbian Anna
    2. The PC is on Windows XP

    a. When I connect the device in Mass Storage mode then I the connection is ok and files could be transfered to device's storage
    b. I installed on PC Nokia Ovi Suite version 2.2.1.23 . When I connect the device to PC and activate at the device Nokia Ovi Suite I observe next message from the Nokia Ovi Suite wizard : "The device is not in PC Suite USB mode. Nokia Ovi suite could not recognize your device..." .
    Does anybody know what is the problem why I can't connect the device to PC in Nokia Ovi Suite mode ?
    c. I installed Qt SDK , made update and I don't see yet QtSDK\Symbian\SDKs\ Qt for Symbian Anna.
    Also in Qt Creator in build configuration there is no Qt version for Symbian Anna , should it be there?
    Should it be installed in that folder after update?
    Does anybody know how to build .sis in Qt Creator using Qt SDK for Symbian Anna ?
    d.I can't create .sis files using existing build configuration Qt 4.7.3 for Symbian^3( Qt SDK)
    qmake finishes succes.
    qmake arguments: -r -spec symbian-sbsv2 "CONFIG+=release" ...
    Does anybody know what is the problem ?
    the built is finished successfully with:

    ...

    target : epoc32\release\armv5\urel\spectrum.exe [arm.v5.urel.gcce4_4_1]
    d:/qt/qtsdk/symbian/tools/gcce4/bin/../lib/gcc/arm-none-symbianelf/4.4.1/../../../../arm-none-symbianelf/bin/ld.exe: warning: D:/Qt/QtSDK/Symbian/SDKs/Symbian3Qt473/epoc32/release/armv5/urel/usrt3_1.lib(ucppinit.o) uses variable-size enums yet the output is to use 32-bit enums; use of enum values across objects may fail


    sbs : warnings: 25
    sbs : errors: 0

    built 'arm.v5.urel.gcce4_4_1'

    Run time 247 seconds

    sbs: build log in D:\Qt\QtSDK\Symbian\SDKs\Symbian3Qt473\epoc32\build\Makefile.2012-01-20-17-45-17.74-1376.log
    make.exe: Leaving directory `D:/DEVELOPING/TOOLBAR/Beeper/version_18_02_timers/spectrum'

    ...

    but .sis file wasn't created.

    Does anybody know how to fix solve/resolve this issue so we may create .sis files ?

    Thank in advance,

    Pavel
    Last edited by Freely; 2012-01-20 at 15:58.

Similar Threads

  1. can not build inbuilt Qt Quick Demos with Symbian device Build on new Qt SDK1.1 TP
    By chintandave_er in forum [Archived] Qt SDKs and Tools
    Replies: 12
    Last Post: 2011-02-08, 19:43
  2. Can I build a 802.11 frame in Symbian^3?
    By darksoul_e in forum Symbian Networking & Messaging (Closed)
    Replies: 1
    Last Post: 2011-01-20, 17:44
  3. How to build a simple BT app for Symbian S60
    By juliosilva in forum Mobile Java Networking & Messaging & Security
    Replies: 3
    Last Post: 2008-02-28, 15:47
  4. want to build for symbian 7.0 and 8.0
    By vp_mhaske in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 1
    Last Post: 2006-12-19, 07:15

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •