×

Discussion Board

Results 1 to 13 of 13

Hybrid View

  1. #1
    Registered User
    Join Date
    Oct 2010
    Posts
    228

    Qt 4.7.4 for Symbian^3

    Hi,

    After Qt SDK update to version 1.1.4 I thought I must compile Symbian^3 apps using the latest Qt version that is 4.7.4. But QA team made a contradictory reply:
    .........................
    Dear Publisher,

    Thank you for submitting your Qt application to Nokia Store.

    Unfortunately Nokia Store is not yet able to process your Qt 4.7.4 application. We expect to resolve an important Nokia Store – Qt 4.7.4 issue shorty. Once this issue is resolved we will promptly process your application.

    Additionally, if you have created your application with a beta Qt 4.7.4 toolchain, it is recommended that you recompile your application with the new Qt SDK 1.1.4.
    ...........................

    so the question is can I and should I compile Symbian^3 apps with latest Qt version (4.7.4) or stick for now with Qt 4.7.3? Actually online updater in Qt Creator (Qt SDK 1.1.4) has only one version for Symbian^3 which is 4.7.4. Thank you

    P.S. Would be great if QA team at least send e-mail about the issue as I waited for 8 days just to discover in comments that there are some problems :/ Before I had e-mail if QA team commented on item but now no e-mails
    http://inmobisoft.com

  2. #2
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,177

    Re: Qt 4.7.4 for Symbian^3

    Basically you can not use Beta SDKs for deployment, thus either always use latest final SDK version, or wait untill there is final release of the version you are wanting to use.

  3. #3
    Registered User
    Join Date
    Oct 2010
    Posts
    228

    Re: Qt 4.7.4 for Symbian^3

    But it is final I'm not using Beta for Symbian Belle firmware. I'm using Qt 4.7.4 for Symbian Anna, as I already mentioned the only available stable target for Symbian^3 devices. Are there any other versions of Qt I can download somehow else except Qt SDK package manager? Thank you
    http://inmobisoft.com

  4. #4
    Super Contributor
    Join Date
    Oct 2008
    Location
    INDIA
    Posts
    2,326

    Re: Qt 4.7.4 for Symbian^3

    What SDK to use is depends on what is your target devices.

    Note for Qt 4.6.3 and Qt 4.7.3 development
    Qt SDK 1.1.4 contains only the latest targets for developing applications for a particular Symbian platform. The targets for Qt 4.6.3 for Symbian and Qt 4.7.3 for Symbian^3 and Symbian Anna have been removed from Qt SDK 1.1.4. To develop for these targets, use Qt SDK 1.1.2. Once you have installed Qt SDK 1.1.2, to enable use of the earlier targets and App TRK, don’t run the SDK update as this will remove the features you need.

    Please be aware that if you want to use Qt SDK 1.1.2 and the latest Qt SDK on the same computer, you should install them into separate user accounts.

    Important information for apps targeting Symbian Belle
    Please note that apps built with the Qt 4.7.4 Symbian Belle target that use Symbian C++ APIs cannot currently be submitted to Nokia Store, unless you limit their distribution to Symbian Belle phones only. For applications that are to be distributed to all Qt 4.7.4 enabled phones, we recommend you build against the Qt 4.7.4 Symbian Anna target.
    regards,
    rahul

  5. #5
    Registered User
    Join Date
    Oct 2010
    Posts
    228

    Re: Qt 4.7.4 for Symbian^3

    Thank you for info. But it's crazy to remove targets that are accepted by OVI store and make default the one that is not accepted Any way I installed the Qt 4.7.3 using the same trick as in Qt SDK 1.1.3 (SDKMaintenanceTool.exe --show-virtual-components)
    http://inmobisoft.com

  6. #6
    Nokia Developer Expert
    Join Date
    Aug 2011
    Posts
    492

    Re: Qt 4.7.4 for Symbian^3

    Please see the latest post regarding issues with Qt 4.7.4 - http://www.developer.nokia.com/Commu...4-Applications.

    Andrew
    Andrew
    Follow @AndrewAtNokia on Twitter for news and updates about Nokia Publish!
    Andrew is now on Facebook to assist you with any publishing related inquiries.

  7. #7
    Registered User
    Join Date
    Oct 2010
    Posts
    228

    Re: Qt 4.7.4 for Symbian^3

    Ok, second time the same bug in Qt SDK. Previous release (1.1.3) missed Maemo target by hiding it, now all but Qt 4.7.4 for Symbian Anna are hidden. Problem is solved, I'll recompile app with older version of Qt. Thanks
    http://inmobisoft.com

  8. #8
    Registered User
    Join Date
    Apr 2009
    Posts
    506

    Re: Qt 4.7.4 for Symbian^3

    but where we can get the issue description?
    thanks
    Symbian & Qt developer. http://vladest.org

  9. #9
    Nokia Developer Expert
    Join Date
    Aug 2011
    Posts
    492

    Re: Qt 4.7.4 for Symbian^3

    Quote Originally Posted by vladest View Post
    but where we can get the issue description?
    thanks
    The pertaining issue is store related and we are still trying to resolve this to ensure that apps built with Qt 4.7.4 are downloadable and fully functioning on our users devices with Symbian ^3 PS1/Anna firmwares. Sorry for the delay and I will update you on any further information on this
    Andrew
    Follow @AndrewAtNokia on Twitter for news and updates about Nokia Publish!
    Andrew is now on Facebook to assist you with any publishing related inquiries.

  10. #10
    Registered User
    Join Date
    May 2011
    Posts
    4

    Re: Qt 4.7.4 for Symbian^3

    Hope you can fix the issue soon and accept Qt 4.7.4 related stuff.
    I'm not able to rebuild my app using 4.7.3, because QSystemStorageInfo is missed somehow in it and i don't want to install the the old SDK to be able to do a build using Qt 4.6.3...

    So good luck to resolve the issue and be able to accept Qt 4.7.4 stuff soon.

  11. #11
    Registered User
    Join Date
    Oct 2010
    Posts
    228

    Re: Qt 4.7.4 for Symbian^3

    You don't need to install old SDK, just run SDKMaintenanceTool.exe --show-virtual-components from command line and select all targets you need
    http://inmobisoft.com

  12. #12
    Registered User
    Join Date
    Nov 2011
    Posts
    80

    Re: Qt 4.7.4 for Symbian^3

    Thanks pippo2010, your trick worked to install Qt 4.6.3 into the current version of Qt Creator.
    It turned out at building my app, that unfortunately i used some stuff that wasn't included in 4.6.3 yet.

    @Nokia developers: Is there any progress or "schedule" to fix the store related issue?

    The point is, many have started to develop using 4.7.4 already and it takes time to back port the code to 4.6.3. I can also see many useful bug fixes in 4.7.4 which i want to use.
    If it takes half a year, well, then i'll go back to 4.6.3. But if you think it can get fixed in the next few weeks, i can wait.

  13. #13
    Nokia Developer Expert
    Join Date
    Aug 2011
    Posts
    492

    Re: Qt 4.7.4 for Symbian^3

    Quote Originally Posted by Johnny_B View Post
    Thanks pippo2010, your trick worked to install Qt 4.6.3 into the current version of Qt Creator.
    It turned out at building my app, that unfortunately i used some stuff that wasn't included in 4.6.3 yet.

    @Nokia developers: Is there any progress or "schedule" to fix the store related issue?

    The point is, many have started to develop using 4.7.4 already and it takes time to back port the code to 4.6.3. I can also see many useful bug fixes in 4.7.4 which i want to use.
    If it takes half a year, well, then i'll go back to 4.6.3. But if you think it can get fixed in the next few weeks, i can wait.
    We are hoping this will be fixed in the coming weeks. I honestly do not have an ETA on this however. I will update you when I receive more information.
    Andrew
    Follow @AndrewAtNokia on Twitter for news and updates about Nokia Publish!
    Andrew is now on Facebook to assist you with any publishing related inquiries.

Similar Threads

  1. Replies: 14
    Last Post: 2011-11-23, 10:36
  2. Replies: 4
    Last Post: 2009-01-12, 13:57
  3. Replies: 1
    Last Post: 2007-04-27, 13:29

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×