×

Discussion Board

Results 1 to 6 of 6
  1. #1
    Nokia Developer Champion
    Join Date
    Jun 2008
    Location
    Noida,India
    Posts
    3,956

    Unable to load web page with QML webview

    Hi,
    I am trying to load webview using the QML webview element(in particular facebook integration), but as soon as i launch the webview qml , only a blank view gets displayed & no web page gets loaded.

    If i see the console in Qt window, i can see the following messages:

    void QCopClient::connectToServer() QLocalSocket::ServerNotFoundError "QLocalSocket::connectToServer: Invalid name"

    The behavior is same for both emulator & device. Also i am able to open facebook through normal browser in my pc as in normal cases a firewall window is displayed but for project purposes the firewall has been disabled for my pc.

    Also if i just mention url as : url: "http://www.google.com" then in Qt console the message prints as: Web page started loading : "http://www.google.com, but in this case also, the screen remains blank & no web page gets loaded.

    so any clues as why this is happening.

    Note: i have already added QT += webkit network in the .pro file

  2. #2
    Nokia Developer Champion
    Join Date
    Jun 2008
    Location
    Noida,India
    Posts
    3,956

    Re: Unable to load web page with QML webview

    Just an update: If i swtich to the 'design' view of the webview qml then the facebook login page gets loaded successfully there, but on meego emulator/device it still shows a white blank screen.

    If i give the URL as : url: "http://www.facebook.com"

    then web page is loaded

    but if the URL parameter is :

    url: "http://www.facebook.com/dialog/oauth?client_id=275680635784928&redirect_uri=http://www.facebook.com/connect/login_success.html&response_type=token&scope=publish_stream,read_stream"

    which is for my fb application, then the page does not gets loaded, a white screen remains there.But at the same time i can see the same page getting loaded in 'design' view of qml
    Last edited by vineet.jain; 2011-12-01 at 10:00.

  3. #3
    Nokia Developer Moderator
    Join Date
    Mar 2009
    Posts
    1,024

    Re: Unable to load web page with QML webview

    Hi,
    QLocalSocket::connectToServer: Invalid name <-- means that the the device or your PC is not able to resolve the URL you are trying to load.
    About the blank page, check the geometry of the webview element as well as the scale and so on.

  4. #4
    Nokia Developer Champion
    Join Date
    Jun 2008
    Location
    Noida,India
    Posts
    3,956

    Re: Unable to load web page with QML webview

    well i check the geometry issue as well, gave pref.width & height but no effect it still displays blank page. Also if its an issue of geometry then how come "http://www.facebook.com" gets loaded successfully

  5. #5
    Nokia Developer Moderator
    Join Date
    Mar 2009
    Posts
    1,024

    Re: Unable to load web page with QML webview

    Ok then check the correctness of your URL.

  6. #6
    Nokia Developer Champion
    Join Date
    Oct 2007
    Location
    જુનાગઢ - India
    Posts
    3,034

    Re: Unable to load web page with QML webview

    Have you added "NetworkServices" CAPABILITY?

Similar Threads

  1. QML Webview page contents overlap
    By schroffi in forum [Archived] Qt Quick
    Replies: 4
    Last Post: 2012-03-23, 10:54
  2. WebView fails to load shared ssl pages
    By molbal in forum [Archived] Qt Quick
    Replies: 9
    Last Post: 2011-11-06, 21:58
  3. Is is posible to use local resource and cache page in Webview
    By nobody_gao@sina.com in forum [Archived] Qt Quick
    Replies: 2
    Last Post: 2011-06-21, 13:22
  4. Can't load "http://store.ovi.com" on WebView in Symbian^1
    By stevensei in forum [Archived] Qt Quick
    Replies: 5
    Last Post: 2011-06-20, 10:02

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •