×

Discussion Board

Results 1 to 12 of 12
  1. #1
    Registered User
    Join Date
    Mar 2003
    Posts
    34

    Question Accelerometer and other sensors on Belle

    It seems that some of the sensors are not supported on Symbian Belle when used through QtMoblity Sensors API. Or am I just doing something wrong? I am testing on Nokia 700.

    So... I was porting our QWidget-based apps for Symbian Belle and I got errors when launching:

    Code:
    Launch failed: Command answer [command error], 1 values(s) to request: 'C|87|Processes|start|""|"show_orientation.exe"|[""]|[]|true' 
    #0 {"Code":-5,Format="Failed to create the process (verify that the executable and all required DLLs have been transferred) (functionality is not supported)"}
    Error: 'Failed to create the process (verify that the executable and all required DLLs have been transferred) (functionality is not supported)' Code: -5
    Now this was weird and unexcepted. But as I was adding orientation support to app that was already working on Belle, I found out that reason was use of QOrientationSensor. Further experimenting showed that neither did QtMobility examples work. QOrientationReading, QRotationReading etc. didn't cause that launch error, but they returned null values. However orientation change on a QML example did work.


    But, our apps are OpenGL apps. Using some nasty hack to find out orientation from some invisible QML view doesn't sound good. But are there other options? Is it even possible?


    - virne

  2. #2
    Registered User
    Join Date
    Mar 2003
    Posts
    34

    Re: Accelerometer and other sensors on Belle

    I am using Qt SDK 1.1.4 and I have tried Qt 4.7.4 for Symbian Belle (and for Anna just in case.)

  3. #3
    Super Contributor
    Join Date
    Oct 2008
    Location
    INDIA
    Posts
    2,326

    Re: Accelerometer and other sensors on Belle

    To develop for Belle platform , you need to download Qt SDK1.1.4, using online installer only.

    which SDK you are using ?

  4. #4
    Registered User
    Join Date
    Mar 2003
    Posts
    34

    Re: Accelerometer and other sensors on Belle

    And by not working QtMobility examples, I mean Sensors API examples. Other QtMobility stuff I am using, seems to work fine.

  5. #5
    Registered User
    Join Date
    Mar 2003
    Posts
    34

    Re: Accelerometer and other sensors on Belle

    I am using Qt SDK 1.1.4 and I have tried Qt 4.7.4 for Symbian Belle (and for Anna just in case.)

  6. #6
    Registered User
    Join Date
    Mar 2003
    Posts
    34

    Re: Accelerometer and other sensors on Belle

    And by not working QtMobility examples, I mean Sensors API examples. Other QtMobility stuff I am using, seems to work fine.

  7. #7
    Nokia Developer Expert
    Join Date
    Sep 2011
    Posts
    382

    Re: Accelerometer and other sensors on Belle

    Meanwhile some of the problems were known and QRotationSensor works on Belle unfortunately others does not even when connected to backend.

  8. #8
    Nokia Developer Expert
    Join Date
    Sep 2011
    Posts
    382

    Re: Accelerometer and other sensors on Belle

    Please check this example. Beside its UI issues, it works fine on Belle.

  9. #9
    Registered User
    Join Date
    Feb 2011
    Posts
    3

    Re: Accelerometer and other sensors on Belle

    Quote Originally Posted by Devnull View Post
    Please check this example. Beside its UI issues, it works fine on Belle.
    Hi,

    I tried this example on Belle (N8 & E7). Orientation example shows only angles 0, 15, 30.. and nothing in between. So, it is the same issue as mentioned in this thread.

    Any ideas how to get it working?

  10. #10
    Nokia Developer Expert
    Join Date
    Sep 2011
    Posts
    382

    Re: Accelerometer and other sensors on Belle

    Selecting the generic.rotation sensor instead of the sym.rotation does make the sensor resolution better on C6-01.

  11. #11
    Registered User
    Join Date
    Feb 2011
    Posts
    3

    Re: Accelerometer and other sensors on Belle

    It worked, thank you!

    Solution was to add following lines before starting rotation sensor:
    rotationSensor->setIdentifier("generic.rotation");
    rotationSensor->connectToBackend();

  12. #12
    Nokia Developer Expert
    Join Date
    Sep 2011
    Posts
    382

    Re: Accelerometer and other sensors on Belle

    You are welcome!

Similar Threads

  1. Accelerometer sensors lag
    By ranco in forum [Archived] Flash Lite on Nokia Devices
    Replies: 4
    Last Post: 2010-05-04, 20:41
  2. N96+sensors (another one...)
    By aesteves in forum Mobile Java General
    Replies: 0
    Last Post: 2009-11-04, 17:18
  3. Sensors
    By kamaljaiswal in forum Symbian User Interface
    Replies: 17
    Last Post: 2008-11-21, 09:41
  4. n96 + sensors
    By psinno in forum Symbian
    Replies: 3
    Last Post: 2008-11-10, 00:46

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×