×

Discussion Board

Results 1 to 8 of 8
  1. #1
    Registered User
    Join Date
    Aug 2010
    Posts
    43

    System Error on application launch

    Hi,

    Whenever I press my application's icon, it gives an error message "System Error". I have put ErrRd but that doesn't seem to work as it is not giving any error ID.
    I read similar threads but the solutions didn't work much for me.
    It's quite urgent. Please help.

  2. #2
    Nokia Developer Champion
    Join Date
    Feb 2009
    Location
    India
    Posts
    1,173

    Re: System Error on application launch

    Do check that all your .mif files are lying at the correct required places. This is one of the possible cause of System Error. Also, check your .pkg file and make sure that the files at the source location are placed there so that they will be transferred to the destination (in device).

  3. #3
    Super Contributor
    Join Date
    Oct 2007
    Location
    જુનાગઢ - India
    Posts
    3,034

    Re: System Error on application launch

    Also provide some more inputs like for which platform you compiled your code and testing on which device.

  4. #4
    Super Contributor
    Join Date
    Mar 2008
    Posts
    1,481

    Re: System Error on application launch

    I guess you are not handling any leave from your code as result that is propagated to UI as system error, this is one of the reason.
    Make sure in your ConstractL method or somewhere you are handling all thrown exception (by system or by your code)

  5. #5
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,166

    Re: System Error on application launch

    You could try out Y-Tasks (Self-signed version is sufficient for the task) it will always get all process exit codes, thus you would be able to see the exit code with it at least.

  6. #6
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,688

    Re: System Error on application launch

    If ErrRd is enabled and you get System Error without ornaments, you could also check the UID. Check if it matches in the .mmp and AppDllUid method, perhaps in the _reg.rss too.

  7. #7
    Registered User
    Join Date
    Aug 2010
    Posts
    43

    Re: System Error on application launch

    all the UID's match.

    Also, the application gives this error on the emulator too. so is there any problem with my installed symbian files?

  8. #8
    Nokia Developer Champion
    Join Date
    Jun 2008
    Location
    Noida,India
    Posts
    4,025

    Re: System Error on application launch

    Does the error displays some figure as well. For e.g system error -1

Similar Threads

  1. Replies: 18
    Last Post: 2011-11-08, 11:46
  2. system error on application launch
    By Baba007 in forum Symbian
    Replies: 8
    Last Post: 2010-04-30, 07:08
  3. unable to launch the application system error -1
    By chintandhruva in forum Symbian
    Replies: 12
    Last Post: 2009-12-21, 13:27
  4. Replies: 1
    Last Post: 2009-07-29, 07:00
  5. Replies: 2
    Last Post: 2008-01-03, 12:46

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×