×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Registered User
    Join Date
    Dec 2011
    Posts
    3

    CSS Rendering incorrectly when deployed onto device.

    Hi guys,

    Just starting a Nokia project and I am getting some bizzare results when I have deployed onto a device.

    I'm starting with a basic menu with 4 cells with an image and title to go with them. This renders nicely on the browser and in the Nokia simulator.

    Now appropriate standard styles are applied in the form of CSS and HTML and the structure is:

    <div (cell)>
    <div (image)><img></img></div>
    <div (text)></div>
    </div>

    However, when I load onto a device the text dissapeared and I was left with just the background colour of the cell and the image, once I removed the background colour I found the text was hidden below the image.

    It looks somewhat like when its packaged and deployed it ignores the inline-block property and the order in which things are declared (as its appearing below the background-color of the containing div)

    Can anyone offer any light as i'm aboslutely baffeled?

    Thanks,

    Mike B

  2. #2
    Nokia Developer Moderator
    Join Date
    Jun 2008
    Location
    Tampere
    Posts
    833

    Re: CSS Rendering incorrectly when deployed onto device.

    Hello Mike and welcome to forum!

    Could you share CSS that goes with code, so we can take a look and try to reproduce the issue you are facing?

    One reason why this does not work, can be that inline-block is not supported. Supported values for display are: inline | block | none
    http://www.developer.nokia.com/Resou...supported.html


    Br,
    Ilkka

  3. #3
    Registered User
    Join Date
    Dec 2011
    Posts
    3

    Re: CSS Rendering incorrectly when deployed onto device.

    Thanks,

    That is exactally why it is rendering incorrectly that is strange and irratating although I realise why as everything was displaying correctly in the simulator. what is the general fix for inline-block not being supported?

    My head tells me not to use a table, I guess it will have to be trying to use floats?

    Cheers,

    Mike B

  4. #4
    Nokia Developer Moderator
    Join Date
    Jun 2008
    Location
    Tampere
    Posts
    833

    Re: CSS Rendering incorrectly when deployed onto device.

    Unfortunately floats are not supported either, so table is the only way to go.
    See section 2.1 Page Layout in http://tools.nokia.com/wt/doc/jsdt/s...ices_Guide.pdf

    Cloud preview is recommended to use for previewing, instead of local preview. Local preview is good for JavaScript debugging purposes, but it is not suitable for verifying layouts etc. That is because it does not run the content trough the proxy.

    Br,
    Ilkka

Similar Threads

  1. Buggy Rendering on device
    By artinteg in forum Nokia Asha Web Apps
    Replies: 1
    Last Post: 2011-05-31, 10:42
  2. Bad rendering SVG icon in device , try in N96
    By hariyanto_toto in forum Symbian Media (Closed)
    Replies: 1
    Last Post: 2010-12-17, 11:11
  3. How deployed executable with dll?
    By miluit01 in forum Open C/C++
    Replies: 1
    Last Post: 2010-10-06, 14:06

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •