×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Registered User
    Join Date
    Dec 2011
    Posts
    33

    IAPClientPaymentException: Application ID initialization fails

    I just want to know, what can make the IAP prompt this kind of exception "com.nokia.mid.payment.IAPClientPaymentException: Application ID initialization fails" when you test it in the emulator.

    Thanks,
    Mark

  2. #2
    Registered User
    Join Date
    Dec 2008
    Location
    Cochin, Kerala, India
    Posts
    84

    Re: IAPClientPaymentException: Application ID initialization fails

    Hi Mark,

    Do you mean that you're getting the error even when running the application. Which Emulator are you using for testing? It may depends upon that. Please specify that.


    Regards
    Vineeth K.


    Quote Originally Posted by foo_mark View Post
    I just want to know, what can make the IAP prompt this kind of exception "com.nokia.mid.payment.IAPClientPaymentException: Application ID initialization fails" when you test it in the emulator.

    Thanks,
    Mark

  3. #3
    Registered User
    Join Date
    Dec 2011
    Posts
    33

    Re: IAPClientPaymentException: Application ID initialization fails

    Hi Vineeth,

    I found out that you needed IAP_VARIANTID.TXT and TEST_MODE.TXT in the "root" of your JAR and not in this folder called "res".

    Cheers,
    Mark

  4. #4
    Registered User
    Join Date
    Jul 2012
    Posts
    2

    Re: IAPClientPaymentException: Application ID initialization fails

    Hi foo_mark,

    How did you solve this problem? When I keep the files in my res folder this error does not come. But when I am keeping the files in the root folder this exception is thrown.
    Another related question: The documentation says to remove the TEST_MODE.TXT file when pointing it to live server. I removed the text but now I get Security Exception. Whats the workaround for this? I am using java sdk 2.0 and the emulator that came with it.

    Thanks,
    Moiz

Similar Threads

  1. Application fails to query the database...
    By bishal_sahu in forum Symbian Signed Support, Application Packaging and Distribution and Security
    Replies: 1
    Last Post: 2010-01-19, 12:35
  2. Application install fails on Nokia n72
    By sanket2612 in forum Mobile Java General
    Replies: 7
    Last Post: 2009-02-26, 09:15
  3. Application startup fails in N72, static initialization is to blame ?
    By kamanashisroy in forum Mobile Java General
    Replies: 2
    Last Post: 2008-06-18, 08:23
  4. application fails on s60 devices
    By yeliya in forum Mobile Java General
    Replies: 6
    Last Post: 2008-05-08, 12:54
  5. How to display an initialization dialog at application startup?
    By pzul_wisner in forum Symbian User Interface
    Replies: 1
    Last Post: 2007-09-20, 16:53

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •