Latest smart installer works fine on Anna and Belle devices, but fails to install anything on [at least some] pre-Anna firmwares. I reproduced the situation on several devices, in particular on Nokia C7 14.002 that you can find (and try) in Nokia's Remote Device Access (look for imei 355379042829001)

Logs investigations show that it is PIPS 1.7.6 installation that actually fails:
====
14/12/2011 6:16:34 Installing 'C:\system\adm\pips_s60_1_7_6_ss.sis' to C:
14/12/2011 6:16:35 DlSt= 13, PrSt= 0, L=0
14/12/2011 6:16:35 + SilentInstallPackage(): 'C:\system\adm\pips_s60_1_7_6_ss.sis' to C:
14/12/2011 6:16:55 CInstallManager: Install completed (-30478). 0
14/12/2011 6:16:55 HandleInstallCompletedL(-30478): 13
14/12/2011 6:16:55 Removing 'C:\system\adm\pips_s60_1_7_6_ss.sis'
14/12/2011 6:16:56 Dependency installation failed -30478
14/12/2011 6:16:56 + SetState(): 13 -> 16
====

You can see full logs at http://pastebin.com/Sj5ZmzcG

*Additional information that may or may not be relevant*

1. A little earlier (end of Nov 2011) to the device that now has problems I was able to install smart installer packages prepared by Remote Compiler 4.7.3 for Symbian 3

2. Now (mid Dec 2011) I fail to install smart installer packages prepared by remote compiler 4.7.4 for Symbian Anna.

3. I also tried requesting older 4.7.3 Symbian 3 build from remote compiler - didn't help (apparently it uses latest smart installer)

4. So I tried starting Windows, installing older 1.1.3 Qt SDK (the last one that allows you to build 4.7.3 binaries locally), tried building smart installer 4.7.3 packages with it. Still didn't help

Please, help