×

Discussion Board

Page 1 of 2 12 LastLast
Results 1 to 15 of 16
  1. #1
    Registered User
    Join Date
    Jul 2003
    Location
    Finland, Tampere
    Posts
    1,113

    SmartInstaller fails to install anything to older S3 devices

    Latest smart installer works fine on Anna and Belle devices, but fails to install anything on [at least some] pre-Anna firmwares. I reproduced the situation on several devices, in particular on Nokia C7 14.002 that you can find (and try) in Nokia's Remote Device Access (look for imei 355379042829001)

    Logs investigations show that it is PIPS 1.7.6 installation that actually fails:
    ====
    14/12/2011 6:16:34 Installing 'C:\system\adm\pips_s60_1_7_6_ss.sis' to C:
    14/12/2011 6:16:35 DlSt= 13, PrSt= 0, L=0
    14/12/2011 6:16:35 + SilentInstallPackage(): 'C:\system\adm\pips_s60_1_7_6_ss.sis' to C:
    14/12/2011 6:16:55 CInstallManager: Install completed (-30478). 0
    14/12/2011 6:16:55 HandleInstallCompletedL(-30478): 13
    14/12/2011 6:16:55 Removing 'C:\system\adm\pips_s60_1_7_6_ss.sis'
    14/12/2011 6:16:56 Dependency installation failed -30478
    14/12/2011 6:16:56 + SetState(): 13 -> 16
    ====

    You can see full logs at http://pastebin.com/Sj5ZmzcG

    *Additional information that may or may not be relevant*

    1. A little earlier (end of Nov 2011) to the device that now has problems I was able to install smart installer packages prepared by Remote Compiler 4.7.3 for Symbian 3

    2. Now (mid Dec 2011) I fail to install smart installer packages prepared by remote compiler 4.7.4 for Symbian Anna.

    3. I also tried requesting older 4.7.3 Symbian 3 build from remote compiler - didn't help (apparently it uses latest smart installer)

    4. So I tried starting Windows, installing older 1.1.3 Qt SDK (the last one that allows you to build 4.7.3 binaries locally), tried building smart installer 4.7.3 packages with it. Still didn't help

    Please, help

  2. #2
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,355

    Re: SmartInstaller fails to install anything to older S3 devices

    The 1.7.6 version of OpenC is rather recent, but I have to check when exactly was added to the system.

    I just checked a log file I have from a N8 with PR 1.0 (11.012, so even older than your C7 PR 1.2) and on that device the OpenC install was successful.

    The phone you use may have a configuration problem which will have to be analysed before further comments can be made. I will let you know once I find something useful.
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  3. #3
    Registered User
    Join Date
    Jul 2003
    Location
    Finland, Tampere
    Posts
    1,113

    Re: SmartInstaller fails to install anything to older S3 devices

    I've got another problematic device (at hand, not via remote device access) and here are some further investigation results that point to that it is exactly PIPS 1.7.6 installation that fails on the old firmware (and on newer firmware it seems to be present already so no installation needed).

    Device: Nokia N8, PR1.2, 014.002

    I tried installing Qt Quick helloworld built yesterday on the 1.1.3 SDK for windows (using 4.7.3 for Symbian 3 + smart installer + self-signed).
    The full installation log is at http://pastebin.com/kRSMkqC7
    Interesting details are as follows:
    =====
    14/12/2011 11:39:28 Installing 'C:\system\adm\pips_s60_1_7_6_ss.sis' to C:
    14/12/2011 11:39:29 DlSt= 13, PrSt= 0, L=0
    14/12/2011 11:39:29 + SilentInstallPackage(): 'C:\system\adm\pips_s60_1_7_6_ss.sis' to C:
    14/12/2011 11:39:40 CInstallManager: Install completed (-30478). 0
    14/12/2011 11:39:40 HandleInstallCompletedL(-30478): 13
    14/12/2011 11:39:40 Removing 'C:\system\adm\pips_s60_1_7_6_ss.sis'
    14/12/2011 11:39:40 Dependency installation failed -30478
    =====

    Interestingly a little earlier log seems to claim there was no pips at all in the firmware:
    =====
    14/12/2011 11:39:21 [0x20013851] v0.00.0 installed
    14/12/2011 11:39:21 [0x20013851] v1.07.6 requested
    =====

    So I guess smart installer decided to download the latest PIPS available (even though Qt 4.7.3 didn't really need PIPS 1.7.6 and could live with PIPS 1.7.5). Earlier logs seem to indicate that 4.7.4 was somehow present on device though I can't quite understand how it could exist without PIPS:
    =====
    14/12/2011 11:39:17 * Processing 0x2001E61C (0, 0)
    14/12/2011 11:39:17 FileCheck: c:\sys\bin\QtCore.dll (0)
    14/12/2011 11:39:17 Package 0x2001E61C files present
    14/12/2011 11:39:17 Package 0x2001E61C: v4.07.403 installed (v4.07.3 requested)
    14/12/2011 11:39:17 + SetState(): 2 -> 3
    14/12/2011 11:39:17 Downloading CHANGES: '2001e61c_changes.xml'
    14/12/2011 11:39:18 Starting download
    14/12/2011 11:39:18 DL 40169/ 40169 (0.3 s, 137.52 kB/s) (total: 39 kB, 0.3 s, avg 137.52 kB/s) OK
    14/12/2011 11:39:18 + SetState(): 3 -> 4
    14/12/2011 11:39:18 + ParseChangesFileL(): 'C:\system\adm\2001e61c_changes.xml'
    14/12/2011 11:39:19 [0x2001E61C] v4.07.403 installed
    14/12/2011 11:39:19 [0x2001E61C] v4.07.3 requested
    14/12/2011 11:39:19 [0x2001E61C] v4.07.403 selected
    =====

    Now if you have a look at PIPS changes xml at http://dl.qt.nokia.com/smartinstalle...51_changes.xml you can see that 1.7.6 was released on Dec 1, 2011. Seems to be exactly the timing where the problems started.

    I hope it helps. Please, ask for more information if needed.

    P.S.
    Additional symptom that may or may not be related
    On the same problematic device Qt Info 3.00 crashes after "Determining system fonts" that is supposed to be the last message before showing the parsed info. Possibly the reason is the same - crash of Qt/QML because of wrong/missing PIPS

  4. #4
    Registered User
    Join Date
    Oct 2011
    Posts
    26

    Re: SmartInstaller fails to install anything to older S3 devices

    I can reproduce this on 2 devices from RDA.

  5. #5
    Registered User
    Join Date
    Jul 2003
    Location
    Finland, Tampere
    Posts
    1,113

    Re: SmartInstaller fails to install anything to older S3 devices

    And the final and very interesting experiment.
    C7 PR1.1, 013.016

    I was able to successfully install both packages needing 4.7.3 and 4.7.4, everything worked fine.
    And then I decided to make a clean experiment and reset the device (using *#7370#) and tried installing package that needs 4.7.3 again. It resulted in the very same PIPS 1.7.6 failure, see logs at http://pastebin.com/qWCpsSHZ

    It looks like the very definition of either 4.7.4 or 4.7.3 or both or maybe of other versions as well changed lately. So if phone *already* has 4.7.3 (or 4.7.4? or PIPS of good enough version), everything is fine. Otherwise smart installer will try installing PIPS 1.7.6 and will fail.
    Last edited by doctordwarf; 2011-12-15 at 11:47. Reason: Fixed typo in the reset code

  6. #6
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,355

    Re: SmartInstaller fails to install anything to older S3 devices

    The hard reset is known to cause problems as the UDA part of the ROM image, basically the C:\ drive which contains the pre-installed Qt will be [partially] deleted. I wonder if this reset is what explains the problems with the other devices from RDA as well.

    My colleagues from the Smart Installer team have tested this with PR 1.2 and it all works swell.
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  7. #7
    Registered User
    Join Date
    Jul 2003
    Location
    Finland, Tampere
    Posts
    1,113

    Re: SmartInstaller fails to install anything to older S3 devices

    Hmm, I had an idea that during the hard reset C:\ drive gets restored to its original state somehow.. :/

    In any case my understanding of smart installer was exactly that it smartly installs everything missing as we cannot tell the customers that Qt doesn't support their phone if they reset the device once
    Also I have at least one concrete device (the above mentioned N8 PR1.2, 014.002) that was installing 4.7.3 apps fine, then failed to accept 4.7.4 app and after that no single 4.7.3 app can be installed to it. Right now it also passed hard reset, but the problem started before the hard reset.

    If you like we can meet e.g. tomorrow and I can show the device and the situation live.

  8. #8
    Registered User
    Join Date
    Jul 2003
    Location
    Finland, Tampere
    Posts
    1,113

    Re: SmartInstaller fails to install anything to older S3 devices

    Also do you happen to have an idea about how to fix the situation at least for a concrete problematic device at hand. That would help me to fix the customer's device while the common solution is being researched. Maybe there is a way to force reinstallation of the whole Qt manually?

  9. #9
    Registered User
    Join Date
    Oct 2011
    Posts
    26

    Re: SmartInstaller fails to install anything to older S3 devices

    Where are we at with this issue ? Any improvements ? We wouldn't like to publish our application and have some users unable to install it.

    Thanks

  10. #10
    Registered User
    Join Date
    Oct 2011
    Posts
    7

    Re: SmartInstaller fails to install anything to older S3 devices

    Hi, it looks we have the same problem:
    Smart Installer began failing in the beginning of December when trying to install on S^3 devices (N8 or C7 with 014.002).

    Is the last working version (1.7.5?) of PIPS installer available for download somewhere?

    br,
    Mika

  11. #11
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,355

    Re: SmartInstaller fails to install anything to older S3 devices

    Mika, the conclusing of the tests was that this will fail on devices which have been formatted, and there is nothing can be done by smart installer to such devices, they would have to be reflashed in an authorised service point in order for the c:\ drive image to be overwritten.
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  12. #12
    Registered User
    Join Date
    Jul 2003
    Location
    Finland, Tampere
    Posts
    1,113

    Re: SmartInstaller fails to install anything to older S3 devices

    Hmm, I was able to repair one N8 with a formatted C: drive by pure installations/reinstallations. Unfortunately I didn't keep track on what exactly I was doing, but what's possible to fix by manual installations should be possible to fix automatically as well.

    Mika, Google on the topic. I didn't exactly follow the recipes on the web, but it was close to them. Something like *#7370# then install 4.6.3, then WebKit, then 4.7.x and maybe opengl somewhere in the middle.

  13. #13
    Registered User
    Join Date
    Oct 2011
    Posts
    7

    Re: SmartInstaller fails to install anything to older S3 devices

    Quote Originally Posted by ltomuta View Post
    Mika, the conclusing of the tests was that this will fail on devices which have been formatted, and there is nothing can be done by smart installer to such devices, they would have to be reflashed in an authorised service point in order for the c:\ drive image to be overwritten.
    Ok, thanks for the prompt reply - this alone is sufficient information for us but if you don't mind I'd like to make a couple of true/false statements to make sure I got it right

    1) If we get a new shiny N8 from the shop with S^3, Smart Installer will work fine on it
    2) If we perform *#7370# reset on the same device, Smart Installer will fail installing after the reset (does *#7370# format the c:\ ?)
    3) It is not possible to fix the issue by manually installing PIPS but it is more complicated
    4) Upgrading to Anna may resolve the issue

    br,
    Mika

  14. #14
    Registered User
    Join Date
    Oct 2011
    Posts
    7

    Re: SmartInstaller fails to install anything to older S3 devices

    Quote Originally Posted by doctordwarf View Post
    Hmm, I was able to repair one N8 with a formatted C: drive by pure installations/reinstallations. Unfortunately I didn't keep track on what exactly I was doing, but what's possible to fix by manual installations should be possible to fix automatically as well.

    Mika, Google on the topic. I didn't exactly follow the recipes on the web, but it was close to them. Something like *#7370# then install 4.6.3, then WebKit, then 4.7.x and maybe opengl somewhere in the middle.
    Thanks for the tip. We upgraded the devices to Anna which probably resolved the issue. But recently we got feedback related to Smart Installer failing with S^3 and we are unable to reproduce it as there is no going back.

  15. #15
    Registered User
    Join Date
    Jul 2003
    Location
    Finland, Tampere
    Posts
    1,113

    Re: SmartInstaller fails to install anything to older S3 devices

    Hmm, in my case upgrade to Anna didn't help and *#7370# was able to break a C7 with Anna. I don't really know what the exact conditions for reproducing the problem are,

Page 1 of 2 12 LastLast

Similar Threads

  1. Belle firmware for older devices
    By pippo2010 in forum Publishing to Nokia Store
    Replies: 5
    Last Post: 2011-12-10, 09:41
  2. [moved] Session Cookie Issues with older Nokia/Symbian Devices
    By johnoverbaugh in forum Mobile Web Site Development
    Replies: 2
    Last Post: 2008-07-10, 22:56
  3. application fails on s60 devices
    By yeliya in forum Mobile Java General
    Replies: 6
    Last Post: 2008-05-08, 12:54
  4. Replies: 0
    Last Post: 2008-02-14, 10:27
  5. Replies: 1
    Last Post: 2004-07-09, 15:31

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •