×

Discussion Board

Results 1 to 12 of 12
  1. #1
    Registered User
    Join Date
    Dec 2011
    Location
    India
    Posts
    4

    Strange Issue with Qt SDK and Qt Creator

    Hi everyone,
    I am having a strange issue with Qt SDK & Creator.
    I have recently received Nokia N9 and want to try creating apps for it. I already had old SDK I used for N8 but as MeeGo Harmattan Target was not available, I tried to run Updater from Qt Creator but nothing happened. So when I checked, SDKMaintenanceTool.exe was missing. I redownloaded latest SDK and ran Maintenance tool directly and installed Harmattan target and components (not Emulator) and installed all updates available. But Qt Quick was still showing that no Qt version available for Harmattan components!
    So when I again tried to start updater from Qt Creator, nothing happened and when I checked, SDKMaintenanceTool.exe was missing again!
    Can someone explain me what am I doing wrong, why no harmattan target is not available and why starting updater, SDKMaintenceTool.exe is getting removed?

  2. #2
    Super Contributor
    Join Date
    Oct 2008
    Location
    INDIA
    Posts
    2,326

    Re: Strange Issue with Qt SDK and Qt Creator

    The previous SDK does not have full release of Harmattan Target , So, Download new Qt SDK 1.1.4 : [ from here ]

  3. #3
    Registered User
    Join Date
    Dec 2011
    Location
    India
    Posts
    4

    Re: Strange Issue with Qt SDK and Qt Creator

    Downloaded Qt SDK 1.1.2 yesterday spending more than 10 hours! Maybe wrong reference from Google. Well, downloading SDK again.
    Thanks.

  4. #4
    Registered User
    Join Date
    Dec 2011
    Location
    India
    Posts
    4

    Re: Strange Issue with Qt SDK and Qt Creator

    I have got all things and getting MeeGo as target but when trying to compile, I get error.
    Compiler Output:
    Code:
    Running build steps for project gpsmeefo...
    Configuration unchanged, skipping qmake step.
    Starting: "E:\qtsdk\madde\bin\make.exe" -w
    make: Entering directory `/e/GPS-MeeFo/gpsmeefo'
    make: Nothing to be done for `first'.
    make: Leaving directory `/e/GPS-MeeFo/gpsmeefo'
    The process "E:\qtsdk\madde\bin\make.exe" exited normally.
    Creating package file ...
    Package Creation: Running command 'e:/qtsdk/madde/bin/mad dpkg-buildpackage -nc -uc -us'.
    dpkg-buildpackage: set CFLAGS to default value: -g -O2
    dpkg-buildpackage: set CPPFLAGS to default value: 
    dpkg-buildpackage: set LDFLAGS to default value: 
    dpkg-buildpackage: set FFLAGS to default value: -g -O2
    dpkg-buildpackage: set CXXFLAGS to default value: -g -O2
    which: pgp: unknown command
    dpkg-buildpackage: source package gpsmeefo
    dpkg-buildpackage: source version 1.2.0
    dpkg-buildpackage: source changed by unknown <>
    dpkg-buildpackage: host architecture armel
    /sysroots/harmattan_sysroot_10.2011.34-1_slim/sysroots/harmattan_sysroot_10.2011.34-1_slim/sysroots/harmattan_sysroot_10.2011.34-1_slim/var/lib/dpkg/status: No such file or directory
    dpkg-buildpackage: warning: Build dependencies/conflicts unsatisfied; aborting.
    dpkg-buildpackage: warning: (Use -d flag to override.)
    Packaging Error: Command 'e:/qtsdk/madde/bin/mad dpkg-buildpackage -nc -uc -us' failed.Exit code: 3
    Error while building project gpsmeefo (target: Harmattan)
    When executing build step 'Create Debian Package'
    What am I doing wrong?

  5. #5
    Nokia Developer Champion
    Join Date
    Nov 2009
    Posts
    200

    Re: Strange Issue with Qt SDK and Qt Creator

    Code:
    dpkg-buildpackage: warning: Build dependencies/conflicts unsatisfied; aborting.
    You apparently have some missing requirement in Build-Depends field (qtc_packaging/debian_harmattan/control)

    edit:
    looking at this: /sysroots/harmattan_sysroot_10.2011.34-1_slim/sysroots/harmattan_sysroot_10.2011.34-1_slim/sysroots/harmattan_sysroot_10.2011.34-1_slim/var/lib/dpkg/status: No such file or directory

    Do you have Harmattan target completely installed? (Updater tool/Development Tools/Harmattan/Harmattan Target)
    Last edited by mikkovtr; 2011-12-19 at 10:35.

  6. #6
    Registered User
    Join Date
    Dec 2011
    Location
    India
    Posts
    4

    Re: Strange Issue with Qt SDK and Qt Creator

    Yes, I have successfully installed target, only skipped Emulator as I already have N9 to test (suggested so by @ltomuta )

  7. #7
    Registered User
    Join Date
    Oct 2011
    Posts
    33

    Re: Strange Issue with Qt SDK and Qt Creator

    Hi! I got the same problem. On creating package step got such error:
    Code:
    /sysroots/harmattan_sysroot_10.2011.34-1_slim/sysroots/harmattan_sysroot_10.2011.34-1_slim/var/lib/dpkg/status: No such file or directory
    I develop under Windows using latest SDK 1.1.4 with installed Harmattan target. Has somebody resolved that issue?

  8. #8
    Registered User
    Join Date
    Oct 2011
    Posts
    33

    Re: Strange Issue with Qt SDK and Qt Creator

    I found the problem occurs if during SDK installation get some error. I post this bug at bugreports https://bugreports.qt-project.org/browse/QTSDK-1198

  9. #9
    Registered User
    Join Date
    Mar 2012
    Posts
    1

    Re: Strange Issue with Qt SDK and Qt Creator

    to Habolog with the latest (Feb 2012) appearance of this
    particular issue:

    i had the similar issue, by being the newest harmattan
    user and developer, and i managed to hack into the
    problem, so here's the solution.

    in Madde/madlib/ma-create-target.sh lines 299 and 300,
    replace \\\ with \\\\ in subsequent tr regexps.

    then execute Madde/postinstall/harmattan-postinstall.sh

    harmattan target will be accessible from qt creator then,
    maybe only after restart.

    almost certainly dpkg on the N9 device will complain
    locked (due to previous unsuccessful deployments of
    test or production app), so you may also execute this on
    your N9 device:

    rm /var/lib/dpkg/lock

    and probably also, but not necessarily:

    dpkg --configure -a

    from this point on, you'll have your app in N9 up and
    running

    this patch nokia developers has to include in the
    repository for immediate update.

    please, Habolog, once you find this resolving, feel free to
    publish the result to the qtsdk bugreports thread you've
    mentioned in your previous post.

    thanks
    Last edited by malisha; 2012-03-21 at 20:17.

  10. #10
    Registered User
    Join Date
    Mar 2012
    Posts
    2

    Re: Strange Issue with Qt SDK and Qt Creator

    Quote Originally Posted by malisha View Post
    in Madde/madlib/ma-create-target.sh lines 299 and 300,
    replace \\\ with \\\\ in subsequent tr regexps.

    then execute Madde/postinstall/harmattan-postinstall.sh
    This doesn't work for me on Windows, anyone know what else I might have to do? Once I've edited the file and try running harmattan-postinstall.sh (either from a cygwin shell, or from a "MADDE Terminal" that was installed with the Qt SDK), I get a message "An error occurred. Press Ctrl-C to exit", but it doesn't say what the error is.

    Thanks,
    Miles

    PS: I spent all day trying to get linux to work on this laptop so I could just develop Qt apps from linux, but I screwed up my Ubuntu install trying to disable Unity, and I can't get networking to work under Arch linux (stupid driver problems). So in the meantime I'd like to be able to write programs for my phone from Windows (my Qt program builds and executes fine on windows, but I am stuck with the above problem when trying to build for the phone).

  11. #11
    Registered User
    Join Date
    Oct 2011
    Posts
    33

    Re: Strange Issue with Qt SDK and Qt Creator

    malisha, thanks for suggestion, but how to do that in Windows? I've tried madde terminal but it failed to run that script.

  12. #12
    Registered User
    Join Date
    Mar 2012
    Posts
    2

    Re: Strange Issue with Qt SDK and Qt Creator

    I found a post that suggesting reinstalling with the offline-installer *after* manually deleting C:\QtSDK, and that did the trick, everything works now. (I had tried reinstalling without deleting C:\QtSDK, and the problem remained)

Similar Threads

  1. Need help to the strange issue
    By SecondInnings in forum Symbian C++
    Replies: 7
    Last Post: 2011-08-26, 15:07
  2. Strange issue please anybody help ?
    By aamitgupta in forum Symbian C++
    Replies: 11
    Last Post: 2009-05-04, 19:05
  3. Strange issue with TSoInetInterfaceInfo
    By patrickfrei in forum Symbian Networking & Messaging (Closed)
    Replies: 1
    Last Post: 2008-01-21, 09:37
  4. Strange issue in N73, pleez help...
    By mailtomandy2000 in forum Symbian C++
    Replies: 1
    Last Post: 2007-05-01, 19:38
  5. Strange password issue
    By marciano in forum Symbian C++
    Replies: 1
    Last Post: 2006-11-29, 00:56

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •