I installed Fillr on N9, and the Ovi Store client told me that and old application needs to be removed in order to install it, but it did not tell me which old application.
I'd like a bit more information in a case like this, optionally down to the level of conflicting files.

This is with Store 3.16.009+0m6