×

Discussion Board

Results 1 to 15 of 21

Hybrid View

  1. #1
    Registered User
    Join Date
    Dec 2011
    Posts
    19

    System Error (-1) !!

    I have designed a simple gui app for my nokia x6 using Qt.But when i run it, it gives me SystemError(-1) message. plz help me! i have installed all the QT files on my cell!!
    i am using this code!!!

    #include "mainwindow.h"
    #include "ui_mainwindow.h"

    MainWindow::MainWindow(QWidget *parent) :
    QMainWindow(parent),
    ui(new Ui::MainWindow)
    {
    ui->setupUi(this);
    }

    MainWindow::~MainWindow()
    {
    delete ui;
    }

    void MainWindow:n_pushButton_clicked()
    {

    ui->listWidget->addItem(ui->lineEdit->text());
    ui->textEdit->setText("Hello");
    }

  2. #2
    Registered User
    Join Date
    Feb 2007
    Location
    India
    Posts
    1,128

    Re: System Error (-1) !!

    Hi,

    Are you testing app on emulator or phone?

    If you are testing app on emulator..than debug code line by line and check which line it's crash.........Generally this error comes Resource missing.....

  3. #3
    Super Contributor
    Join Date
    Mar 2008
    Posts
    1,481

    Re: System Error (-1) !!

    This code looks fine. In Symbian -1 means not found, have you commented or removed some code from your project so the initialization is not happening properly?

  4. #4
    Registered User
    Join Date
    Dec 2011
    Posts
    19

    Re: System Error (-1) !!

    i have recently found that its not because of code! its something else!! i have tried to install the QT built in examples too ! they also give the same error.Don't know why??

  5. #5
    Registered User
    Join Date
    Dec 2011
    Posts
    19

    Re: System Error (-1) !!

    my emulator doesn't work.So m trying my first app on my cell!! Moreover ,when i build the files for my device,the software gives me the
    error
    plz tell me
    Launching: calculator.exe
    Launch failed: Command answer [command error], 1 values(s) to request: 'C|8|Processes|start|""|"calculator.exe"|[""]|[]|true'
    #0 {"Code":-1,Format="Failed to create the process (verify that the executable and all required DLLs have been transferred) (item not found)"}
    Error: 'Failed to create the process (verify that the executable and all required DLLs have been transferred) (item not found)' Code: -1
    Finished.

  6. #6
    Super Contributor
    Join Date
    Mar 2008
    Posts
    1,481

    Re: System Error (-1) !!

    Was your coda sw in the phone was running and was connected to your PC?
    Could you check that and also create the wizards to create a simple hello word type application and try to install and run it.
    Please repost your findings here.

  7. #7
    Registered User
    Join Date
    Dec 2011
    Posts
    19

    Re: System Error (-1) !!

    @mahbub_s60 !!! i have also tried to install the built in QT examples!! but when installed!! they don't run!!

Similar Threads

  1. Fatal: IO Error:SymbainOS error = -34 : General: System error
    By dharmeshkhatri in forum Mobile Java Networking & Messaging & Security
    Replies: 9
    Last Post: 2010-04-12, 15:17
  2. Replies: 3
    Last Post: 2009-05-18, 09:38
  3. running easydgm on simulator occur error:system error(-1)
    By mandysss in forum Symbian Networking & Messaging (Closed)
    Replies: 2
    Last Post: 2008-10-31, 05:46
  4. java.io.IOEXCEPTION: SymbianOS error = -33 : System error
    By hari_scjp in forum Mobile Java Networking & Messaging & Security
    Replies: 1
    Last Post: 2006-02-27, 13:38
  5. java.io.IOException: SymbianOS error = -28 : System error
    By raghuraman in forum Mobile Java Networking & Messaging & Security
    Replies: 2
    Last Post: 2004-10-21, 09:33

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×