×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Registered User
    Join Date
    May 2009
    Location
    Guatemala
    Posts
    186

    Qt SDK 1.1.4 for S60 5th

    Hi everybody.

    I don't develop Qt applications since april 2011, and am currently trying to install the necessary tools to start developing Qt applications again but I'm not sure if the Qt SDK 1.1.4 is what I need to install.

    I'm going to work on an application that will run on Symbian Anna and Belle devices, but I also want it to run on S60 5th edition.

    These are my doubts:

    This post on the Nokia Developer site says that "The targets for Qt 4.6.3 for Symbian and Qt 4.7.3 for Symbian^3 and Symbian Anna have been removed from Qt SDK 1.1.4. To develop for these targets, use Qt SDK 1.1.2"

    But This post on Qt Labs says that "The Qt 4.7.4-based bundle is not supported in S60 5th Edition devices where the last supported Qt version is Qt 4.7.3. To support this Qt SDK 1.1.4 has the Qt 4.7.3 for S60 5th Edition build target (this was earlier named as Symbian^1)"

    So, does the Qt SDK 1.1.4 have the Qt 4.7.3 target for S60 5th edition or not ?

    Maybe there is no contradiction, but I would like to have some clarification.

    I remember that I read somewhere that it was only included in the online installer. Is that correct ? If so, why ?

    I currently have a very bad and slow internet connection at home, and downloading the 1.5 Gigs there will take forever, but I have a super fast network at work, which I usually use to download installers for my home computer. But in this case, it seems that I won't be able to do that because the offline installer is for some unknown reason (at least for me) different than the online version. Is there a way to download all necessary tools that are included in the 1.1.4 version, but with the Qt 4.7.3 target for S60 5th, and save them for later use on another machine ?

    And an additional doubt: Can a same content item have one Qt 4.7.3 file for S60 5th and one Qt 4.7.4 for Anna/Belle ? Does the store support this ?

    Thank you very much for your answers and comments.

    Best,
    -CarlosDL

  2. #2
    Nokia Developer Expert
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,143

    Re: Qt SDK 1.1.4 for S60 5th

    Basically you would build a separately for Symbian^3 & Symbian^1 by using the most uptodate version supported by the paltform. i.e for Symbian^3 you would use Qt 4.7.4 and Qt 4.7.3 for Symbian^1.

    If the possibility for Symbian^1 is not available, you could check the updater and see that it gets installed from there.

  3. #3
    Nokia Developer Expert
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,143

    Re: Qt SDK 1.1.4 for S60 5th

    Basically you would build a separately for Symbian^3 & Symbian^1 by using the most uptodate version supported by the paltform. i.e for Symbian^3 you would use Qt 4.7.4 and Qt 4.7.3 for Symbian^1.

    If the possibility for Symbian^1 is not available, you could check the updater and see that it gets installed from there.

  4. #4
    Registered User
    Join Date
    May 2009
    Location
    Guatemala
    Posts
    186

    Re: Qt SDK 1.1.4 for S60 5th

    Thanks,

    I managed to install it by using the online installer, and it in fact includes the S60 5th build target.
    I have also confirmed that the Store does support combinations of different Qt versions for the same content item.

    Best,
    -CarlosDL

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •