×

Discussion Board

Results 1 to 10 of 10
  1. #1
    Registered User
    Join Date
    Nov 2010
    Location
    Finland
    Posts
    91

    Question GPS and GalleryViewer works when launched via QtCreator,not when opened from phone??

    What could be the problem
    QtMobility.location 1.1 working in N950/N9 when build from QtCreator with cable, but not when opened from the phone itself.

    There is two things:
    PositionSource & DocumentGalleryModel

    both works nicely in my N950/N9 when I run from QtCreator via cable, but if I use the phone itself to open the app, these doesn’t work. It just doesn’t open gps connection or show any photos.

    Any ideas?

  2. #2
    Registered User
    Join Date
    Sep 2011
    Posts
    449

    Re: GPS and GalleryViewer works when launched via QtCreator,not when opened from phon

    Hi,

    Did you include the tokens required in the manifest.aegis file in the dir qtc_packaging/debian_harmattan ?

    Also, please check if you have passed the correct parameters for Exec in .desktop file.

    http://www.developer.nokia.com/Commu...tiple+instance
    Last edited by kusumk; 2012-01-23 at 04:52. Reason: some more info

  3. #3
    Registered User
    Join Date
    Nov 2010
    Location
    Finland
    Posts
    91

    Re: GPS and GalleryViewer works when launched via QtCreator,not when opened from phon

    Quote Originally Posted by kusumk View Post
    Hi,

    Did you include the tokens required in the manifest.aegis file in the dir qtc_packaging/debian_harmattan ?

    Also, please check if you have passed the correct parameters for Exec in .desktop file.

    http://www.developer.nokia.com/Commu...tiple+instance
    No I didn't include any tokens, haven't heard about those before? What should I add?

  4. #4
    Registered User
    Join Date
    Sep 2011
    Posts
    449

    Re: GPS and GalleryViewer works when launched via QtCreator,not when opened from phon

    Hi,

    Please check -

    http://www.developer.nokia.com/Commu...ecurity_Tokens

    You wil have to add the tokens related to Location in your manifest.aegis file.

    syntax as per -

    http://harmattan-dev.nokia.com/docs/...st_syntax.html

  5. #5
    Registered User
    Join Date
    Nov 2010
    Location
    Finland
    Posts
    91

    Re: GPS and GalleryViewer works when launched via QtCreator,not when opened from phon

    Quote Originally Posted by kusumk View Post
    Hi,

    Please check -

    http://www.developer.nokia.com/Commu...ecurity_Tokens

    You wil have to add the tokens related to Location in your manifest.aegis file.

    syntax as per -

    http://harmattan-dev.nokia.com/docs/...st_syntax.html
    Thanks, I will try those and report the outcome later today.
    But the weird thing is that I have got that work before, and have never added those things.. and why does it work when run trough QtCreator?

  6. #6
    Registered User
    Join Date
    Sep 2011
    Posts
    449

    Re: GPS and GalleryViewer works when launched via QtCreator,not when opened from phon

    Hi,

    When you run through QT Creator you would be running in developer mode. You can see that in qtcreator -> options -> Linux devices -> You would set the user as developer.

    When you run it from device, it is run with user permissions. Aegis tokens are required when you run as user for security purposes.

  7. #7
    Super Contributor
    Join Date
    Mar 2009
    Posts
    1,024

    Re: GPS and GalleryViewer works when launched via QtCreator,not when opened from phon

    Quote Originally Posted by jkosonen View Post
    Thanks, I will try those and report the outcome later today.
    But the weird thing is that I have got that work before, and have never added those things.. and why does it work when run trough QtCreator?
    this is explained here
    http://www.developer.nokia.com/Commu...ecurity_Tokens

  8. #8
    Registered User
    Join Date
    Nov 2010
    Location
    Finland
    Posts
    91

    Re: GPS and GalleryViewer works when launched via QtCreator,not when opened from phon

    For some reason it still doesn't seem to work when started from phone
    Currently it is:

    <aegis>
    <request policy="add">

    <credential name="TrackerReadAccess" />
    <credential name="TrackerWriteAccess" />
    <credential name="Location" />
    <credential name="GRP:ulse-access" />
    <credential name="GRP::video" />
    <credential name="GRP::audio" />
    </request>

    <for path="/opt/usr/bin/file" />
    <for path="applauncherd-launcher::/usr/bin/applauncherd.bin" id="" />
    </aegis>
    Last edited by jkosonen; 2012-01-23 at 15:41.

  9. #9
    Registered User
    Join Date
    Nov 2010
    Location
    Finland
    Posts
    91

    Re: GPS and GalleryViewer works when launched via QtCreator,not when opened from phon

    Got it to work tweaking the aegis. Thanks a much!
    Last edited by jkosonen; 2012-01-23 at 16:47.

  10. #10
    Super Contributor
    Join Date
    Mar 2009
    Posts
    1,024

    Re: GPS and GalleryViewer works when launched via QtCreator,not when opened from phon

    Hi,
    You can use: accli -p <PID> -I

    Reference and more info:
    http://harmattan-dev.nokia.com/docs/...urity_FAQ.html

Similar Threads

  1. Replies: 7
    Last Post: 2011-12-02, 14:56
  2. Check if slider phone is opened
    By microsoft2 in forum Symbian
    Replies: 3
    Last Post: 2011-01-29, 08:48
  3. swf works fine untill packaged in a sis and launched from icon
    By sgone in forum [Archived] Flash Lite on Nokia Devices
    Replies: 9
    Last Post: 2010-09-04, 09:57
  4. Event for phone opened / closed
    By Agent_BK in forum Symbian
    Replies: 2
    Last Post: 2010-06-23, 19:46
  5. Replies: 1
    Last Post: 2009-10-12, 12:48

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×